Uploaded image for project: 'Apache Hop (incubating)'
  1. Apache Hop (incubating)
  2. HOP-1605

API should use boolean "isXXXX()" getter naming convention

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Open
    • Priority: Low
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Database

      Description

      JavaBean naming convention is to use isXXXX() for boolean fields.

      It's good timing to rename methods in DatabaseInterface:

      public boolean supportsViews(); -> public boolean isSupportsViews();
      public boolean supportsSynonyms(); -> public boolean isSupportsSynonyms();

      or

      public boolean supportsViews(); -> public boolean isSupportView();
      public boolean supportsSynonyms(); -> public boolean isSupportSynonym();

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              mxm Maximilian Michels
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: