Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.14.0
    • Fix Version/s: 1.1.0
    • Component/s: None
    • Labels:
      None

      Description

      TestStreaming seems to fail in one of its tests or another about 1 in 50 times.

        Activity

        alangates Alan Gates added a comment -

        A patch that checks for deadlocks during table creation in unit tests.

        hiveqa Hive QA added a comment -

        Overall: -1 at least one tests failed

        Here are the results of testing the latest attachment:
        https://issues.apache.org/jira/secure/attachment/12683007/HIVE-8948.patch

        ERROR: -1 due to 1 failed/errored test(s), 6681 tests executed
        Failed tests:

        org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_optimize_nullscan
        

        Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1884/testReport
        Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1884/console
        Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-1884/

        Messages:

        Executing org.apache.hive.ptest.execution.PrepPhase
        Executing org.apache.hive.ptest.execution.ExecutionPhase
        Executing org.apache.hive.ptest.execution.ReportingPhase
        Tests exited with: TestsFailedException: 1 tests failed
        

        This message is automatically generated.

        ATTACHMENT ID: 12683007 - PreCommit-HIVE-TRUNK-Build

        ekoifman Eugene Koifman added a comment -

        Alan Gates I thought prepDb() is only used for embedded Derby. How does this end up with a deadlock?

        alangates Alan Gates added a comment -

        prepDb is only used by Derby, and I don't know how it deadlocks. But I can see it do it, about 1 run in 50, only on Linux (I can't reproduce it on Mac).

        ekoifman Eugene Koifman added a comment -

        +1

        alangates Alan Gates added a comment -

        Patch checked in. Thanks Eugene for the review.


          People

          • Assignee:
            alangates Alan Gates
            Reporter:
            alangates Alan Gates
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development