Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-8898

Remove HIVE-8874 once HBASE-12493 is fixed

    Details

    • Type: Task
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2.0
    • Component/s: HBase Handler
    • Labels:
      None

      Issue Links

        Activity

        swarnim Swarnim Kulkarni added a comment -

        I logged a JIRA here[1] to revert the work done.

        [1] https://issues.apache.org/jira/browse/HIVE-11559

        swarnim Swarnim Kulkarni added a comment -

        Damn lol. [1] is the JIRA. I did dig into it a bit more and commented on it and seems like the regression might not be as bad as I thought it would be. Regardless I am still of the opinion of reverting this and moving this over to 2.x.

        [1] https://issues.apache.org/jira/browse/HIVE-10990

        sershe Sergey Shelukhin added a comment -

        This links to itself. What is the JIRA for regression?

        swarnim Swarnim Kulkarni added a comment -

        It seems like we might have introduced a regression[1] with this patch. I am digging into what might have caused this and how we can fix this.

        [1] https://issues.apache.org/jira/browse/HIVE-8898

        sershe Sergey Shelukhin added a comment -

        That makes sense... Brock Noland Yongzhi Chen what do you think?

        swarnim Swarnim Kulkarni added a comment -

        Sergey Shelukhin Good point! I think the hive dependency on hbase is a little fuzzy right now to say the least. Since this is committed on the 1.x branch currently, how about we rollback this change from here and push this change onto the 2.x branch? In this way we still maintain the backwards compatibility from our old code and still upgrade to use the new one in our "bleeding edge" branch?

        sershe Sergey Shelukhin added a comment -

        Are you sure this is a good idea? Hive can still run against an older version of HBase

        sushanth Sushanth Sowmyan added a comment -

        This issue has been fixed and released as part of the 1.2.0 release. If you find an issue which seems to be related to this one, please create a new jira and link this one with new jira.

        csun Chao Sun added a comment -

        Committed to trunk. Thanks Yongzhi!

        brocknoland Brock Noland added a comment -

        +1

        ychena Yongzhi Chen added a comment -

        This fix is using hbase version 0.98.9 instead of 0.98.3 in order to use the new functions.

        ychena Yongzhi Chen added a comment -

        Brock Noland could you review the code?

        Thanks

        ychena Yongzhi Chen added a comment -

        The test failure has nothing to do with the change. It is avro tests, but all the code changes are only relevant to hbase.

        hiveqa Hive QA added a comment -

        Overall: -1 at least one tests failed

        Here are the results of testing the latest attachment:
        https://issues.apache.org/jira/secure/attachment/12701452/HIVE-8898.1.patch

        ERROR: -1 due to 1 failed/errored test(s), 7561 tests executed
        Failed tests:

        TestSparkCliDriver-parallel_join1.q-ptf_general_queries.q-avro_joins.q-and-12-more - did not produce a TEST-*.xml file
        

        Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/2906/testReport
        Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/2906/console
        Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-2906/

        Messages:

        Executing org.apache.hive.ptest.execution.PrepPhase
        Executing org.apache.hive.ptest.execution.ExecutionPhase
        Executing org.apache.hive.ptest.execution.ReportingPhase
        Tests exited with: TestsFailedException: 1 tests failed
        

        This message is automatically generated.

        ATTACHMENT ID: 12701452 - PreCommit-HIVE-TRUNK-Build

        ychena Yongzhi Chen added a comment -

        Need code review.

        brocknoland Brock Noland added a comment -

        Marking blocker for 0.15 to keep awareness.


          People

          • Assignee:
            ychena Yongzhi Chen
            Reporter:
            brocknoland Brock Noland
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development