Hive
  1. Hive
  2. HIVE-7459

Fix NPE when an empty file is included in a Hive query that uses CombineHiveInputFormat

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.14.0
    • Component/s: None
    • Labels:
      None

      Issue Links

        Activity

        Thejas M Nair added a comment -

        This has been fixed in 0.14 release. Please open new jira if you see any issues.

        Brock Noland added a comment -

        Thank you to Matt Martin for the fix and Ryan Blue for the rebase to trunk! I have committed this to trunk.

        Brock Noland added a comment -

        +1

        They are flaky...

        6000 tests * (1/10 of 1% probability of failing) = 6 tests.

        Ryan Blue added a comment -

        I don't think there's much chance that those test failures were caused by the patch because it is so small. Is it normal to have test failures in trunk?

        Hive QA added a comment -

        Overall: -1 at least one tests failed

        Here are the results of testing the latest attachment:
        https://issues.apache.org/jira/secure/attachment/12657966/HIVE-7459.patch

        ERROR: -1 due to 4 failed/errored test(s), 5781 tests executed
        Failed tests:

        org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_tez_join_hash
        org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_ql_rewrite_gbtoidx
        org.apache.hadoop.hive.cli.TestNegativeMinimrCliDriver.testNegativeCliDriver_cluster_tasklog_retrieval
        org.apache.hive.hcatalog.pig.TestHCatLoader.testReadDataPrimitiveTypes
        

        Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/66/testReport
        Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/66/console
        Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-66/

        Messages:

        Executing org.apache.hive.ptest.execution.PrepPhase
        Executing org.apache.hive.ptest.execution.ExecutionPhase
        Executing org.apache.hive.ptest.execution.ReportingPhase
        Tests exited with: TestsFailedException: 4 tests failed
        

        This message is automatically generated.

        ATTACHMENT ID: 12657966

        Brock Noland added a comment -

        Thank you Ryan! I am re-uploading the patch so automated testing picks it up.

        Ryan Blue added a comment -

        Matt Martin's patch, applied to the current trunk.


          People

          • Assignee:
            Ryan Blue
            Reporter:
            Brock Noland
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development