Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-7270

SerDe Properties are not considered by show create table Command

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.13.1
    • Fix Version/s: 1.0.0
    • Component/s: CLI
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The HIVE table DDl generated by show create table <target_table> command does not contain SerDe properties of the target table even though it contain specific SerDe properties.

      1. HIVE-7270.1.patch.txt
        15 kB
        Navis
      2. HIVE-7270.2.patch.txt
        15 kB
        Navis
      3. HIVE-7270.3.patch.txt
        15 kB
        Navis

        Issue Links

          Activity

          hiveqa Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12651932/HIVE-7270.1.patch.txt

          ERROR: -1 due to 2 failed/errored test(s), 5669 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_root_dir_external_table
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_authorization_ctas
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-Build/564/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-Build/564/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-Build-564/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 2 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12651932

          jdere Jason Dere added a comment -

          +1. Is the failure in authorization_ctas related to the patch?

          navis Navis added a comment -

          I've missed this. Sorry, Jason Dere.
          authorization_ctas.q seemed not related to this and it's not reproduce in local env. Attaching the same patch for running ptest.

          hiveqa Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12677270/HIVE-7270.2.patch.txt

          ERROR: -1 due to 1 failed/errored test(s), 6578 tests executed
          Failed tests:

          org.apache.hive.minikdc.TestJdbcWithMiniKdc.testNegativeTokenAuth
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1471/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1471/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-1471/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 1 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12677270 - PreCommit-HIVE-TRUNK-Build

          jdere Jason Dere added a comment -

          Looks like the tests have passed, Navis you can commit at your convenience.

          navis Navis added a comment -

          Jason Dere Sorry, I've missed your comment. Pending for test.

          hiveqa Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12686797/HIVE-7270.3.patch.txt

          ERROR: -1 due to 1 failed/errored test(s), 6701 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_optimize_nullscan
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/2063/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/2063/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-2063/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 1 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12686797 - PreCommit-HIVE-TRUNK-Build

          navis Navis added a comment -

          Committed to trunk

          jdere Jason Dere added a comment -

          Would like to add this to 0.14.1/1.0 branch

          vikram.dixit Vikram Dixit K added a comment -

          +1. Go ahead with the branch commits.

          jdere Jason Dere added a comment -

          Committed to 0.14/1.0 branches

          thejas Thejas M Nair added a comment -

          Updating release version for jiras resolved in 1.0.0 .

          thejas Thejas M Nair added a comment -

          This issue has been fixed in Apache Hive 1.0.0. If there is any issue with the fix, please open a new jira to address it.


            People

            • Assignee:
              navis Navis
              Reporter:
              renil.joseph R J
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development