Hive
  1. Hive
  2. HIVE-7127

Handover more details on exception in hiveserver2

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.14.0
    • Component/s: JDBC
    • Labels:
      None

      Description

      Currently, JDBC hands over exception message and error codes. But it's not helpful for debugging.

      org.apache.hive.service.cli.HiveSQLException: Error while compiling statement: FAILED: ParseException line 1:0 cannot recognize input near 'createa' 'asd' '<EOF>'
      	at org.apache.hive.jdbc.Utils.verifySuccess(Utils.java:121)
      	at org.apache.hive.jdbc.Utils.verifySuccessWithInfo(Utils.java:109)
      	at org.apache.hive.jdbc.HiveStatement.execute(HiveStatement.java:231)
      	at org.apache.hive.beeline.Commands.execute(Commands.java:736)
      	at org.apache.hive.beeline.Commands.sql(Commands.java:657)
      	at org.apache.hive.beeline.BeeLine.dispatch(BeeLine.java:889)
      	at org.apache.hive.beeline.BeeLine.begin(BeeLine.java:744)
      	at org.apache.hive.beeline.BeeLine.mainWithInputRedirection(BeeLine.java:459)
      	at org.apache.hive.beeline.BeeLine.main(BeeLine.java:442)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at org.apache.hadoop.util.RunJar.main(RunJar.java:160)
      

      With this patch, JDBC client can get more details on hiveserver2.

      Caused by: org.apache.hive.service.cli.HiveSQLException: Error while compiling statement: FAILED: ParseException line 1:0 cannot recognize input near 'createa' 'asd' '<EOF>'
      	at org.apache.hive.service.cli.operation.SQLOperation.prepare(Unknown Source)
      	at org.apache.hive.service.cli.operation.SQLOperation.run(Unknown Source)
      	at org.apache.hive.service.cli.session.HiveSessionImpl.executeStatementInternal(Unknown Source)
      	at org.apache.hive.service.cli.session.HiveSessionImpl.executeStatementAsync(Unknown Source)
      	at org.apache.hive.service.cli.CLIService.executeStatementAsync(Unknown Source)
      	at org.apache.hive.service.cli.thrift.ThriftCLIService.ExecuteStatement(Unknown Source)
      	at org.apache.hive.service.cli.thrift.TCLIService$Processor$ExecuteStatement.getResult(Unknown Source)
      	at org.apache.hive.service.cli.thrift.TCLIService$Processor$ExecuteStatement.getResult(Unknown Source)
      	at org.apache.thrift.ProcessFunction.process(Unknown Source)
      	at org.apache.thrift.TBaseProcessor.process(Unknown Source)
      	at org.apache.hive.service.auth.TSetIpAddressProcessor.process(Unknown Source)
      	at org.apache.thrift.server.TThreadPoolServer$WorkerProcess.run(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at java.lang.Thread.run(Unknown Source)
      
      1. HIVE-7127.5.patch.txt
        18 kB
        Navis
      2. HIVE-7127.4.patch.txt
        18 kB
        Navis
      3. HIVE-7127.2.patch.txt
        8 kB
        Navis
      4. HIVE-7127.1.patch.txt
        11 kB
        Navis

        Issue Links

          Activity

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12646847/HIVE-7127.1.patch.txt

          ERROR: -1 due to 10 failed/errored test(s), 5467 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_combine2
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_parquet_decimal1
          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_root_dir_external_table
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_authorization_ctas
          org.apache.hadoop.hive.ql.exec.tez.TestTezTask.testSubmit
          org.apache.hive.beeline.TestBeelineArgParsing.testBeelineOpts
          org.apache.hive.hcatalog.pig.TestOrcHCatPigStorer.testWriteDecimal
          org.apache.hive.hcatalog.pig.TestOrcHCatPigStorer.testWriteDecimalX
          org.apache.hive.hcatalog.pig.TestOrcHCatPigStorer.testWriteDecimalXY
          org.apache.hive.jdbc.TestJdbcDriver2.testErrorMessages
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-Build/314/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-Build/314/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-Build-314/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 10 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12646847

          Szehon Ho added a comment -

          Thanks for this change, I left some comments on the rb

          Szehon Ho added a comment -

          +1 (non-binding) Thanks for that.

          Also I'm changing the exact syntax to be "NO PRECOMMIT TESTS" for build to skip it. It is searching for exact string

          Navis added a comment -

          Ah, Thanks.

          Navis added a comment -

          set cause for sql exception if underlying exception is available.

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12647053/HIVE-7127.2.patch.txt

          ERROR: -1 due to 10 failed/errored test(s), 5467 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_join18_multi_distinct
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_parquet_decimal1
          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_root_dir_external_table
          org.apache.hadoop.hive.cli.TestNegativeCliDriver.testNegativeCliDriver_authorization_ctas
          org.apache.hadoop.hive.common.metrics.TestMetrics.testScopeConcurrency
          org.apache.hadoop.hive.ql.exec.tez.TestTezTask.testSubmit
          org.apache.hive.hcatalog.pig.TestHCatLoader.testReadDataPrimitiveTypes
          org.apache.hive.hcatalog.pig.TestOrcHCatPigStorer.testWriteDecimal
          org.apache.hive.hcatalog.pig.TestOrcHCatPigStorer.testWriteDecimalX
          org.apache.hive.hcatalog.pig.TestOrcHCatPigStorer.testWriteDecimalXY
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-Build/324/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-Build/324/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-Build-324/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 10 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12647053

          Navis added a comment -

          Szehon Ho Now you are a committer (congratulation!) and I think it's ok to regard your +1 as binding one. Running test again.

          Szehon Ho added a comment -

          Thanks a lot, Navis!

          Sure, can you please also update the review board with latest patch, seems there are some more changes in Driver that didn't get into that.

          Navis added a comment -

          Updated review board entry and kicked test manually.

          Szehon Ho added a comment -

          Thanks, +1 pending test

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12652341/HIVE-7127.5.patch.txt

          ERROR: -1 due to 1 failed/errored test(s), 5657 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_root_dir_external_table
          

          Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-Build/649/testReport
          Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-Build/649/console
          Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-Build-649/

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 1 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12652341

          Navis added a comment -

          Committed to trunk. Thanks Szehon Ho, for the review!

          Thejas M Nair added a comment -

          This has been fixed in 0.14 release. Please open new jira if you see any issues.


            People

            • Assignee:
              Navis
              Reporter:
              Navis
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development