Hive
  1. Hive
  2. HIVE-6410

Allow output serializations separators to be set for HDFS path as well.

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 0.14.0
    • Component/s: Query Processor
    • Labels:
      None

      Description

      HIVE-3682 adds functionality for users to set serialization constants for 'insert overwrite local directory'. The same functionality should be available for hdfs path as well. The workaround suggested is to create a table with required format and insert into the table, which enforces the users to know the schema of the result and create the table ahead. Though that works, it is good to have the functionality for loading into directory as well.

      I'm planning to add the same functionality in 'insert overwrite directory' in this jira.

      1. HIVE-6410.patch
        43 kB
        Amareshwari Sriramadasu

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Patch Available Patch Available Open Open
          4d 21h 49m 1 Amareshwari Sriramadasu 18/Feb/14 04:26
          Open Open Patch Available Patch Available
          1d 1h 38m 2 Amareshwari Sriramadasu 18/Feb/14 04:26
          Patch Available Patch Available Resolved Resolved
          238d 9h 8m 1 Xuefu Zhang 14/Oct/14 14:35
          Resolved Resolved Closed Closed
          30d 6h 8m 1 Thejas M Nair 13/Nov/14 19:44
          Nemon Lou added a comment -

          Amareshwari SriramadasuDo you mind uploading this patch to HIVE-5672?
          I have tried hive 1.0, this bug still exists.

          Thejas M Nair made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Thejas M Nair added a comment -

          This has been fixed in 0.14 release. Please open new jira if you see any issues.

          Xuefu Zhang made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Xuefu Zhang added a comment - - edited

          Close this one as dupe of HIVE-5672 to avoid confusion.

          Navis made changes -
          Fix Version/s 0.14.0 [ 12326450 ]
          Fix Version/s 0.13.0 [ 12324986 ]
          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12628684/HIVE-6410.patch

          ERROR: -1 due to 1 failed/errored test(s), 5556 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_insert_overwrite_directory
          

          Test results: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/2192/testReport
          Console output: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/2192/console

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 1 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12628684

          Xuefu Zhang made changes -
          Link This issue is duplicated by HIVE-6833 [ HIVE-6833 ]
          Xuefu Zhang added a comment -

          Though closing either one of the dupes is fine, HIVE-5672 has the history of discussions, which provides background for code reviewers.

          Amareshwari Sriramadasu made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Fix Version/s 0.13.0 [ 12324986 ]
          Amareshwari Sriramadasu made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Amareshwari Sriramadasu added a comment -

          Resubmitting for tests to run

          Amareshwari Sriramadasu added a comment -

          Xuefu Wang, had the patch ready, so uploaded. I don't mind any of them being closed as duplicate of other, as long as code gets in.

          Amareshwari Sriramadasu made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Amareshwari Sriramadasu made changes -
          Attachment HIVE-6410.patch [ 12628684 ]
          Amareshwari Sriramadasu added a comment -

          Attaching the patch with fix. The changes include :

          • Grammar changes for accepting table format and row format for 'insert overwrite directory'.
          • Fixed existing code to accept serde properties as well.
          • Added insert_overwrite_directory.q

          Review board request - https://reviews.apache.org/r/18060/

          Xuefu Zhang made changes -
          Link This issue duplicates HIVE-5672 [ HIVE-5672 ]
          Xuefu Zhang added a comment -

          Obviously, this is a dupe of https://issues.apache.org/jira/browse/HIVE-5672. Please close this one and take HIVE-5672 instead. Thanks.

          Amareshwari Sriramadasu made changes -
          Field Original Value New Value
          Link This issue relates to HIVE-3682 [ HIVE-3682 ]
          Amareshwari Sriramadasu created issue -

            People

            • Assignee:
              Amareshwari Sriramadasu
              Reporter:
              Amareshwari Sriramadasu
            • Votes:
              1 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development