Details

    1. HIVE-6345.5.patch
      202 kB
      Remus Rusanu
    2. HIVE-6345.4.patch
      204 kB
      Remus Rusanu
    3. HIVE-6345.3.patch
      204 kB
      Jitendra Nath Pandey
    4. HIVE-6345.3.patch
      204 kB
      Remus Rusanu
    5. HIVE-6345.2.patch
      188 kB
      Remus Rusanu

      Activity

      Remus Rusanu created issue -
      Remus Rusanu made changes -
      Field Original Value New Value
      Attachment HIVE-6345.2.patch [ 12628474 ]
      Remus Rusanu added a comment -

      The patch contains the fix for HIVE-6344 as well, including review feedback.
      This patch added fast cast (allocation free) between HiveDecimalWritable and Decimal128 (both to and from).
      It also includes the negative constant folding fix sent to me by Jitendra in a patch.
      I could not fix Vectorized SMB join on decimals because of HIVE-6412

      Jitendra Nath Pandey added a comment -

      There are a few tab characters in the patch.
      The patch looks good to me otherwise. +1

      Remus Rusanu made changes -
      Attachment HIVE-6345.3.patch [ 12628704 ]
      Remus Rusanu made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Remus Rusanu added a comment -

      New patch removes all tabs and trailing spaces, adds missing Apache header.

      Remus Rusanu made changes -
      Labels vectorization
      Remus Rusanu made changes -
      Component/s Query Processor [ 12312586 ]
      Jitendra Nath Pandey made changes -
      Status Patch Available [ 10002 ] Open [ 1 ]
      Jitendra Nath Pandey added a comment -

      Uploading the same patch to trigger the jenkins build.

      Jitendra Nath Pandey made changes -
      Attachment HIVE-6345.3.patch [ 12629212 ]
      Jitendra Nath Pandey made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Hive QA added a comment -

      Overall: -1 at least one tests failed

      Here are the results of testing the latest attachment:
      https://issues.apache.org/jira/secure/attachment/12629212/HIVE-6345.3.patch

      ERROR: -1 due to 5 failed/errored test(s), 5134 tests executed
      Failed tests:

      org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_orc_vectorization_ppd
      org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_vector_decimal_aggregate
      org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_vector_decimal_mapjoin
      org.apache.hadoop.hive.ql.exec.vector.TestVectorizationContext.testBetweenFilters
      org.apache.hadoop.hive.ql.exec.vector.TestVectorizationContext.testInFiltersAndExprs
      

      Test results: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1347/testReport
      Console output: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1347/console

      Messages:

      Executing org.apache.hive.ptest.execution.PrepPhase
      Executing org.apache.hive.ptest.execution.ExecutionPhase
      Executing org.apache.hive.ptest.execution.ReportingPhase
      Tests exited with: TestsFailedException: 5 tests failed
      

      This message is automatically generated.

      ATTACHMENT ID: 12629212

      Remus Rusanu added a comment -

      Rebase after HIVE-5759 changes. Changes expected .out files with Linux generated ones (diff in EXPLAIN statistics).

      Remus Rusanu made changes -
      Attachment HIVE-6345.4.patch [ 12629387 ]
      Remus Rusanu made changes -
      Status Patch Available [ 10002 ] Open [ 1 ]
      Remus Rusanu made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Hive QA added a comment -

      Overall: -1 at least one tests failed

      Here are the results of testing the latest attachment:
      https://issues.apache.org/jira/secure/attachment/12629387/HIVE-6345.4.patch

      ERROR: -1 due to 5 failed/errored test(s), 5142 tests executed
      Failed tests:

      org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_orc_vectorization_ppd
      org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_bucketmapjoin6
      org.apache.hadoop.hive.ql.exec.vector.TestVectorizationContext.testBetweenFilters
      org.apache.hadoop.hive.ql.exec.vector.TestVectorizationContext.testInFiltersAndExprs
      org.apache.hadoop.hive.ql.security.TestStorageBasedClientSideAuthorizationProvider.testSimplePrivileges
      

      Test results: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1371/testReport
      Console output: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1371/console

      Messages:

      Executing org.apache.hive.ptest.execution.PrepPhase
      Executing org.apache.hive.ptest.execution.ExecutionPhase
      Executing org.apache.hive.ptest.execution.ReportingPhase
      Tests exited with: TestsFailedException: 5 tests failed
      

      This message is automatically generated.

      ATTACHMENT ID: 12629387

      Remus Rusanu added a comment -

      the current .4 patch has a merge mistake and introduces regressions. Will update shortly.

      Remus Rusanu made changes -
      Status Patch Available [ 10002 ] Open [ 1 ]
      Remus Rusanu made changes -
      Attachment HIVE-6345.5.patch [ 12629743 ]
      Remus Rusanu made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Remus Rusanu added a comment -

      Patch .5 fixes the regression cases

      Hive QA added a comment -

      Overall: +1 all checks pass

      Here are the results of testing the latest attachment:
      https://issues.apache.org/jira/secure/attachment/12629743/HIVE-6345.5.patch

      SUCCESS: +1 5147 tests passed

      Test results: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1411/testReport
      Console output: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1411/console

      Messages:

      Executing org.apache.hive.ptest.execution.PrepPhase
      Executing org.apache.hive.ptest.execution.ExecutionPhase
      Executing org.apache.hive.ptest.execution.ReportingPhase
      

      This message is automatically generated.

      ATTACHMENT ID: 12629743

      Jitendra Nath Pandey made changes -
      Status Patch Available [ 10002 ] Resolved [ 5 ]
      Release Note Committed to trunk. Thanks to Remus!!
      Resolution Fixed [ 1 ]
      Jitendra Nath Pandey made changes -
      Release Note Committed to trunk. Thanks to Remus!!
      Jitendra Nath Pandey made changes -
      Fix Version/s 0.13.0 [ 12324986 ]
      Jitendra Nath Pandey added a comment -

      Committed to trunk. Thanks to Remus!!

      Transition Time In Source Status Execution Times Last Executer Last Execution Date
      Patch Available Patch Available Open Open
      6d 1h 46m 3 Remus Rusanu 19/Feb/14 10:58
      Open Open Patch Available Patch Available
      12d 13h 52m 4 Remus Rusanu 19/Feb/14 11:20
      Patch Available Patch Available Resolved Resolved
      6h 24m 1 Jitendra Nath Pandey 19/Feb/14 17:44

        People

        • Assignee:
          Remus Rusanu
          Reporter:
          Remus Rusanu
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development