Hive
  1. Hive
  2. HIVE-6246

Sign(a) UDF is not supported for decimal type

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.12.0
    • Fix Version/s: 0.13.0
    • Component/s: UDF
    • Labels:
      None

      Description

      java.sql.SQLException: Error while compiling statement: FAILED: SemanticException [Error 10014]: Line 1:86 Wrong arguments 'a': No matching method for class org.apache.hadoop.hive.ql.udf.UDFSign with (decimal(38,10)). Possible choices: FUNC(double)

      1. HIVE-6246.patch
        4 kB
        Xuefu Zhang
      2. HIVE-6246.1.patch
        2 kB
        Xuefu Zhang
      3. HIVE-6246.1.patch
        4 kB
        Xuefu Zhang

        Issue Links

          Activity

          Xuefu Zhang added a comment -

          Wiki is updated, listing sign as one of supported functions for decimal.

          Xuefu Zhang added a comment -

          Patch committed to trunk. Thanks to Prasad for the review.
          Wiki will be updated accordingly.

          Prasad Mujumdar added a comment -

          +1

          Lefty Leverenz added a comment -

          When this is committed, it needs to be documented in the wiki here: Mathematical UDFs – just add sign(a) to the list.

          Xuefu Zhang added a comment -

          Above failures are related to HIVE-6310, having nothing to do with the patch here.

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12625450/HIVE-6246.1.patch

          ERROR: -1 due to 3 failed/errored test(s), 4962 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_import_exported_table
          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_load_hdfs_file_with_space_in_the_name
          org.apache.hadoop.hive.cli.TestNegativeMinimrCliDriver.testNegativeCliDriver_file_with_header_footer_negative
          

          Test results: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1052/testReport
          Console output: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1052/console

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 3 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12625450

          Xuefu Zhang added a comment -

          Patch #1 has no real code changes: comments and method name.

          Swarnim Kulkarni added a comment -

          Non committer +1

          Mohammad Kamrul Islam added a comment -

          Left comments in RB.

          Xuefu Zhang added a comment -
          Xuefu Zhang added a comment -

          It looks like that the above reported failures are not caused by this patch, as they are failing in other pre-commit test runs.

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12624861/HIVE-6246.patch

          ERROR: -1 due to 7 failed/errored test(s), 4950 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_annotate_stats_filter
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_annotate_stats_groupby
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_annotate_stats_join
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_annotate_stats_part
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_annotate_stats_select
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_annotate_stats_table
          org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_annotate_stats_union
          

          Test results: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1001/testReport
          Console output: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1001/console

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 7 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12624861


            People

            • Assignee:
              Xuefu Zhang
              Reporter:
              Xuefu Zhang
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development