Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-5107 Change hive's build to maven
  3. HIVE-5897

Fix hadoop2 execution environment Milestone 2

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.13.0
    • Component/s: None
    • Labels:
      None

      Description

      Follow on to HIVE-5755.

      List of known issues:

      hcatalog-pig-adapter and ql need

               <dependency>
                 <groupId>org.apache.hadoop</groupId>
                 <artifactId>hadoop-mapreduce-client-common</artifactId>
                 <version>${hadoop-23.version}</version>
                 <scope>test</scope>
              </dependency>
      

      hcatalog core and hbase storage handler needs

               <dependency>
                 <groupId>org.apache.hadoop</groupId>
                <artifactId>hadoop-common</artifactId>
                <version>${hadoop-23.version}</version>
                <classifier>tests</classifier>
                <scope>test</scope>
              </dependency>
              <dependency>
                <groupId>org.apache.hadoop</groupId>
                <artifactId>hadoop-mapreduce-client-hs</artifactId>
                <version>${hadoop-23.version}</version>
                <scope>test</scope>
              </dependency>
             <dependency>
               <groupId>org.apache.hadoop</groupId>
               <artifactId>hadoop-yarn-server-tests</artifactId>
               <version>${hadoop-23.version}</version>
               <classifier>tests</classifier>
               <scope>test</scope>
             </dependency>
      

      hcatalog core needs:

             <dependency>
                <groupId>org.apache.hadoop</groupId>
                <artifactId>hadoop-mapreduce-client-jobclient</artifactId>
                <version>${hadoop-23.version}</version>
                <scope>test</scope>
              </dependency>
      

      beeline needs

              <dependency>
                <groupId>org.apache.hadoop</groupId>
                <artifactId>hadoop-mapreduce-client-core</artifactId>
                <version>${hadoop-23.version}</version>
                <scope>test</scope>
              </dependency>
      

        Attachments

        1. HIVE-5897.5.patch
          12 kB
          Vikram Dixit K
        2. HIVE-5897.4.patch
          12 kB
          Vikram Dixit K
        3. HIVE-5897.patch
          5 kB
          Brock Noland
        4. HIVE-5897.patch
          5 kB
          Brock Noland
        5. HIVE-5897.patch
          5 kB
          Brock Noland

          Issue Links

            Activity

              People

              • Assignee:
                vikram.dixit Vikram Dixit K
                Reporter:
                brocknoland Brock Noland
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: