Hive
  1. Hive
  2. HIVE-5814

Add DATE, TIMESTAMP, DECIMAL, CHAR, VARCHAR types support in HCat

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.12.0
    • Fix Version/s: 0.13.0
    • Component/s: HCatalog
    • Labels:
      None

      Description

      Hive 0.12 added support for new data types. Pig 0.12 added some as well. HCat should handle these as well. Also note that CHAR was added recently.

      Also allow user to specify a parameter in Pig like so HCatStorer('','', '-onOutOfRangeValue Throw') to control what happens when Pig's value is out of range for target Hive column. Valid values for the option are Throw and Null. Throw - make the runtime raise an exception, Null, which is the default, means NULL is written to target column and a message to that effect is emitted to the log. Only 1 message per column/data type is sent to the log.

      See attached HCat-Pig Type Mapping Hive 0.13.pdf for exact mappings.

      1. HCat-Pig Type Mapping Hive 0.13.pdf
        48 kB
        Eugene Koifman
      2. HIVE-5814.2.patch
        110 kB
        Eugene Koifman
      3. HIVE-5814.3.patch
        140 kB
        Eugene Koifman
      4. HIVE-5814.4.patch
        140 kB
        Eugene Koifman
      5. HIVE-5814.5.patch
        141 kB
        Eugene Koifman

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Patch Available Patch Available Open Open
          10d 20h 35m 6 Eugene Koifman 31/Jan/14 18:42
          Open Open Patch Available Patch Available
          68d 3h 10m 7 Eugene Koifman 31/Jan/14 18:43
          Patch Available Patch Available Resolved Resolved
          5d 2h 21m 1 Sushanth Sowmyan 05/Feb/14 21:04
          Eugene Koifman added a comment -

          org.apache.hcatalog.pig.HCatLoader has been deprecated in Hive 0.12.
          In fact every class in org.apache.hcatalog has been deprecated. All new features are added in org.apache.hive.hcatalog which contains all the classes/methods from org.apache.hcatalog and new APIs.

          Erik Putrycz added a comment -

          I have Hortonworks 2.1, and a hive table with Timestamp fields fails with HCat:

          a = LOAD 'myTable2' using org.apache.hcatalog.pig.HCatLoader();
          b = limit a 10;
          dump b;
          
          CREATE TABLE myTable2( Barcode_Item_ID STRING,
          Process_Date_UTC TIMESTAMP,
          Process_TimeUTC TIMESTAMP)
          STORED AS orc
          

          I replaced the JARs bundled with Hortonworks with the official 0.13 ones, and no change.
          According to the PDF document, the TIMESTAMP field should be mapped but here is the exception I get:

          2014-04-28 15:32:54,864 [main] ERROR org.apache.pig.PigServer - exception during parsing: Error during parsing. Type timestamp not present
          Failed to parse: Type timestamp not present
          	at org.apache.pig.parser.QueryParserDriver.parse(QueryParserDriver.java:198)
          	at org.apache.pig.PigServer$Graph.parseQuery(PigServer.java:1676)
          	at org.apache.pig.PigServer$Graph.access$000(PigServer.java:1409)
          	at org.apache.pig.PigServer.parseAndBuild(PigServer.java:342)
          	at org.apache.pig.PigServer.executeBatch(PigServer.java:367)
          	at org.apache.pig.PigServer.executeBatch(PigServer.java:353)
          	at org.apache.pig.tools.grunt.GruntParser.executeBatch(GruntParser.java:140)
          	at org.apache.pig.tools.grunt.GruntParser.processDump(GruntParser.java:769)
          	at org.apache.pig.tools.pigscript.parser.PigScriptParser.parse(PigScriptParser.java:372)
          	at org.apache.pig.tools.grunt.GruntParser.parseStopOnError(GruntParser.java:198)
          	at org.apache.pig.tools.grunt.GruntParser.parseStopOnError(GruntParser.java:173)
          	at org.apache.pig.tools.grunt.Grunt.exec(Grunt.java:84)
          	at org.apache.pig.Main.run(Main.java:478)
          	at org.apache.pig.Main.main(Main.java:156)
          	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
          	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          	at java.lang.reflect.Method.invoke(Method.java:606)
          	at org.apache.hadoop.util.RunJar.main(RunJar.java:212)
          Caused by: java.lang.TypeNotPresentException: Type timestamp not present
          	at org.apache.hcatalog.data.schema.HCatSchemaUtils.getPrimitiveHType(HCatSchemaUtils.java:176)
          	at org.apache.hcatalog.data.schema.HCatSchemaUtils.getHCatFieldSchema(HCatSchemaUtils.java:126)
          	at org.apache.hcatalog.data.schema.HCatSchemaUtils.getHCatFieldSchema(HCatSchemaUtils.java:119)
          	at org.apache.hcatalog.common.HCatUtil.getHCatFieldSchemaList(HCatUtil.java:164)
          	at org.apache.hcatalog.common.HCatUtil.getTableSchemaWithPtnCols(HCatUtil.java:197)
          	at org.apache.hcatalog.pig.HCatLoader.getSchema(HCatLoader.java:197)
          	at org.apache.pig.newplan.logical.relational.LOLoad.getSchemaFromMetaData(LOLoad.java:175)
          	at org.apache.pig.newplan.logical.relational.LOLoad.<init>(LOLoad.java:89)
          	at org.apache.pig.parser.LogicalPlanBuilder.buildLoadOp(LogicalPlanBuilder.java:853)
          	at org.apache.pig.parser.LogicalPlanGenerator.load_clause(LogicalPlanGenerator.java:3479)
          	at org.apache.pig.parser.LogicalPlanGenerator.op_clause(LogicalPlanGenerator.java:1536)
          	at org.apache.pig.parser.LogicalPlanGenerator.general_statement(LogicalPlanGenerator.java:1013)
          	at org.apache.pig.parser.LogicalPlanGenerator.statement(LogicalPlanGenerator.java:553)
          	at org.apache.pig.parser.LogicalPlanGenerator.query(LogicalPlanGenerator.java:421)
          	at org.apache.pig.parser.QueryParserDriver.parse(QueryParserDriver.java:188)
          
          Eugene Koifman added a comment -

          Lefty Leverenz The feature is complete but the doc changes are still needed.

          Lefty Leverenz added a comment -

          Also, we should take on a documentation task to update the HCat wiki with the Out-of-range semantics.

          Has this been done yet? It doesn't seem to be included in HIVE-6316 (Document support for new types in HCat).

          Lefty Leverenz made changes -
          Link This issue incorporates HIVE-6232 [ HIVE-6232 ]
          Sushanth Sowmyan made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Fix Version/s 0.13.0 [ 12324986 ]
          Resolution Fixed [ 1 ]
          Sushanth Sowmyan added a comment -

          Committed to trunk. Thanks, Eugene!

          Eugene Koifman made changes -
          Link This issue is related to HIVE-6370 [ HIVE-6370 ]
          Sushanth Sowmyan added a comment -

          I see.

          Yes, agreed, using toString() and valueOf as-is should be unacceptable, and we should modify LazySimpleSerDe/etc to that effect (not needed in this jira, let's not bundle still more changes here)

          Eugene Koifman made changes -
          Description Hive 0.12 added support for new data types. Pig 0.12 added some as well. HCat should handle these as well. Also note that CHAR was added recently.

          Also allow user to specify a parameter in Pig like so HCatStorer('','', '-onOutOfRangeValue Throw') to control what happens when Pig's value is out of range for target Hive column. Valid values for the option are Throw and Null. Throw - make the runtime raise an exception, Null, which is the default, means NULL is written to target column and a message to that effect is emitted to the log. Only 1 message per column/data type is sent to the log.
          Hive 0.12 added support for new data types. Pig 0.12 added some as well. HCat should handle these as well. Also note that CHAR was added recently.

          Also allow user to specify a parameter in Pig like so HCatStorer('','', '-onOutOfRangeValue Throw') to control what happens when Pig's value is out of range for target Hive column. Valid values for the option are Throw and Null. Throw - make the runtime raise an exception, Null, which is the default, means NULL is written to target column and a message to that effect is emitted to the log. Only 1 message per column/data type is sent to the log.

          See attached HCat-Pig Type Mapping Hive 0.13.pdf for exact mappings.
          Eugene Koifman made changes -
          Description Hive 0.12 added support for new data types. Pig 0.12 added some as well. HCat should handle these as well. Also note that CHAR was added recently. Hive 0.12 added support for new data types. Pig 0.12 added some as well. HCat should handle these as well. Also note that CHAR was added recently.

          Also allow user to specify a parameter in Pig like so HCatStorer('','', '-onOutOfRangeValue Throw') to control what happens when Pig's value is out of range for target Hive column. Valid values for the option are Throw and Null. Throw - make the runtime raise an exception, Null, which is the default, means NULL is written to target column and a message to that effect is emitted to the log. Only 1 message per column/data type is sent to the log.
          Eugene Koifman added a comment -

          java.sql.Date works like this.
          1. d = new Date(System.currentTimeMillis()
          2. d.toString() - prints out human readable date, but implicitly takes into account local timezone
          3. Date.valueOf("2014-01-01") calculates millis value again using local timezone.
          4. our LazySerde serializes Date using toString/valueOf which in my opinion is totally wrong. Thus if operation in 1 is performed at 5AM UTC time (Apr 2nd for example) but hive is running in Palo Alto, it will save the date which is 1 day before, i.e. Apr 1st. It should just store the millis value (perhaps making sure to chop off the 'time' part if any, i.e. so that it represents midnight since Epoch) and read it back the same way. Then we'd have 'absolute' notion of date.

          Sushanth Sowmyan added a comment -

          Also, I would suggest editing the original description of this jira to indicate that HIVE-6232 was rolled into this patch as well, it'll help others that are jira trawling later on.

          Sushanth Sowmyan added a comment -

          I've reviewed HIVE-5814.5.patch as a diff on the original HIVE-5814.patch that I reviewed last week, and it looks good to me.

          I must admit to being slightly nervous about the comments you made about java.sql.Date being weird, having not experimented with it myself, and would like to understand what other corner cases exist, and whether we want to make any changes to other serdes about this.

          Also, we should take on a documentation task to update the HCat wiki with the Out-of-range semantics.

          For this patch itself, though, I'm +1.

          Eugene Koifman added a comment -

          this failure is not related to any HCat changes

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12626383/HIVE-5814.5.patch

          ERROR: -1 due to 1 failed/errored test(s), 5000 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_auto_sortmerge_join_16
          

          Test results: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1136/testReport
          Console output: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1136/console

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 1 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12626383

          Eugene Koifman made changes -
          Attachment HIVE-5814.5.patch [ 12626383 ]
          Eugene Koifman added a comment -

          HIVE-5814.5.patch - include TestHCatLoaderStorer change

          Eugene Koifman added a comment -

          Also included are a bunch of tests around out-of-range values from Pig

          Eugene Koifman added a comment -
          Eugene Koifman added a comment -

          HIVE-5814.4.patch adds ability for user to specify what happens if Pig value is out of range for target column in Hive.
          Here is an example:
          store data into 'test_tbl' using org.apache.hive.hcatalog.pig.HCatStorer('','','-onOutOfRangeValue Throw');

          Valid values are Throw and Null (default).

          Eugene Koifman made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Eugene Koifman made changes -
          Attachment HIVE-5814.4.patch [ 12626347 ]
          Eugene Koifman made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Eugene Koifman made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Eugene Koifman made changes -
          Attachment HIVE-5814.3.patch [ 12625486 ]
          Eugene Koifman made changes -
          Attachment HIVE-5814.3.patch [ 12626277 ]
          Eugene Koifman made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Eugene Koifman made changes -
          Attachment HIVE-5814 HCat-Pig type mapping.pdf [ 12624013 ]
          Eugene Koifman made changes -
          Attachment HCat-Pig Type Mapping Hive 0.13.pdf [ 12626251 ]
          Eugene Koifman added a comment -

          Updated spec

          Hive QA added a comment -

          Overall: -1 at least one tests failed

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12625486/HIVE-5814.3.patch

          ERROR: -1 due to 6 failed/errored test(s), 4968 tests executed
          Failed tests:

          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_auto_sortmerge_join_16
          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_import_exported_table
          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_infer_bucket_sort_reducers_power_two
          org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_load_hdfs_file_with_space_in_the_name
          org.apache.hadoop.hive.cli.TestNegativeMinimrCliDriver.testNegativeCliDriver_file_with_header_footer_negative
          org.apache.hadoop.hive.cli.TestNegativeMinimrCliDriver.testNegativeCliDriver_mapreduce_stack_trace_hadoop20
          

          Test results: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1060/testReport
          Console output: http://bigtop01.cloudera.org:8080/job/PreCommit-HIVE-Build/1060/console

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          Tests exited with: TestsFailedException: 6 tests failed
          

          This message is automatically generated.

          ATTACHMENT ID: 12625486

          Eugene Koifman made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Eugene Koifman made changes -
          Attachment HIVE-5814.3.patch [ 12625486 ]
          Eugene Koifman added a comment -

          HIVE-5814.3.patch rebased with current trunk

          Eugene Koifman made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Eugene Koifman made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Eugene Koifman made changes -
          Attachment HIVE-5814.2.patch [ 12625462 ]
          Eugene Koifman added a comment -

          same patch, diff name; trying to get pre commit test to run

          Eugene Koifman made changes -
          Attachment HIVE-5814.patch [ 12624020 ]
          Eugene Koifman made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Sushanth Sowmyan added a comment -

          The patch looks good from HCat's perspective. It does not apply cleanly on trunk right now, but from the intent, I'm good on this. If you can update the patch and set it to patch available again (and if the precommit tests are working again), we can get the precommit tests running on this.

          Eugene Koifman made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Eugene Koifman made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Eugene Koifman made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Eugene Koifman made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Eugene Koifman added a comment -
          Eugene Koifman made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Eugene Koifman made changes -
          Attachment HIVE-5814.patch [ 12624020 ]
          Eugene Koifman made changes -
          Attachment HIVE-5814 HCat-Pig type mapping.pdf [ 12624013 ]
          Eugene Koifman made changes -
          Attachment HIVE-5814PrimitiveTypeHivePigMapping.pdf [ 12622292 ]
          Eugene Koifman made changes -
          Attachment HIVE-5814.patch [ 12613912 ]
          Eugene Koifman made changes -
          Link This issue relates to HIVE-6194 [ HIVE-6194 ]
          Eugene Koifman made changes -
          Attachment HIVE-5814PrimitiveTypeHivePigMapping.pdf [ 12622292 ]
          Eugene Koifman made changes -
          Summary Add DATE, TIMESTAMP, DECIMAL, VARCHAR types support in HCat Add DATE, TIMESTAMP, DECIMAL, CHAR, VARCHAR types support in HCat
          Eugene Koifman made changes -
          Description Hive 0.12 added support for new data types. Pig 0.12 added some as well. HCat should handle these as well. Hive 0.12 added support for new data types. Pig 0.12 added some as well. HCat should handle these as well. Also note that CHAR was added recently.
          Eugene Koifman made changes -
          Link This issue relates to HIVE-5565 [ HIVE-5565 ]
          Eugene Koifman made changes -
          Field Original Value New Value
          Attachment HIVE-5814.patch [ 12613912 ]
          Eugene Koifman added a comment - - edited

          partial implementation

          Eugene Koifman created issue -

            People

            • Assignee:
              Eugene Koifman
              Reporter:
              Eugene Koifman
            • Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development