Hive
  1. Hive
  2. HIVE-4487

Hive does not set explicit permissions on hive.exec.scratchdir

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.10.0
    • Fix Version/s: 0.12.0
    • Component/s: None
    • Labels:

      Description

      The hive.exec.scratchdir defaults to /tmp/hive-${user.name}, but when Hive creates this directory it doesn't set any explicit permission on it. This means if you have the default HDFS umask setting of 022, then these directories end up being world readable. These permissions also get applied to the staging directories and their files, thus leaving inter-stage data world readable.

      This can cause a potential leak of data especially when operating on a Kerberos enabled cluster. Hive should probably default these directories to only be readable by the owner.

        Issue Links

          Activity

          Lefty Leverenz added a comment -

          Doc done (please review): hive.scratch.dir.permission is documented in the wiki now.

          By the way, the parameter name omits ".exec." so it doesn't match similar parameters.

          Lefty Leverenz added a comment -

          Doc note: This adds configuration parameter hive.scratch.dir.permission to HiveConf.java, so it needs to be documented in the wiki (in two places):

          HIVE-6847 adds a parameter description in release 0.14.0.

          Ashutosh Chauhan added a comment -

          This issue has been fixed and released as part of 0.12 release. If you find further issues, please create a new jira and link it to this one.

          Chaoyu Tang added a comment -

          Noticed that Mark has already provided a patch with the same changes in Hive-5322. Thanks, Mark Wagner

          Chaoyu Tang added a comment -

          Synced to the head of trunk and was able to reproduce the issue as Yin Huai saw.
          The cause is, as Thejas said, in the conversion of octal permission to short. Changed the line 209 in Context.java to:
          FsPermission fsPermission = new FsPermission(Short.parseShort(scratchDirPermission.trim(), 8))
          will solve the problem.

          Thejas M Nair added a comment -

          I have created HIVE-5322 to track the permission issue.

          Thejas M Nair added a comment -

          I think the problem might have to do with HIVE-5313 change. It converts the octal string into short using Short.parseShort(scratchDirPermission) but that function expects decimal. So "700" gets converted to 700 instead of 448.

          Chaoyu Tang added a comment -

          Yin Huai It works in my eclipse. The log tells that it failed in line outStream = fs.create(resFile) of DDLTask.
          Could you debug and check before this line is executed, what permission and owner of the dir (e.g. /tmp/yhuai/hive_2013-09-19_xxxx/, one level up -local-10000) are? What Hadoop version you are using?

          Hudson added a comment -

          FAILURE: Integrated in Hive-trunk-hadoop1-ptest #173 (See https://builds.apache.org/job/Hive-trunk-hadoop1-ptest/173/)
          HIVE-5313 - HIVE-4487 breaks build because 0.20.2 is missing FSPermission(string) (brock: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1524578)

          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/Context.java
          Yin Huai added a comment -
          drwxrwxrwt  22 root     root      56K Sep 19 13:36 tmp
          
          drwxrwxrwx 2 yhuai   yhuai   4.0K Sep 19 13:50 yhuai
          
          Yin Huai added a comment -

          i meant when I did "show tables" in hive cli launched in eclipse.

          Brock Noland added a comment -

          Can you share the file permissions on each directory in the tree?

          Yin Huai added a comment -

          Here is my error log when I am launching hive cli through eclipse.

          Caused by: java.io.FileNotFoundException: /tmp/yhuai/hive_2013-09-19_13-43-12_206_2528583202954923226-1/-local-10000 (Permission denied)
          	at java.io.FileOutputStream.open(Native Method)
          	at java.io.FileOutputStream.<init>(FileOutputStream.java:209)
          	at org.apache.hadoop.fs.RawLocalFileSystem$LocalFSFileOutputStream.<init>(RawLocalFileSystem.java:180)
          	at org.apache.hadoop.fs.RawLocalFileSystem$LocalFSFileOutputStream.<init>(RawLocalFileSystem.java:176)
          	at org.apache.hadoop.fs.RawLocalFileSystem.create(RawLocalFileSystem.java:234)
          	at org.apache.hadoop.fs.ChecksumFileSystem$ChecksumFSOutputSummer.<init>(ChecksumFileSystem.java:335)
          	at org.apache.hadoop.fs.ChecksumFileSystem.create(ChecksumFileSystem.java:368)
          	at org.apache.hadoop.fs.FileSystem.create(FileSystem.java:484)
          	at org.apache.hadoop.fs.FileSystem.create(FileSystem.java:465)
          	at org.apache.hadoop.fs.FileSystem.create(FileSystem.java:372)
          	at org.apache.hadoop.fs.FileSystem.create(FileSystem.java:364)
          	at org.apache.hadoop.hive.ql.exec.DDLTask.showTables(DDLTask.java:2252)
          	... 13 more
          
          Hudson added a comment -

          FAILURE: Integrated in Hive-trunk-hadoop2-ptest #106 (See https://builds.apache.org/job/Hive-trunk-hadoop2-ptest/106/)
          HIVE-5313 - HIVE-4487 breaks build because 0.20.2 is missing FSPermission(string) (brock: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1524578)

          Brock Noland added a comment -

          Full error message from: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-Build-813/failed/TestParseNegative/hive.log

          20_510_7475863120290716577-1/-ext-10000 to 0777
          java.io.IOException: Failed to set permissions of path: /home/hiveptest/ip-10-74-50-170-hiveptest-2/apache-svn-trunk-source/build/ql/scratchdir/hive_2013-09-18_19-22-20_510_7475863120290716577-1/-ext-10000 to 0777
          	at org.apache.hadoop.fs.FileUtil.checkReturnValue(FileUtil.java:689)
          	at org.apache.hadoop.fs.FileUtil.setPermission(FileUtil.java:662)
          	at org.apache.hadoop.fs.RawLocalFileSystem.setPermission(RawLocalFileSystem.java:509)
          	at org.apache.hadoop.fs.RawLocalFileSystem.mkdirs(RawLocalFileSystem.java:344)
          	at org.apache.hadoop.fs.FilterFileSystem.mkdirs(FilterFileSystem.java:189)
          	at org.apache.hadoop.fs.FilterFileSystem.mkdirs(FilterFileSystem.java:189)
          	at org.apache.hadoop.fs.ProxyFileSystem.mkdirs(ProxyFileSystem.java:217)
          	at org.apache.hadoop.fs.FilterFileSystem.mkdirs(FilterFileSystem.java:189)
          	at org.apache.hadoop.fs.FileSystem.mkdirs(FileSystem.java:1126)
          	at org.apache.hadoop.hive.ql.exec.CopyTask.execute(CopyTask.java:74)
          	at org.apache.hadoop.hive.ql.exec.Task.executeTask(Task.java:151)
          	at org.apache.hadoop.hive.ql.exec.TaskRunner.runSequential(TaskRunner.java:65)
          	at org.apache.hadoop.hive.ql.Driver.launchTask(Driver.java:1415)
          	at org.apache.hadoop.hive.ql.Driver.execute(Driver.java:1193)
          	at org.apache.hadoop.hive.ql.Driver.runInternal(Driver.java:1021)
          	at org.apache.hadoop.hive.ql.Driver.run(Driver.java:889)
          	at org.apache.hadoop.hive.ql.QTestUtil.runLoadCmd(QTestUtil.java:539)
          	at org.apache.hadoop.hive.ql.QTestUtil.createSources(QTestUtil.java:586)
          	at org.apache.hadoop.hive.ql.QTestUtil.init(QTestUtil.java:678)
          	at org.apache.hadoop.hive.ql.parse.TestParseNegative.runTest(TestParseNegative.java:248)
          	at org.apache.hadoop.hive.ql.parse.TestParseNegative.testParseNegative_ambiguous_join_col(TestParseNegative.java:117)
          
          Brock Noland added a comment -

          Very strange. I don't see why this would be occurring since the hiveptest owns everything in /home/hiveptest/. It's not a privileged user so cannot it cannot change ownership. The only way I can see that is if "hive_2013-09-18_19-22-30_852_799993877859563099-1" somehow got created with 000 (or anything but 700).

          Hudson added a comment -

          FAILURE: Integrated in Hive-trunk-h0.21 #2341 (See https://builds.apache.org/job/Hive-trunk-h0.21/2341/)
          HIVE-5313 - HIVE-4487 breaks build because 0.20.2 is missing FSPermission(string) (brock: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1524578)

          Thejas M Nair added a comment -

          I am seeing several precommit intermittent test failures in last few builds, which seem to be caused by permission errors. I am wondering if it might be related to this change. I also saw this on my linux machine, but not in another run on my mac.

          The tests have errors like this -
          Copying data from file:/home/hiveptest/ip-10-74-50-170-hiveptest-2/apache-svn-trunk-source/data/files/kv1.txt
          Failed with exception Failed to set permissions of path: /home/hiveptest/ip-10-74-50-170-hiveptest-2/apache-svn-trunk-source/build/ql/scratchdir/hive_2013-09-18_19-22-30_852_799993877859563099-1/-ext-10000 to 0777

          For example in - https://builds.apache.org/job/PreCommit-HIVE-Build/813/testReport/org.apache.hadoop.hive.ql.parse/TestParseNegative/testParseNegative_ambiguous_join_col/

          Thejas M Nair added a comment -

          Patch committed to 0.12 branch

          Hudson added a comment -

          FAILURE: Integrated in Hive-trunk-hadoop2 #439 (See https://builds.apache.org/job/Hive-trunk-hadoop2/439/)
          HIVE-5313 - HIVE-4487 breaks build because 0.20.2 is missing FSPermission(string) (brock: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1524578)

          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/Context.java
          Brock Noland added a comment -

          I created HIVE-5313 to fix this.

          Yin Huai added a comment -

          If we use "ant clean package eclipse-files", we cannot build hive inside eclipse.

          Yin Huai added a comment -

          FsPermission(String mode) was not in hadoop 0.20.2.

          Hudson added a comment -

          FAILURE: Integrated in Hive-trunk-hadoop2 #438 (See https://builds.apache.org/job/Hive-trunk-hadoop2/438/)
          HIVE-4487 - Hive does not set explicit permissions on hive.exec.scratchdir (Chaoyu Tang via Brock Noland) (brock: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1524509)

          • /hive/trunk/common/src/java/org/apache/hadoop/hive/conf/HiveConf.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/Context.java
          Hudson added a comment -

          FAILURE: Integrated in Hive-trunk-hadoop1-ptest #172 (See https://builds.apache.org/job/Hive-trunk-hadoop1-ptest/172/)
          HIVE-4487 - Hive does not set explicit permissions on hive.exec.scratchdir (Chaoyu Tang via Brock Noland) (brock: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1524509)

          • /hive/trunk/common/src/java/org/apache/hadoop/hive/conf/HiveConf.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/Context.java
          Thejas M Nair added a comment -

          Yes, I will commit it to 0.12 branch.

          Brock Noland added a comment -

          Thanks Chaoyu! I have committed this to trunk. Thejas M Nair you mind consider this one for 0.12 as well.

          Brock Noland added a comment -

          +1

          Hive QA added a comment -

          Overall: +1 all checks pass

          Here are the results of testing the latest attachment:
          https://issues.apache.org/jira/secure/attachment/12589262/HIVE-4487.patch

          SUCCESS: +1 3125 tests passed

          Test results: https://builds.apache.org/job/PreCommit-HIVE-Build/770/testReport
          Console output: https://builds.apache.org/job/PreCommit-HIVE-Build/770/console

          Messages:

          Executing org.apache.hive.ptest.execution.PrepPhase
          Executing org.apache.hive.ptest.execution.ExecutionPhase
          Executing org.apache.hive.ptest.execution.ReportingPhase
          

          This message is automatically generated.

          Chaoyu Tang added a comment -

          Please review the changes in https://reviews.apache.org/r/12049/

          Chaoyu Tang added a comment -

          How about the hive.exec.local.scratchdir (/tmp/$

          {user.name}

          in local system) if it is applicable, should not it be 700 as well?

          Joey Echeverria added a comment -

          The current workaround is to set the umask in hive-site.xml:

            <property>
              <name>fs.permissions.umask-mode</name>
              <value>077</value>
            </property>
          

            People

            • Assignee:
              Chaoyu Tang
              Reporter:
              Joey Echeverria
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development