Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: CLI, Server Infrastructure
    • Labels:
      None

      Description

      Add HTTP as endpoint option for HiveServer2. This supports environments for which TCP connectivity is inconvenient or impossible. One key scenario is beeline connecting to a HTTPS proxy/gateway which forwards to HS2-HTTP.
      Due to the proxy/gateway scenario being most secure, support for HS2 HTTPS has not been added.

      new behavior:
      new configuration options to use HTTP server mode rather than TCP
      http mode uses Jetty server/servlets
      new beeline client URI parsing and HTTP transport behavior.

      Usage:
      (1) TCP-mode: beeline> !connect jdbc:hive2://<server>:<port>/ user password

      (2) HTTP-mode: beeline> !connect jdbc:hive2:http://<server>:<port>/path/../ user password

      (3) via HTTPS proxy: beeline> !connect jdbc:hive2:https://<server>:<port>/path/../ user password

      1. HIVE-4026.patch
        20 kB
        Mike Liddell

        Issue Links

          Activity

          Vaibhav Gumashta added a comment -

          Duplicate of HIVE-4752


            People

            • Assignee:
              Mike Liddell
              Reporter:
              Mike Liddell
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development