Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-25799

Maven should stop early for unsupported java versions

    XMLWordPrintableJSON

Details

    Description

      I made the mistake of using my default java compiler (which apparently is 17) to build hive, and it failed. If hive only supports a certain version (or ranges of versions) of java, it would be incredibly helpful if maven reported this eagerly.

      This is easily achievable using the maven enforcer system (a number of enforcers are already deployed in the top level pom):

      https://maven.apache.org/enforcer/enforcer-rules/requireJavaVersion.html

      Attachments

        Issue Links

          Activity

            People

              jsoref Josh Soref
              jsoref Josh Soref
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 40m
                  40m