Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 0.11.0
    • Component/s: None
    • Labels:
      None
    • Release Note:
      Beginning 0.11, Hive has started to use antlr 3.4

      Description

      Upgrade antlr version to 3.4

      1. HIVE-2439_branch10.patch
        73 kB
        Thiruvel Thirumoolan
      2. HIVE-2439_branch9_2.patch
        71 kB
        Thiruvel Thirumoolan
      3. HIVE-2439_branch9_3.patch
        72 kB
        Thiruvel Thirumoolan
      4. HIVE-2439_branch9.patch
        5 kB
        Thiruvel Thirumoolan
      5. hive-2439_incomplete.patch
        4 kB
        Ashutosh Chauhan
      6. HIVE-2439_trunk_1.patch
        73 kB
        Thiruvel Thirumoolan
      7. HIVE-2439_trunk_2.patch
        74 kB
        Thiruvel Thirumoolan
      8. HIVE-2439_trunk.patch
        72 kB
        Thiruvel Thirumoolan

        Issue Links

          Activity

          Alejandro Abdelnur added a comment -

          Using antlr 3.4 supposedly fixes the following issue:

          Exception in thread "main" java.lang.NoSuchFieldError: type

          However, with 3.4 I'm getting:

          Exception in thread "main" java.lang.NoSuchFieldError: channel

          Sticking to 3.0.1 things work.

          Ashutosh Chauhan added a comment -

          Alejandro,
          Which problem you are referring to? If you use hive as is, you should not see any such exception.

          Alejandro Abdelnur added a comment -

          Running Hive from within Oozie, if using antlr 3.4, hive cli fails with:

          Exception in thread "main" java.lang.NoSuchFieldError: channel
          

          If I downgrade to 3.0.1 the hive cli invocation works OK.

          Ashutosh Chauhan added a comment -

          This is an incomplete patch which you need to get past this problem. But this patch is not sufficient. I worked on this briefly in September and encountered a bug in antlr. See: http://www.antlr.org/pipermail/antlr-interest/2011-September/042720.html I have not been able to narrow it down to file an official bug in antlr but right now I am apprehensive about 3.4. Good news though is antlr community is talking about 3.4.1 which may get released soon.

          Ashutosh Chauhan added a comment -

          If any one wants to pursue this further feel free to take over the patch.

          Thiruvel Thirumoolan added a comment -

          Took a shot at this one on branch 0.9. Faced the same problems as Ashutosh, but I was able compile cleanly using antlr 3.2 and 3.3 after I cleaned up the ivy cache or removed all antlr directories. The change in parse tree happens with 3.3 and the release notes don't help me.

          It looks like adding a token to one of the grammars was providing a consistent tree with 3.2 and 3.3/3.4. I have requested antlr group for clarification and hope to get to something working. I will try to post a patch for branch 0.9 that has been done based on Ashutosh's previous patch if my approach is correct. Here is an email that I sent along with the links of my experiments. In case someone has any thoughts or feedback, they are welcome.

          ------

          On 12/3/12 6:11 PM, "Thiruvel Thirumoolan" <*> wrote:

          Hi Jim,

          Thanks for your response, I guess the formatting was misleading. I have
          reformatted and this should help.

          After some poking around, a small change to the grammar provides a
          consistent tree between 3.2 and 3.3. Is this the original mistake we had?

          Suspected rule:

          destination:
          ...

          KW_TABLE tableOrPartition
          -> ^(tableOrPartition)

          Modified rule:

          destination:
          ...

          KW_TABLE tableOrPartition
          -> ^(TOK_TAB_OR_PART tableOrPartition)

          After adding a token to the rewrite rule, I was able to see a consistent
          tree. I will have to change AST parsing code in Hive obviously, a little
          involved. But is this the bug in the grammar? I could not find any
          incompatible change in ANTLR 3.3 release notes regarding this [1] [only
          debug related incompatible change].

          [1] - http://www.antlr.org/wiki/display/ANTLR3/ANTLR+3.3+Release+Notes

          Thanks!
          Thiruvel

          On 12/3/12 7:43 AM, "Jim Idle" <*> wrote:

          With just a quick glance at your sample grammar I think that your issues
          is
          only that some of your rules are using rewrite rules ( -> ) but they are
          only being used on say 1 out of 2 alts. IIRC, if you use rewrite rules on
          one alt of a rule, you must use them on all the others too.

          JIm

          On Fri, Nov 30, 2012 at 10:56 PM, Thiruvel Thirumoolan <*> wrote:

          Hello,

          I work on Apache Hive and it currently uses antlr 3.0.1. We would like
          to
          upgrade to antlr 3.4 so its easy to work with other Apache projects on
          Hadoop that use antlr 3.4. We found that the parse tree generated from
          Hive.g [1] is different with 3.0.1/3.1/3.2 and 3.3/3.4.

          I have stripped down the lengthy grammar and created a smaller version
          (Insert.g [2]). I have pushed a small mvn v3 project to
          https://github.com/thiruvel/HiveANTLR34Issue that uses ANTLR in a way
          Hive uses it. Here is the tree difference and the entire output is on
          github. One can run "mvn test" to simulate it.

          Antlr 3.0.1/3.1/3.2:

          ( TOK_DESTINATION( TOK_TAB( TOK_TABNAME( TABLE_X))( TOK_PARTSPEC(
          TOK_PARTVAL( DIM_1)( 'A'))( TOK_PARTVAL( DIM_2)( 'B')))))

          Antlr 3.3/3.4:

          ( TOK_DESTINATION( TOK_TAB))

          Are we missing something in the grammar or is this a bug addressed in
          v4?
          I am afraid we can't move to v4 as that would mean moving all other
          projects to v4. Are there any workarounds that we can use with antlr
          3.4 to
          ensure a similar Tree is generated?

          Any help is greatly appreciated.

          Thank You!
          Thiruvel

          [1] - http://svn.apache.org/repos/asf/hive/branches/branch-0.9/ql/src/java/org/apache/hadoop/hive/ql/parse/Hive.g
          [2] - https://github.com/thiruvel/HiveANTLR34Issue/blob/master/src/main/antlr3/com/yahoo/antlr/Insert.g

          Ashutosh Chauhan added a comment -

          Thanks, Thiruvel for taking this up. I don't have any more insight into this issue at the moment, but I am certainly interested in getting this resolved.

          Thiruvel Thirumoolan added a comment -

          Work in progress patch for branch9. Inherits from Ashutosh's previous patch. Majority of the test cases that failed previously pass now, though there are still failures.

          For experimentation I used https://github.com/thiruvel/HiveANTLR34Issue and changed the grammar there and confirmed the same tree is generated with antlr 3.2 and 3.4.

          Feedback/Comments welcome.

          Thiruvel Thirumoolan added a comment -

          Couple of tests fail due the same cause in TestCliDriver, weird error messages. Both of them are related to views. TestHiveServerSessions fail for me with or without the change, havent looked deeper as its unrelated. All others seem to pass.

          Exception for join_view.q:

          ...
          create view v as select invites.bar, invites2.foo, invites2.ds from invites
          join invites2 on invites.ds=invites2.ds
          ...
          2012-12-04 10:59:19,647 DEBUG parse.SemanticAnalyzer
          (SemanticAnalyzer.java:genPlan(6766)) - Created Plan for Query Block null
          2012-12-04 10:59:19,648 ERROR ql.Driver (SessionState.java:printError(400)) -
          FAILED: Hive Internal Error: java.lang.IllegalArgumentException(replace op
          boundaries of
          <ReplaceOp@[@41,138:139='ds',<24>,5:101]..[@41,138:139='ds',<24>,5:101]:"`ds`">
          overlap with previous
          <ReplaceOp@[@39,130:136='invites',<24>,5:93]..[@41,138:139='ds',<24>,5:101]:"`invites`.`ds`">)
          java.lang.IllegalArgumentException: replace op boundaries of
          <ReplaceOp@[@41,138:139='ds',<24>,5:101]..[@41,138:139='ds',<24>,5:101]:"`ds`">
          overlap with previous
          <ReplaceOp@[@39,130:136='invites',<24>,5:93]..[@41,138:139='ds',<24>,5:101]:"`invites`.`ds`">
          at
          org.antlr.runtime.TokenRewriteStream.reduceToSingleOperationPerIndex(TokenRewriteStream.java:504)
          at
          org.antlr.runtime.TokenRewriteStream.toString(TokenRewriteStream.java:374)
          at
          org.antlr.runtime.TokenRewriteStream.toString(TokenRewriteStream.java:358)
          at
          org.apache.hadoop.hive.ql.parse.SemanticAnalyzer.saveViewDefinition(SemanticAnalyzer.java:7602)

          Ashutosh Chauhan added a comment -

          If you are using 0.9 branch, use patch from HIVE-2937 to get past TestHiveServerSessions failure.

          Thiruvel Thirumoolan added a comment -

          There are two failures in TestCliDriver related to views which are a little weird (exception at the end). As per [1], during Semantic Analyzer, Hive expands a query [say replace with all columns if there is a *]. This is achieved using antlr TokenRewriteStream class. The inputs to this class from Hive hasn't changed because of the version bump (or updated Lexer/Parser), but TokenRewriteStream.toString() has undergone almost a rewrite when compared to 3.0.1 when comparing the sources. The IllegalArgumentException is due to the additional code in 3.4.

          This does not happen with all view related tests. Going by the test case failures, it happens when there is a join. Other test cases related to lateral views, UDF/UDTF all pass, but two tests related to join fail [a view being created from join of tables]. Failed test cases: join_view.q and ppd_union_view.q. Not sure if there is a problem in the way we are using this API.

          [1] - https://cwiki.apache.org/confluence/display/Hive/ViewDev#ViewDev-StoredViewDefinition

          Exception:

          ...
          create view v as select invites.bar, invites2.foo, invites2.ds from invites
          join invites2 on invites.ds=invites2.ds
          ...
          2012-12-04 10:59:19,647 DEBUG parse.SemanticAnalyzer
          (SemanticAnalyzer.java:genPlan(6766)) - Created Plan for Query Block null
          2012-12-04 10:59:19,648 ERROR ql.Driver (SessionState.java:printError(400)) -
          FAILED: Hive Internal Error: java.lang.IllegalArgumentException(replace op
          boundaries of
          <ReplaceOp@[@41,138:139='ds',<24>,5:101]..[@41,138:139='ds',<24>,5:101]:"`ds`">
          overlap with previous
          <ReplaceOp@[@39,130:136='invites',<24>,5:93]..[@41,138:139='ds',<24>,5:101]:"`invites`.`ds`">)
          java.lang.IllegalArgumentException: replace op boundaries of
          <ReplaceOp@[@41,138:139='ds',<24>,5:101]..[@41,138:139='ds',<24>,5:101]:"`ds`">
          overlap with previous
          <ReplaceOp@[@39,130:136='invites',<24>,5:93]..[@41,138:139='ds',<24>,5:101]:"`invites`.`ds`">
          at
          org.antlr.runtime.TokenRewriteStream.reduceToSingleOperationPerIndex(TokenRewriteStream.java:504)
          at
          org.antlr.runtime.TokenRewriteStream.toString(TokenRewriteStream.java:374)
          at
          org.antlr.runtime.TokenRewriteStream.toString(TokenRewriteStream.java:358)
          at
          org.apache.hadoop.hive.ql.parse.SemanticAnalyzer.saveViewDefinition(SemanticAnalyzer.java:7602)
          at
          org.apache.hadoop.hive.ql.parse.SemanticAnalyzer.analyzeInternal(SemanticAnalyzer.java:7537)
          at
          org.apache.hadoop.hive.ql.parse.BaseSemanticAnalyzer.analyze(BaseSemanticAnalyzer.java:244)

          Thiruvel Thirumoolan added a comment -

          This patch addresses the issues related to views that were failing before. With this all previous failing tests pass. Early feedback welcome. Here is a description of the problem related to views.

          UnparseTranslator() has a translation map where its possible to replace all the
          text with the appropriate escaped version [say invites.ds will be replaced with
          `invites`.`ds` and the entire query is processed like this and stored as
          Extended text in table's metadata]. This holds all individual translations and
          where they apply in the stream. The newer antlr has some conditions on
          overlap. Two of the entries in this translation map can be disjoint or even the
          same, but there cannot be partial overlap, which causes the exception.

          Some of the entries during join_view.q: One can think of the below as UnparseTranslator.translations entries.

          Start: Stop: Replacement Text
          ..
          39:41:`invites`.`ds`
          41:41:`ds`
          43:45:`invites2`.`ds`
          45:45:`ds`
          ..

          Other translations don't seem to have a problem. Whenever SemanticAnalyser
          finds that a translation is required, it will add it to the translation map. In
          this case "41:41:`ds`" is being added by parseJoinCondPopulateAlias() for the
          HiveParser.Identifier case. And "43:45:`invites2`.`ds`" is done by
          genExprNodeDesc() after this during plan generation. So there is a duplicate entry. UnparseTranslator.addTranslation() has logic to eliminate subsets but seem to miss this. Have included this situation in the patch.

          Ashutosh Chauhan added a comment -

          Thiruvel,
          We usually work on trunk. So, I will suggest you to use trunk for this work. From trunk, we can always backport patches.

          Thiruvel Thirumoolan added a comment -

          Uploading HIVE-2439_trunk.patch. It applies on trunk and branch 10. Ran unit tests. Have problems with my review account, will post it later if I get it working.

          Thiruvel Thirumoolan added a comment -

          Looks like Phabricator is on version 5 and arc is on version 6. Unable to post patch on phabricator. Phabricator doesnt seem to have any branches, so gets difficult trying to get it from one of their trees before the version bump.

          Will try posting couple of days later.

          Thiruvel Thirumoolan added a comment -

          Patch uploaded to Phabricator - https://reviews.facebook.net/D7527

          Namit Jain added a comment -

          What is the reason for upgrading antlr ?

          Thiruvel Thirumoolan added a comment -

          Namit Jain

          This is intended to simplify life for users of Hive, HCatalog and Pig. As HCat/Pig use antlr 3.4, anyone using all the components have to workaround in unfriendly and complicated ways. Thomas Weise raised this issue before http://markmail.org/thread/xltnc5ak2saurdbu. Websearch for 'hive pig antlr' also brings up workarounds like using jarjar.

          While upgrading antlr, I also fixed problems in Hive.g that didn't surface with 3.0.1.

          Ashutosh Chauhan Feel free to add if I have missed anything.

          Thiruvel Thirumoolan added a comment -

          I am also working on running HCatalog unit tests with 0.23 and it needs hive jars with this fix [as hcat depends on pig10 which in turn depends on antlr 3.4]. Currently I push hive jars locally for testing. But would be nice to see this in.

          Ashutosh Chauhan added a comment -

          Yeah, this will make life of HCatalog users much easier. I will take a look at it soon.

          Ashutosh Chauhan added a comment -
          Ashutosh Chauhan added a comment -

          Thanks Thriuvel for addressing comments. Latest patch looks good. +1. Running tests now.

          Ashutosh Chauhan added a comment -

          All the tests passed, except for TestNegativeCliDriver.set_table_property.q which needs update to the .q.out file.

          Ashutosh Chauhan added a comment -

          I ran tests on trunk.

          Thiruvel Thirumoolan added a comment -

          Updated patch on phabricator (https://reviews.facebook.net/D7527) with set_table_property.q.out changes and re-ran all tests on trunk. Attached trunk_2 patch to the JIRA for reference.

          Ashutosh Chauhan added a comment -

          Thanks Thiruvel for the update. Running tests again.

          Ashutosh Chauhan added a comment -

          Committed to trunk. Thanks, Thiruvel!

          Ashutosh Chauhan added a comment -

          Note to other devs: Please do ant very-clean package once after upping your repos to this version.

          Hudson added a comment -

          Integrated in hive-trunk-hadoop1 #15 (See https://builds.apache.org/job/hive-trunk-hadoop1/15/)
          HIVE-2439 : Upgrade antlr version to 3.4 (Thiruvel Thirumoolan via Ashutosh Chauhan) (Revision 1433458)

          Result = ABORTED
          hashutosh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1433458
          Files :

          • /hive/trunk/ivy/libraries.properties
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/ASTErrorNode.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/ASTNode.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/Hive.g
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/ParseDriver.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/UnparseTranslator.java
          • /hive/trunk/ql/src/test/results/clientnegative/archive_partspec3.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/clusterbyorderby.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/column_rename3.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/lateral_view_join.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/select_charliteral.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/set_table_property.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/show_columns2.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/show_tables_bad1.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/show_tables_bad2.q.out
          • /hive/trunk/ql/src/test/results/compiler/errors/invalid_select.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/case_sensitivity.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/cast1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input20.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input7.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input8.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input9.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_part1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_testsequencefile.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_testxpath.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_testxpath2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join7.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join8.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample7.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/subq.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf_case.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf_when.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/union.q.out
          Thiruvel Thirumoolan added a comment -

          Thanks Ashutosh!

          Would it be possible to get this into 10 or 10.1? Given that HCatalog v5 has just been cut, it can depend on Hive 10. I am also working on Hive10 + Hadoop23 (0.23.x) unit tests and might have a patch to trunk and branch10 soon. So 10 has some more changes (at-least from my end).

          Hudson added a comment -

          Integrated in Hive-trunk-h0.21 #1914 (See https://builds.apache.org/job/Hive-trunk-h0.21/1914/)
          HIVE-2439 : Upgrade antlr version to 3.4 (Thiruvel Thirumoolan via Ashutosh Chauhan) (Revision 1433458)

          Result = FAILURE
          hashutosh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1433458
          Files :

          • /hive/trunk/ivy/libraries.properties
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/ASTErrorNode.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/ASTNode.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/Hive.g
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/ParseDriver.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/UnparseTranslator.java
          • /hive/trunk/ql/src/test/results/clientnegative/archive_partspec3.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/clusterbyorderby.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/column_rename3.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/lateral_view_join.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/select_charliteral.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/set_table_property.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/show_columns2.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/show_tables_bad1.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/show_tables_bad2.q.out
          • /hive/trunk/ql/src/test/results/compiler/errors/invalid_select.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/case_sensitivity.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/cast1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input20.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input7.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input8.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input9.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_part1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_testsequencefile.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_testxpath.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_testxpath2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join7.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join8.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample7.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/subq.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf_case.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf_when.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/union.q.out
          Hudson added a comment -

          Integrated in Hive-trunk-hadoop2 #67 (See https://builds.apache.org/job/Hive-trunk-hadoop2/67/)
          HIVE-2439 : Upgrade antlr version to 3.4 (Thiruvel Thirumoolan via Ashutosh Chauhan) (Revision 1433458)

          Result = FAILURE
          hashutosh : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1433458
          Files :

          • /hive/trunk/ivy/libraries.properties
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/ASTErrorNode.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/ASTNode.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/Hive.g
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/ParseDriver.java
          • /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/parse/UnparseTranslator.java
          • /hive/trunk/ql/src/test/results/clientnegative/archive_partspec3.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/clusterbyorderby.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/column_rename3.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/lateral_view_join.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/select_charliteral.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/set_table_property.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/show_columns2.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/show_tables_bad1.q.out
          • /hive/trunk/ql/src/test/results/clientnegative/show_tables_bad2.q.out
          • /hive/trunk/ql/src/test/results/compiler/errors/invalid_select.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/case_sensitivity.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/cast1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/groupby6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input20.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input7.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input8.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input9.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_part1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_testsequencefile.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_testxpath.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/input_testxpath2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join7.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/join8.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample2.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample3.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample5.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/sample7.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/subq.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf1.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf4.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf6.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf_case.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/udf_when.q.out
          • /hive/trunk/ql/src/test/results/compiler/parse/union.q.out

            People

            • Assignee:
              Thiruvel Thirumoolan
              Reporter:
              Ashutosh Chauhan
            • Votes:
              0 Vote for this issue
              Watchers:
              13 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development