Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-22704

Distribution package incorrectly ships the upgrade.order files from the metastore module

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.1.3, 3.2.0, 4.0.0
    • Component/s: None
    • Labels:
      None

      Description

      Expected would be to take the upgrade.order from the standalon-metastore but HIVE-19938 have broke that when it introduced a regex

      $ echo asd > ./metastore/scripts/upgrade/postgres/upgrade.order.postgres
      $ mvn install -pl packaging/ -Pdist -am -DskipTests -q
      $ cat ./packaging/target/apache-hive-4.0.0-SNAPSHOT-bin/apache-hive-4.0.0-SNAPSHOT-bin/scripts/metastore/upgrade/postgres/upgrade.order.postgres
      asd
      

        Attachments

        1. HIVE-22704.01.patch
          3 kB
          Zoltan Haindrich
        2. HIVE-22704.01.patch
          3 kB
          Zoltan Haindrich

          Activity

            People

            • Assignee:
              kgyrtkirk Zoltan Haindrich
              Reporter:
              kgyrtkirk Zoltan Haindrich
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: