Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-11473

Upgrade Spark dependency to 1.5 [Spark Branch]

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: spark-branch, 1.3.0, 2.0.0
    • Component/s: Spark
    • Labels:
      None

      Description

      In Spark 1.5, SparkListener interface is changed. So HoS may fail to create the spark client if the un-implemented event callback method is invoked.

        Attachments

        1. HIVE-11473.1-spark.patch
          3 kB
          Rui Li
        2. HIVE-11473.2-spark.patch
          3 kB
          Xuefu Zhang
        3. HIVE-11473.3-spark.patch
          9 kB
          Rui Li
        4. HIVE-11473.3-spark.patch
          9 kB
          Rui Li

          Issue Links

            Activity

              People

              • Assignee:
                lirui Rui Li
                Reporter:
                jxiang Jimmy Xiang
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: