Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-7955 Improve naming of classes, methods, and variables related to block replication and recovery
  3. HDFS-9869

Erasure Coding: Rename replication-based names in BlockManager to more generic [part-2]

VotersStop watchingWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Reviewed

    Description

      The idea of this jira is to rename the following entities in BlockManager as,

      • PendingReplicationBlocks to PendingReconstructionBlocks
      • excessReplicateMap to extraRedundancyMap

      Attachments

        1. HDFS-9869-001.patch
          64 kB
          Rakesh Radhakrishnan
        2. HDFS-9869-002.patch
          95 kB
          Rakesh Radhakrishnan
        3. HDFS-9869-003.patch
          112 kB
          Rakesh Radhakrishnan
        4. HDFS-9869-004.patch
          112 kB
          Rakesh Radhakrishnan
        5. HDFS-9869-005.patch
          109 kB
          Rakesh Radhakrishnan
        6. HDFS-9869-006.patch
          111 kB
          Rakesh Radhakrishnan
        7. HDFS-9869-007.patch
          112 kB
          Rakesh Radhakrishnan

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            rakeshr Rakesh Radhakrishnan
            rakeshr Rakesh Radhakrishnan
            Votes:
            0 Vote for this issue
            Watchers:
            5 Stop watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment