Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-7955 Improve naming of classes, methods, and variables related to block replication and recovery
  3. HDFS-9857

Erasure Coding: Rename replication-based names in BlockManager to more generic [part-1]

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Sub-task
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 3.0.0-alpha1
    • erasure-coding
    • None
    • Reviewed

    Description

      The idea of this jira is to rename the following entities in BlockManager as,

      • UnderReplicatedBlocks to LowRedundancyBlocks
      • neededReplications to neededReconstruction
      • replicationQueuesInitializer to reconstructionQueuesInitializer

      Thanks Zhe Zhang, Andrew Wang for the useful discussions

      Attachments

        1. HDFS-9857-02.patch
          111 kB
          Rakesh Radhakrishnan
        2. HDFS-9857-004.patch
          112 kB
          Rakesh Radhakrishnan
        3. HDFS-9857-003.patch
          111 kB
          Rakesh Radhakrishnan
        4. HDFS-9857-001.patch
          98 kB
          Rakesh Radhakrishnan

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            rakeshr Rakesh Radhakrishnan
            rakeshr Rakesh Radhakrishnan
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment