Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-980

Convert FSNamesystem lock to ReadWriteLock

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.22.0
    • Fix Version/s: None
    • Component/s: namenode
    • Labels:
      None

      Description

      As Dhruba noted here there would be substantial benefits to converting the FSNamesystem lock over to a ReadWriteLock. The first would be an ability to provide concurrent readers with a throughput increase, and the second would be more safety for operations like in HDFS-909.

        Issue Links

          Activity

          Todd Lipcon created issue -
          Todd Lipcon made changes -
          Field Original Value New Value
          Link This issue relates to HDFS-909 [ HDFS-909 ]
          dhruba borthakur added a comment -

          Duplicate of HDFS-1093

          dhruba borthakur made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          57d 1h 28m 1 dhruba borthakur 14/Apr/10 06:44

            People

            • Assignee:
              Unassigned
              Reporter:
              Todd Lipcon
            • Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development