Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-9400

TestRollingUpgradeRollback fails on branch-2.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      During a Jenkins pre-commit run on branch-2 for the HDFS-9394 patch, we noticed a pre-existing failure in TestRollingUpgradeRollback. I have confirmed that this test is failing in branch-2 only. It passes in trunk, and it passes in branch-2.7.

      1. HDFS-9400-branch-2.001.patch
        6 kB
        Mingliang Liu
      2. HDFS-9400-branch-2.002.patch
        6 kB
        Brahma Reddy Battula
      3. HDFS-9400-branch-2.patch
        0.9 kB
        Brahma Reddy Battula

        Issue Links

          Activity

          cnauroth Chris Nauroth added a comment -

          I have marked this as a 2.8.0 blocker in case the test failure represents a real product bug in rolling upgrade.

          liuml07 Mingliang Liu added a comment -

          Thanks for reporting this Chris Nauroth. I can easily reproduce this bug locally.

          brahmareddy Brahma Reddy Battula added a comment -

          Even this testcase fails without HDFS-8332 in Trunk. After dfs.close(); dfs is object getting used TestRollingUpgrade.queryForPreparation(dfs); so just before this call add dfs = dfsCluster.getFileSystem(0); even which is same with trunk.

          java.io.IOException: Filesystem closed
          	at org.apache.hadoop.hdfs.DFSClient.checkOpen(DFSClient.java:455)
          	at org.apache.hadoop.hdfs.DFSClient.rollingUpgrade(DFSClient.java:2421)
          	at org.apache.hadoop.hdfs.DistributedFileSystem.rollingUpgrade(DistributedFileSystem.java:1313)
          	at org.apache.hadoop.hdfs.TestRollingUpgrade.queryForPreparation(TestRollingUpgrade.java:583)
          	at org.apache.hadoop.hdfs.TestRollingUpgradeRollback.testRollbackWithHAQJM(TestRollingUpgradeRollback.java:231)
          
          brahmareddy Brahma Reddy Battula added a comment -

          Forgot to mention HDFS-8979 adds checkOpen(); to branch-2 which leads this issue.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 10s docker + precommit patch detected.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 7m 37s branch-2 passed
          +1 compile 0m 36s branch-2 passed with JDK v1.8.0_60
          +1 compile 0m 33s branch-2 passed with JDK v1.7.0_79
          +1 checkstyle 0m 18s branch-2 passed
          +1 mvneclipse 0m 19s branch-2 passed
          -1 findbugs 2m 3s hadoop-hdfs-project/hadoop-hdfs in branch-2 has 1 extant Findbugs warnings.
          +1 javadoc 1m 7s branch-2 passed with JDK v1.8.0_60
          +1 javadoc 1m 50s branch-2 passed with JDK v1.7.0_79
          +1 mvninstall 0m 38s the patch passed
          +1 compile 0m 34s the patch passed with JDK v1.8.0_60
          +1 javac 0m 34s the patch passed
          +1 compile 0m 33s the patch passed with JDK v1.7.0_79
          +1 javac 0m 33s the patch passed
          +1 checkstyle 0m 15s the patch passed
          +1 mvneclipse 0m 14s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 2m 5s the patch passed
          +1 javadoc 1m 9s the patch passed with JDK v1.8.0_60
          +1 javadoc 1m 53s the patch passed with JDK v1.7.0_79
          -1 unit 47m 49s hadoop-hdfs in the patch failed with JDK v1.8.0_60.
          -1 unit 45m 47s hadoop-hdfs in the patch failed with JDK v1.7.0_79.
          -1 asflicense 0m 20s Patch generated 58 ASF License warnings.
          118m 27s



          Reason Tests
          JDK v1.8.0_60 Failed junit tests hadoop.hdfs.TestDistributedFileSystem
            hadoop.hdfs.server.namenode.ha.TestDNFencing
          JDK v1.7.0_79 Failed junit tests hadoop.hdfs.server.balancer.TestBalancerWithMultipleNameNodes
            hadoop.hdfs.server.namenode.ha.TestRetryCacheWithHA
            hadoop.hdfs.TestDistributedFileSystem
            hadoop.hdfs.server.namenode.snapshot.TestSnapshotDiffReport



          Subsystem Report/Notes
          Docker Client=1.7.1 Server=1.7.1 Image:test-patch-base-hadoop-date2015-11-08
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12771221/HDFS-9400-branch-2.patch
          JIRA Issue HDFS-9400
          Optional Tests asflicense javac javadoc mvninstall unit findbugs checkstyle compile
          uname Linux c4cc5dbad9fa 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /home/jenkins/jenkins-slave/workspace/PreCommit-HDFS-Build/patchprocess/apache-yetus-ee5baeb/precommit/personality/hadoop.sh
          git revision branch-2 / 385dcc4
          Default Java 1.7.0_79
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_60 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_79
          findbugs v3.0.0
          findbugs https://builds.apache.org/job/PreCommit-HDFS-Build/13433/artifact/patchprocess/branch-findbugs-hadoop-hdfs-project_hadoop-hdfs-warnings.html
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/13433/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_60.txt
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/13433/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_79.txt
          unit test logs https://builds.apache.org/job/PreCommit-HDFS-Build/13433/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.8.0_60.txt https://builds.apache.org/job/PreCommit-HDFS-Build/13433/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_79.txt
          JDK v1.7.0_79 Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/13433/testReport/
          asflicense https://builds.apache.org/job/PreCommit-HDFS-Build/13433/artifact/patchprocess/patch-asflicense-problems.txt
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Max memory used 214MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/13433/console

          This message was automatically generated.

          brahmareddy Brahma Reddy Battula added a comment -

          Test failures and findbug warnings are unrelated..Raised HDFS-9401 to handle findbug error..Chris Nauroth kindly review..

          cnauroth Chris Nauroth added a comment -

          HDFS-8332 was purposefully reverted from branch-2 due to a compatibility concern. I'm surprised that this change would be required, and it might indicate that some aspect of the compatibility problem has crept back into branch-2.

          I did some investigation and used git bisect to pin it down to HDFS-8979. That's the first commit when the test started failing. That was supposed to be a Checkstyle cleanup, but perhaps a logic change got in there too. It's a big patch, so I'm still reviewing it.

          Mingliang Liu, could you please take a look too?

          liuml07 Mingliang Liu added a comment -

          Thank you Chris Nauroth for narrowing down the cause of this failing test. The HDFS-8979 was not supposed to contain logic change. Unfortunately it brought some changes which was actually added by HDFS-8332 in trunk.

          Thank you Brahma Reddy Battula for working on this and investigating the root cause. I totally agree with you that the root cause is calling checkOpen() in DFSClient class, brought by HDFS-8979 which obviously was not aware of the revert of HDFS-8332 from branch-2 when committing.

          The fix may be to simply revert the unnecessary checkOpen() method call brought by HDFS-8979. I tested the v1 patch locally on my Gentoo Linux and Mac, and it seems to work.

          liuml07 Mingliang Liu added a comment -

          By the way, Brahma Reddy Battula, feel free to consolidate the v1 patch to a refined one. I did not fully debug the failing test and may miss some context.

          brahmareddy Brahma Reddy Battula added a comment -

          The fix may be to simply revert the unnecessary checkOpen() method call brought by HDFS-8979.

          Yes, patch looks fine to me..Chris Nauroth do you think same..?

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 15s docker + precommit patch detected.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 8m 50s branch-2 passed
          +1 compile 0m 34s branch-2 passed with JDK v1.8.0_60
          +1 compile 0m 32s branch-2 passed with JDK v1.7.0_79
          +1 checkstyle 0m 16s branch-2 passed
          +1 mvneclipse 0m 18s branch-2 passed
          -1 findbugs 2m 19s hadoop-hdfs-project/hadoop-hdfs-client in branch-2 has 5 extant Findbugs warnings.
          +1 javadoc 0m 31s branch-2 passed with JDK v1.8.0_60
          +1 javadoc 0m 29s branch-2 passed with JDK v1.7.0_79
          +1 mvninstall 0m 37s the patch passed
          +1 compile 0m 33s the patch passed with JDK v1.8.0_60
          +1 javac 0m 33s the patch passed
          +1 compile 0m 31s the patch passed with JDK v1.7.0_79
          +1 javac 0m 31s the patch passed
          -1 checkstyle 0m 13s Patch generated 1 new checkstyle issues in hadoop-hdfs-project/hadoop-hdfs-client (total was 57, now 57).
          +1 mvneclipse 0m 15s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 2m 23s the patch passed
          +1 javadoc 0m 30s the patch passed with JDK v1.8.0_60
          +1 javadoc 0m 33s the patch passed with JDK v1.7.0_79
          +1 unit 1m 16s hadoop-hdfs-client in the patch passed with JDK v1.8.0_60.
          +1 unit 1m 11s hadoop-hdfs-client in the patch passed with JDK v1.7.0_79.
          +1 asflicense 0m 31s Patch does not generate ASF License warnings.
          26m 6s



          Subsystem Report/Notes
          Docker Client=1.7.1 Server=1.7.1 Image:test-patch-base-hadoop-date2015-11-10
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12771477/HDFS-9400-branch-2.001.patch
          JIRA Issue HDFS-9400
          Optional Tests asflicense javac javadoc mvninstall unit findbugs checkstyle compile
          uname Linux 5c640cedc021 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /home/jenkins/jenkins-slave/workspace/PreCommit-HDFS-Build/patchprocess/apache-yetus-ee5baeb/precommit/personality/hadoop.sh
          git revision branch-2 / c91bd3a
          Default Java 1.7.0_79
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_60 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_79
          findbugs v3.0.0
          findbugs https://builds.apache.org/job/PreCommit-HDFS-Build/13450/artifact/patchprocess/branch-findbugs-hadoop-hdfs-project_hadoop-hdfs-client-warnings.html
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/13450/artifact/patchprocess/diff-checkstyle-hadoop-hdfs-project_hadoop-hdfs-client.txt
          JDK v1.7.0_79 Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/13450/testReport/
          modules C: hadoop-hdfs-project/hadoop-hdfs-client U: hadoop-hdfs-project/hadoop-hdfs-client
          Max memory used 221MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/13450/console

          This message was automatically generated.

          liuml07 Mingliang Liu added a comment -

          The test report seems good?

          cnauroth Chris Nauroth added a comment -

          Brahma Reddy Battula, the patch looks mostly good. One thing I noticed is that prior to HDFS-8979, getStoragePolicy already had a call to checkOpen, but getStoragePolicies did not. The current patch here is removing the checkOpen call from getStoragePolicy though. Can you please revise the patch one more time to remove the call from getStoragePolicies instead? Thank you.

          brahmareddy Brahma Reddy Battula added a comment -

          Chris Nauroth thanks a lot.. will upload patch soon.

          brahmareddy Brahma Reddy Battula added a comment -

          Uploaded the patch..Chris Nauroth kindly review..thanks

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 9s docker + precommit patch detected.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 13m 16s branch-2 passed
          +1 compile 0m 28s branch-2 passed with JDK v1.8.0_66
          +1 compile 0m 31s branch-2 passed with JDK v1.7.0_85
          +1 checkstyle 0m 16s branch-2 passed
          +1 mvnsite 0m 38s branch-2 passed
          +1 mvneclipse 0m 17s branch-2 passed
          -1 findbugs 2m 0s hadoop-hdfs-project/hadoop-hdfs-client in branch-2 has 5 extant Findbugs warnings.
          +1 javadoc 0m 22s branch-2 passed with JDK v1.8.0_66
          +1 javadoc 0m 25s branch-2 passed with JDK v1.7.0_85
          +1 mvninstall 0m 35s the patch passed
          +1 compile 0m 29s the patch passed with JDK v1.8.0_66
          -1 javac 3m 51s hadoop-hdfs-project_hadoop-hdfs-client-jdk1.8.0_66 with JDK v1.8.0_66 generated 2 new issues (was 24, now 24).
          +1 javac 0m 29s the patch passed
          +1 compile 0m 30s the patch passed with JDK v1.7.0_85
          -1 javac 4m 21s hadoop-hdfs-project_hadoop-hdfs-client-jdk1.7.0_85 with JDK v1.7.0_85 generated 2 new issues (was 25, now 25).
          +1 javac 0m 30s the patch passed
          -1 checkstyle 0m 12s Patch generated 1 new checkstyle issues in hadoop-hdfs-project/hadoop-hdfs-client (total was 57, now 57).
          +1 mvnsite 0m 36s the patch passed
          +1 mvneclipse 0m 13s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 2m 5s the patch passed
          +1 javadoc 0m 21s the patch passed with JDK v1.8.0_66
          +1 javadoc 0m 25s the patch passed with JDK v1.7.0_85
          +1 unit 0m 55s hadoop-hdfs-client in the patch passed with JDK v1.8.0_66.
          +1 unit 0m 59s hadoop-hdfs-client in the patch passed with JDK v1.7.0_85.
          +1 asflicense 0m 24s Patch does not generate ASF License warnings.
          28m 43s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:date2015-11-18
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12773003/HDFS-9400-branch-2.002.patch
          JIRA Issue HDFS-9400
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux f5d112e91c69 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /home/jenkins/jenkins-slave/workspace/PreCommit-HDFS-Build/patchprocess/apache-yetus-3f4279a/precommit/personality/hadoop.sh
          git revision branch-2 / d5782a4
          findbugs v3.0.0
          findbugs https://builds.apache.org/job/PreCommit-HDFS-Build/13548/artifact/patchprocess/branch-findbugs-hadoop-hdfs-project_hadoop-hdfs-client-warnings.html
          javac hadoop-hdfs-project_hadoop-hdfs-client-jdk1.8.0_66: https://builds.apache.org/job/PreCommit-HDFS-Build/13548/artifact/patchprocess/diff-compile-javac-hadoop-hdfs-project_hadoop-hdfs-client-jdk1.8.0_66.txt
          javac hadoop-hdfs-project_hadoop-hdfs-client-jdk1.7.0_85: https://builds.apache.org/job/PreCommit-HDFS-Build/13548/artifact/patchprocess/diff-compile-javac-hadoop-hdfs-project_hadoop-hdfs-client-jdk1.7.0_85.txt
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/13548/artifact/patchprocess/diff-checkstyle-hadoop-hdfs-project_hadoop-hdfs-client.txt
          JDK v1.7.0_85 Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/13548/testReport/
          modules C: hadoop-hdfs-project/hadoop-hdfs-client U: hadoop-hdfs-project/hadoop-hdfs-client
          Max memory used 73MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/13548/console

          This message was automatically generated.

          brahmareddy Brahma Reddy Battula added a comment -

          findbugs and javac errors are unrelated this patch.May be we can raise seperate issue for this..?

          cnauroth Chris Nauroth added a comment -

          I have committed this to branch-2. Brahma and Mingliang, thank you for the help!

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8821 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8821/)
          HDFS-9400. TestRollingUpgradeRollback fails on branch-2. Contributed by (cnauroth: rev bad2afe39a3a589ca9d25de297a080b974645fea)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2621 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2621/)
          HDFS-9400. TestRollingUpgradeRollback fails on branch-2. Contributed by (cnauroth: rev bad2afe39a3a589ca9d25de297a080b974645fea)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #680 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/680/)
          HDFS-9400. TestRollingUpgradeRollback fails on branch-2. Contributed by (cnauroth: rev bad2afe39a3a589ca9d25de297a080b974645fea)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #692 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/692/)
          HDFS-9400. TestRollingUpgradeRollback fails on branch-2. Contributed by (cnauroth: rev bad2afe39a3a589ca9d25de297a080b974645fea)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #1418 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1418/)
          HDFS-9400. TestRollingUpgradeRollback fails on branch-2. Contributed by (cnauroth: rev bad2afe39a3a589ca9d25de297a080b974645fea)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #616 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/616/)
          HDFS-9400. TestRollingUpgradeRollback fails on branch-2. Contributed by (cnauroth: rev bad2afe39a3a589ca9d25de297a080b974645fea)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2554 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2554/)
          HDFS-9400. TestRollingUpgradeRollback fails on branch-2. Contributed by (cnauroth: rev bad2afe39a3a589ca9d25de297a080b974645fea)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt

            People

            • Assignee:
              brahmareddy Brahma Reddy Battula
              Reporter:
              cnauroth Chris Nauroth
            • Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development