Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-9384

TestWebHdfsContentLength intermittently hangs and fails due to TCP conversation mismatch between client and server.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      TestWebHdfsContentLength runs a simple hand-coded HTTP server in a background thread to simulate some WebHDFS server responses. In some environments (notably Windows), I have observed that the test can hang and fail intermittently. The root cause is that the server fails to fully consume the client's input. This causes a mismatch in the TCP conversation state, and ultimately the client side hangs, then aborts after the 60-second socket timeout.

      1. HDFS-9384.001.patch
        1 kB
        Chris Nauroth
      2. HDFS-9384.002.patch
        2 kB
        Chris Nauroth
      3. HDFS-9384.003.patch
        2 kB
        Chris Nauroth

        Activity

        cnauroth Chris Nauroth added a comment -

        I'm attaching a patch to fix the problem. I've run with this patch multiple times in multiple environments, and the test failure no longer repros.

        I left a comment in the patch explaining the problem in more detail. I'm pasting it here for convenience:

                  // The second request can be sent with Transfer-Encoding: chunked.
                  // The Java HTTP client tends to split the headers and the chunked
                  // body into separate writes, so the first read above likely only read
                  // the headers.  We must fully consume the input to prevent a hang on
                  // the client side.
        

        TestWebHdfsTimeouts is an example of an existing similar test that already works correctly, because it follows the same strategy of fully consuming the input sent by the client.

        cnauroth Chris Nauroth added a comment -

        Xiaoyu Yao, would you please code review? Thank you!

        cnauroth Chris Nauroth added a comment -

        I just realized that this test suite has no timeout. I'd like to take the opportunity to add a timeout, so here is patch v002.

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 7s docker + precommit patch detected.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 3m 34s trunk passed
        +1 compile 0m 27s trunk passed with JDK v1.8.0_60
        +1 compile 0m 26s trunk passed with JDK v1.7.0_79
        +1 checkstyle 0m 11s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 1m 56s trunk passed
        +1 javadoc 0m 23s trunk passed with JDK v1.8.0_60
        +1 javadoc 0m 24s trunk passed with JDK v1.7.0_79
        +1 mvninstall 0m 31s the patch passed
        +1 compile 0m 25s the patch passed with JDK v1.8.0_60
        +1 javac 0m 25s the patch passed
        +1 compile 0m 26s the patch passed with JDK v1.7.0_79
        +1 javac 0m 26s the patch passed
        +1 checkstyle 0m 11s the patch passed
        +1 mvneclipse 0m 13s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 2m 7s the patch passed
        +1 javadoc 0m 20s the patch passed with JDK v1.8.0_60
        +1 javadoc 0m 25s the patch passed with JDK v1.7.0_79
        +1 unit 0m 54s hadoop-hdfs-client in the patch passed with JDK v1.8.0_60.
        +1 unit 0m 58s hadoop-hdfs-client in the patch passed with JDK v1.7.0_79.
        +1 asflicense 0m 25s Patch does not generate ASF License warnings.
        17m 15s



        Subsystem Report/Notes
        Docker Client=1.7.1 Server=1.7.1 Image:test-patch-base-hadoop-date2015-11-05
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12770858/HDFS-9384.002.patch
        JIRA Issue HDFS-9384
        Optional Tests asflicense javac javadoc mvninstall unit findbugs checkstyle compile
        uname Linux ef3eaa0b3ff3 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /home/jenkins/jenkins-slave/workspace/PreCommit-HDFS-Build/patchprocess/apache-yetus-e8bd3ad/precommit/personality/hadoop.sh
        git revision trunk / 21c0e3e
        Default Java 1.7.0_79
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_60 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_79
        findbugs v3.0.0
        JDK v1.7.0_79 Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/13402/testReport/
        modules C: hadoop-hdfs-project/hadoop-hdfs-client U: hadoop-hdfs-project/hadoop-hdfs-client
        Max memory used 226MB
        Powered by Apache Yetus http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/13402/console

        This message was automatically generated.

        arpitagarwal Arpit Agarwal added a comment -

        +1, nice find.

        arpitagarwal Arpit Agarwal added a comment -

        And +1 from Jenkins too! I can't recall the last time I saw that.

        cnauroth Chris Nauroth added a comment -

        And +1 from Jenkins too! I can't recall the last time I saw that.

        To be fair, with the split into hadoop-hdfs-client, this was only running a small and quick subset of the tests. I'll take it though.

        xyao Xiaoyu Yao added a comment -

        Sorry for the late. The fix looks good to me. I only have one question: The content read from the new while loop if any could overwrite the header read earlier.
        Should we append them to a StringBuffer and return the full content or it does not matter for the test?

        while (client.getInputStream().read(buf) > 0);
        
        cnauroth Chris Nauroth added a comment -

        Hi Xiaoyu. Thank you for reviewing.

        Technically, it's not necessary to retain the full contents of the client request, because the tests only run assertions related to the header information, which is in the first buffer read. However, I still think your suggestion is helpful for the sake of making the code more intuitive. I have attached patch v003.

        xyao Xiaoyu Yao added a comment -

        Thanks Chris Nauroth for addressing my comments. Patch v003 looks pretty good to me. +1 pending Jenkins.

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 7s docker + precommit patch detected.
        +1 @author 0m 1s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 3m 22s trunk passed
        +1 compile 0m 28s trunk passed with JDK v1.8.0_60
        +1 compile 0m 27s trunk passed with JDK v1.7.0_79
        +1 checkstyle 0m 12s trunk passed
        +1 mvneclipse 0m 12s trunk passed
        +1 findbugs 2m 1s trunk passed
        +1 javadoc 0m 24s trunk passed with JDK v1.8.0_60
        +1 javadoc 0m 26s trunk passed with JDK v1.7.0_79
        +1 mvninstall 0m 34s the patch passed
        +1 compile 0m 30s the patch passed with JDK v1.8.0_60
        +1 javac 0m 30s the patch passed
        +1 compile 0m 27s the patch passed with JDK v1.7.0_79
        +1 javac 0m 27s the patch passed
        +1 checkstyle 0m 11s the patch passed
        +1 mvneclipse 0m 13s the patch passed
        +1 whitespace 0m 0s Patch has no whitespace issues.
        +1 findbugs 2m 14s the patch passed
        +1 javadoc 0m 23s the patch passed with JDK v1.8.0_60
        +1 javadoc 0m 24s the patch passed with JDK v1.7.0_79
        +1 unit 1m 0s hadoop-hdfs-client in the patch passed with JDK v1.8.0_60.
        +1 unit 1m 0s hadoop-hdfs-client in the patch passed with JDK v1.7.0_79.
        +1 asflicense 0m 25s Patch does not generate ASF License warnings.
        17m 48s



        Subsystem Report/Notes
        Docker Client=1.7.1 Server=1.7.1 Image:test-patch-base-hadoop-date2015-11-05
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12770882/HDFS-9384.003.patch
        JIRA Issue HDFS-9384
        Optional Tests asflicense javac javadoc mvninstall unit findbugs checkstyle compile
        uname Linux c5f265d5e945 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /home/jenkins/jenkins-slave/workspace/PreCommit-HDFS-Build@2/patchprocess/apache-yetus-ee5baeb/precommit/personality/hadoop.sh
        git revision trunk / 286cc64
        Default Java 1.7.0_79
        Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_60 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_79
        findbugs v3.0.0
        JDK v1.7.0_79 Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/13410/testReport/
        modules C: hadoop-hdfs-project/hadoop-hdfs-client U: hadoop-hdfs-project/hadoop-hdfs-client
        Max memory used 228MB
        Powered by Apache Yetus http://yetus.apache.org
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/13410/console

        This message was automatically generated.

        cnauroth Chris Nauroth added a comment -

        I have committed this to trunk and branch-2. Arpit and Xiaoyu, thank you for the code reviews.

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #8766 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8766/)
        HDFS-9384. TestWebHdfsContentLength intermittently hangs and fails due (cnauroth: rev 66c096731052fb187dc49f5bcaec8432c4b92d0c)

        • hadoop-hdfs-project/hadoop-hdfs-client/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsContentLength.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #646 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/646/)
        HDFS-9384. TestWebHdfsContentLength intermittently hangs and fails due (cnauroth: rev 66c096731052fb187dc49f5bcaec8432c4b92d0c)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsContentLength.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #636 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/636/)
        HDFS-9384. TestWebHdfsContentLength intermittently hangs and fails due (cnauroth: rev 66c096731052fb187dc49f5bcaec8432c4b92d0c)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsContentLength.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2576 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2576/)
        HDFS-9384. TestWebHdfsContentLength intermittently hangs and fails due (cnauroth: rev 66c096731052fb187dc49f5bcaec8432c4b92d0c)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsContentLength.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk #1369 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1369/)
        HDFS-9384. TestWebHdfsContentLength intermittently hangs and fails due (cnauroth: rev 66c096731052fb187dc49f5bcaec8432c4b92d0c)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsContentLength.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #577 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/577/)
        HDFS-9384. TestWebHdfsContentLength intermittently hangs and fails due (cnauroth: rev 66c096731052fb187dc49f5bcaec8432c4b92d0c)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsContentLength.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2516 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2516/)
        HDFS-9384. TestWebHdfsContentLength intermittently hangs and fails due (cnauroth: rev 66c096731052fb187dc49f5bcaec8432c4b92d0c)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/test/java/org/apache/hadoop/hdfs/web/TestWebHdfsContentLength.java

          People

          • Assignee:
            cnauroth Chris Nauroth
            Reporter:
            cnauroth Chris Nauroth
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development