Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-9193

Fix incorrect references the usages of the DN in dfshealth.js

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None

      Issue Links

        Activity

        shahrs87 Rushabh S Shah added a comment -

        Haohui Mai: do we need to commit to 2.7.2 also ?

        My bad. I didn't see that the namenode UI change went only to branch-2 not branch-2.7
        Sorry for the noise.

        shahrs87 Rushabh S Shah added a comment -

        Haohui Mai: do we need to commit to 2.7.2 also ?

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #452 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/452/)
        HDFS-9193. Fix incorrect references the usages of the DN in (wheat9: rev 3b85bd7c3391719624a261f061a67cc4356be477)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2392 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2392/)
        HDFS-9193. Fix incorrect references the usages of the DN in (wheat9: rev 3b85bd7c3391719624a261f061a67cc4356be477)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2421 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2421/)
        HDFS-9193. Fix incorrect references the usages of the DN in (wheat9: rev 3b85bd7c3391719624a261f061a67cc4356be477)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #477 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/477/)
        HDFS-9193. Fix incorrect references the usages of the DN in (wheat9: rev 3b85bd7c3391719624a261f061a67cc4356be477)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk-Java8 #485 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/485/)
        HDFS-9193. Fix incorrect references the usages of the DN in (wheat9: rev 3b85bd7c3391719624a261f061a67cc4356be477)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk #1216 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1216/)
        HDFS-9193. Fix incorrect references the usages of the DN in (wheat9: rev 3b85bd7c3391719624a261f061a67cc4356be477)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #8564 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8564/)
        HDFS-9193. Fix incorrect references the usages of the DN in (wheat9: rev 3b85bd7c3391719624a261f061a67cc4356be477)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        wheat9 Haohui Mai added a comment -

        Thanks for reporting. +1. Will commit shortly.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 0m 0s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 release audit 0m 12s The applied patch generated 1 release audit warnings.
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
            0m 16s  



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12764849/HDFS-9193.patch
        Optional Tests  
        git revision trunk / fdf02d1
        Release Audit https://builds.apache.org/job/PreCommit-HDFS-Build/12778/artifact/patchprocess/patchReleaseAuditProblems.txt
        Java 1.7.0_55
        uname Linux asf901.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12778/console

        This message was automatically generated.

        lichangleo Chang Li added a comment -

        the error is caused by a reference error happened in dfshealth.js when trying to load datanodes tab page

        } else if (u.usedPercentage < 85) {
        

        the u is defined no where
        uploaded patch fix this problem


          People

          • Assignee:
            lichangleo Chang Li
            Reporter:
            lichangleo Chang Li
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development