Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-9176

TestDirectoryScanner#testThrottling often fails.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Target Version/s:
    1. HDFS-9176.001.patch
      1 kB
      Daniel Templeton
    2. HDFS-9176.002.patch
      2 kB
      Daniel Templeton

      Issue Links

        Activity

        templedf Daniel Templeton added a comment -

        It's probably the timing-based nature of the test. I'll dig into the errors and see what I can do.

        templedf Daniel Templeton added a comment -

        The failure was not what I was expecting. There is a test to validate that things shut down promptly when requested, and that's what was failing. And it was failing big time. The test allows for a couple of seconds. The failured shutdowns were taking hours.

        But, it only failed twice. Since those two failures, the test has passed in the last 5 Jenkins runs. Since it appears to be working now, I'm going to close this issue. If it reappears later, we can reopen it.

        templedf Daniel Templeton added a comment -

        The test failed twice is an odd way and hasn't failed since in the last 5 runs. I'm going to blame environment or other changes.

        templedf Daniel Templeton added a comment -

        The latest build hit the same issue again, so it wasn't just a temporary environmental effect.

        templedf Daniel Templeton added a comment -

        Doh. If you look carefully at these log lines, you'll see the issue:

        2015-10-05 15:22:33,725 [pool-53-thread-1] WARN  datanode.DirectoryScanner (DirectoryScanner.java:shutdown(527)) - DirectoryScanner: shutdown has been called, but periodic scanner not started
        2015-10-05 15:22:33,726 [Thread-911] INFO  datanode.TestDirectoryScanner (TestDirectoryScanner.java:testThrottling(675)) - Scanner took 3609189682ms to shutdown
        

        Notice that the shutdown() method is called in the same second as the assert fails, and yet the assert says that the shutdown took a very long time. The issue is that the assert is occasionally happening before the interrupter thread updates the timestamp.

        The attached patch should resolve the issue.

        templedf Daniel Templeton added a comment -

        This JIRA fixes a new test introduced by HDFS-8873.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 8m 1s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 57s There were no new javac warning messages.
        -1 release audit 0m 13s The applied patch generated 1 release audit warnings.
        +1 checkstyle 1m 25s There were no new checkstyle issues.
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 27s mvn install still works.
        +1 eclipse:eclipse 0m 38s The patch built with eclipse:eclipse.
        +1 findbugs 2m 28s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
        +1 native 1m 13s Pre-build of native portion
        -1 hdfs tests 200m 57s Tests failed in hadoop-hdfs.
            224m 23s  



        Reason Tests
        Failed unit tests hadoop.hdfs.web.TestWebHdfsContentLength
          hadoop.hdfs.security.TestDelegationTokenForProxyUser



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12765086/HDFS-9176.001.patch
        Optional Tests javac unit findbugs checkstyle
        git revision trunk / 30ac69c
        Release Audit https://builds.apache.org/job/PreCommit-HDFS-Build/12801/artifact/patchprocess/patchReleaseAuditProblems.txt
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/12801/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/12801/testReport/
        Java 1.7.0_55
        uname Linux asf901.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12801/console

        This message was automatically generated.

        templedf Daniel Templeton added a comment -

        Made patch a little more robust.

        eddyxu Lei (Eddy) Xu added a comment - - edited

        Daniel Templeton thanks a lot for the patch.

        One question:

        // If the scan didn't complete before the shutdown was run, check
        // that the shutdown was timely
        if (finalMs > 0) {
            LOG.info("Scanner took " + (Time.monotonicNow() - finalMs)
                     + "ms to shutdown");
            assertTrue("Scanner took too long to shutdown",
                       Time.monotonicNow() - finalMs < 1000L);
        }
        

        Because masterThread and reportCompileThreadPool will be terminated within 1 minutes,
        should we wait and retry several times here so that the above code has higher chance to be executed?

        templedf Daniel Templeton added a comment -

        Once the block scanner has run, there's no point in waiting any more. The threads that shutdown() would stop are already stopped.

        I have the throttle set to 1ms, which means that only one directory will be scanned per second. The idea is to slow the process down as much as possible. I'm guessing that there are sometimes fewer directories than 2x the number of threads, resulting in the scan completing early. There's no way to slow it down any more than that.

        I suppose one additional way to increase the likelihood of having the shutdown() thread run would be to reduce the scheduling delay to 1s or 500ms. Still no guarantee, but it would increase the odds.

        templedf Daniel Templeton added a comment -

        I poked at it a bit, and it's not possible to reduce the schedule delay. If it goes less than 2s, a different test fails because there wasn't enough time to let the waiting/running ratio stabilize.

        templedf Daniel Templeton added a comment -

        I made one small change to (slightly) reduce the likelihood that the shutdown timing test will be bypassed.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 8m 35s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 8m 40s There were no new javac warning messages.
        -1 release audit 0m 15s The applied patch generated 1 release audit warnings.
        +1 checkstyle 1m 31s There were no new checkstyle issues.
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 36s mvn install still works.
        +1 eclipse:eclipse 0m 35s The patch built with eclipse:eclipse.
        +1 findbugs 2m 42s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
        +1 native 1m 22s Pre-build of native portion
        -1 hdfs tests 241m 1s Tests failed in hadoop-hdfs.
            266m 20s  



        Reason Tests
        Failed unit tests hadoop.hdfs.web.TestWebHdfsTimeouts
          hadoop.hdfs.TestReplaceDatanodeOnFailure
          hadoop.hdfs.TestRenameWhileOpen
          hadoop.hdfs.security.TestDelegationTokenForProxyUser
          hadoop.hdfs.web.TestWebHdfsContentLength
          hadoop.hdfs.server.blockmanagement.TestBlockTokenWithDFSStriped
          hadoop.hdfs.TestRollingUpgrade



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12765200/HDFS-9176.001.patch
        Optional Tests javac unit findbugs checkstyle
        git revision trunk / 874c8ed
        Release Audit https://builds.apache.org/job/PreCommit-HDFS-Build/12812/artifact/patchprocess/patchReleaseAuditProblems.txt
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/12812/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/12812/testReport/
        Java 1.7.0_55
        uname Linux asf909.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12812/console

        This message was automatically generated.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 11m 55s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 10m 43s There were no new javac warning messages.
        -1 release audit 0m 19s The applied patch generated 1 release audit warnings.
        +1 checkstyle 1m 53s There were no new checkstyle issues.
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 2m 10s mvn install still works.
        +1 eclipse:eclipse 0m 48s The patch built with eclipse:eclipse.
        +1 findbugs 3m 26s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
        +1 native 1m 51s Pre-build of native portion
        -1 hdfs tests 97m 4s Tests failed in hadoop-hdfs.
            130m 14s  



        Reason Tests
        Failed unit tests hadoop.hdfs.web.TestWebHdfsTimeouts
          hadoop.hdfs.security.TestDelegationTokenForProxyUser
          hadoop.hdfs.web.TestWebHdfsContentLength
        Timed out tests org.apache.hadoop.hdfs.server.datanode.TestDirectoryScanner
          org.apache.hadoop.hdfs.web.TestWebHDFSAcl



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12765261/HDFS-9176.002.patch
        Optional Tests javac unit findbugs checkstyle
        git revision trunk / 6d5713a
        Release Audit https://builds.apache.org/job/PreCommit-HDFS-Build/12817/artifact/patchprocess/patchReleaseAuditProblems.txt
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/12817/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/12817/testReport/
        Java 1.7.0_55
        uname Linux asf909.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12817/console

        This message was automatically generated.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 7m 43s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 47s There were no new javac warning messages.
        -1 release audit 0m 18s The applied patch generated 1 release audit warnings.
        +1 checkstyle 1m 21s There were no new checkstyle issues.
        +1 whitespace 0m 1s The patch has no lines that end in whitespace.
        +1 install 1m 29s mvn install still works.
        +1 eclipse:eclipse 0m 34s The patch built with eclipse:eclipse.
        +1 findbugs 2m 28s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
        +1 native 1m 3s Pre-build of native portion
        -1 hdfs tests 161m 31s Tests failed in hadoop-hdfs.
            184m 19s  



        Reason Tests
        Timed out tests org.apache.hadoop.hdfs.server.namenode.ha.TestSeveralNameNodes
          org.apache.hadoop.hdfs.server.datanode.TestIncrementalBrVariations



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12765261/HDFS-9176.002.patch
        Optional Tests javac unit findbugs checkstyle
        git revision trunk / 99e5204
        Release Audit https://builds.apache.org/job/PreCommit-HDFS-Build/12837/artifact/patchprocess/patchReleaseAuditProblems.txt
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/12837/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/12837/testReport/
        Java 1.7.0_55
        uname Linux asf903.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12837/console

        This message was automatically generated.

        eddyxu Lei (Eddy) Xu added a comment -

        +1. Thanks for the bug fix, Daniel Templeton.

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #8589 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8589/)
        HDFS-9176. Fix TestDirectoryScanner#testThrottling often fails. (Daniel (lei: rev 6dd47d754cb11297c8710a5c318c034abea7a836)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDirectoryScanner.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #503 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/503/)
        HDFS-9176. Fix TestDirectoryScanner#testThrottling often fails. (Daniel (lei: rev 6dd47d754cb11297c8710a5c318c034abea7a836)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDirectoryScanner.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2438 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2438/)
        HDFS-9176. Fix TestDirectoryScanner#testThrottling often fails. (Daniel (lei: rev 6dd47d754cb11297c8710a5c318c034abea7a836)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDirectoryScanner.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk #1232 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1232/)
        HDFS-9176. Fix TestDirectoryScanner#testThrottling often fails. (Daniel (lei: rev 6dd47d754cb11297c8710a5c318c034abea7a836)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDirectoryScanner.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2406 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2406/)
        HDFS-9176. Fix TestDirectoryScanner#testThrottling often fails. (Daniel (lei: rev 6dd47d754cb11297c8710a5c318c034abea7a836)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDirectoryScanner.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #468 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/468/)
        HDFS-9176. Fix TestDirectoryScanner#testThrottling often fails. (Daniel (lei: rev 6dd47d754cb11297c8710a5c318c034abea7a836)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDirectoryScanner.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #496 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/496/)
        HDFS-9176. Fix TestDirectoryScanner#testThrottling often fails. (Daniel (lei: rev 6dd47d754cb11297c8710a5c318c034abea7a836)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDirectoryScanner.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt

          People

          • Assignee:
            templedf Daniel Templeton
            Reporter:
            hitliuyi Yi Liu
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development