Daniel Templeton Thank you very much for your code review and comments.
Before we begin, I want to point out that Jing Zhao commented that we should not fix this issue at all, but just add a warning for the user that they should use "-ns" option in the error message.This is based on the discussion in
HDFS-6376. So I have a second patch which does exactly that. So I am guessing that second patch will get applied by Jing Zhao.
Meanwhile I will post one more patch that modifies the first code path in case you would like to use it.
Love that you're explaining what you're doing, but let's leave the JIRA ID out of it and don't explain it in terms of what changed. The comment should just explain the current state of things.
Agreed, let me remove the redundant JIRA number and fix that comment.
It might be, however I was just following the pattern in the nearby code. It is easier to read code if we have same patterns in a file.
I really don't like the idea of duplicating key names between DFSConfigKeys and HdfsClientConfigKeys
Not really sure about this, but I am guessing this might be due to the fact that we have an on-going refactoring work being done which separates HDFS client into its own jar.