This JIRA is to:
Improve chooseing datanode storage for block placement:
In BlockPlacementPolicyDefault (chooseLocalStorage, chooseRandom), we have following logic to choose datanode storage to place block.
For given storage type, we iterate storages of the datanode. But for datanode, it only cares about the storage type. In the loop, we check according to Storage type and return the first storage if the storages of the type on the datanode fit in requirement. So we can remove the iteration of storages, and just need to do once to find a good storage of given type, it's efficient if the storages of the type on the datanode don't fit in requirement since we don't need to loop all storages and do the same check.
Besides, no need to shuffle the storages, since we only need to check according to the storage type on the datanode once.
This also improves the logic and make it more clear.
(current logic above)