Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-884

DataNode makeInstance should report the directory list when failing to start up

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.22.0
    • Fix Version/s: 0.22.0
    • Component/s: datanode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      When Datanode.makeInstance() cannot work with one of the directories in dfs.data.dir, it logs this at warn level (while losing the stack trace).

      It should include the nested exception for better troubleshooting. Then, when all dirs in the list fail, an exception is thrown, but this exception does not include the list of directories. It should list the absolute path of every missing/failing directory, so that whoever sees the exception can see where to start looking for problems: either the filesystem or the configuration.

      1. InvalidDirs.patch
        2 kB
        Konstantin Shvachko
      2. InvalidDirs.patch
        3 kB
        Konstantin Shvachko
      3. InvalidDirs.patch
        3 kB
        Konstantin Shvachko
      4. HDFS-884.patch
        1 kB
        steve_l
      5. HDFS-884.patch
        2 kB
        steve_l

        Issue Links

          Activity

          steve_l created issue -
          steve_l added a comment -

          Patch changes logging, prints exception stack traces on failure if you want to see where things went wrong.

          After everything fails, the list of directories absolute paths is printed (in quotes), at the error level. makeInstance() still returns null at this time, which is the expected behaviour. It just now has more stuff in the logs.

          I also took the opportunity to move from an indexed for loop to a foreach loop, which

          Tests? None. You'd need to start a datanode without valid directories and look for system output captured somewhere. Tricky. Messing with system.out upsets test harnesses no end.

          steve_l made changes -
          Field Original Value New Value
          Attachment HDFS-884.patch [ 12429770 ]
          steve_l made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Fix Version/s 0.22.0 [ 12314241 ]
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12429770/HDFS-884.patch
          against trunk revision 897068.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/177/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/177/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/177/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/177/console

          This message is automatically generated.

          steve_l made changes -
          Link This issue is part of HDFS-890 [ HDFS-890 ]
          steve_l added a comment -

          HDFS-890 would extend and obsolete this issue/patch, as instead of reporting problems, makeInstance should raise an exception listing all failing directories and the reasons, and at least one nested cause.

          steve_l added a comment -

          move to URIs breaks this patch

          steve_l made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          steve_l added a comment -

          Resync with head and URI list

          steve_l made changes -
          Attachment HDFS-884.patch [ 12431420 ]
          steve_l added a comment -

          This has more detailed reporting of bad directories/URIs, but it does not raise any exception if the no of data dirs ==0.

          steve_l made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12431420/HDFS-884.patch
          against trunk revision 903098.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/206/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/206/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/206/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/206/console

          This message is automatically generated.

          steve_l added a comment -

          There are no tests here as it is only logged output, and we don't have a test setup that captures/analyses logs.

          Gavin made changes -
          Reporter Steve Loughran [ steve_l ] Steve Loughran [ stevel@apache.org ]
          Gavin made changes -
          Assignee Steve Loughran [ steve_l ] Steve Loughran [ stevel@apache.org ]
          dhruba borthakur added a comment -

          This seems like a useful patch to have, but sadly it is out-of-date and does not merge with trunk. If you upload another patch for the current trunk, I will commit it. Thanks St

          dhruba borthakur made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Steve Loughran added a comment -

          I have a more up to date version on my local git-managed SCM, I will chase it down and post, though probably not until august, as I'm about to go on vacation with no laptop for two weeks

          Konstantin Shvachko added a comment -

          I updated the patch. Changed it a bit. When the data dir list is empty, instead of just logging it is better to throw an IO exception, which will be logged up the stack.

          Konstantin Shvachko made changes -
          Attachment InvalidDirs.patch [ 12467196 ]
          Konstantin Shvachko made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Eli Collins added a comment -

          +1 latest patch looks good.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12467196/InvalidDirs.patch
          against trunk revision 1053214.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these core unit tests:
          org.apache.hadoop.hdfs.server.common.TestDistributedUpgrade
          org.apache.hadoop.hdfs.server.namenode.TestLargeDirectoryDelete
          org.apache.hadoop.hdfs.server.namenode.TestStorageRestore
          org.apache.hadoop.hdfs.TestDatanodeConfig
          org.apache.hadoop.hdfs.TestDFSStorageStateRecovery
          org.apache.hadoop.hdfs.TestHDFSTrash

          -1 contrib tests. The patch failed contrib unit tests.

          +1 system test framework. The patch passed system test framework compile.

          Test results: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/62//testReport/
          Findbugs warnings: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/62//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/62//console

          This message is automatically generated.

          Konstantin Shvachko made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Konstantin Shvachko added a comment -

          Missed one case where TestDatanodeConfig relies on that createDataNode() returns null. Fixed it.

          Konstantin Shvachko made changes -
          Attachment InvalidDirs.patch [ 12467853 ]
          Konstantin Shvachko made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Steve Loughran added a comment -

          looks good, though I'm not sure we need the assert statement given that the constructor does the same check and includes the list of invalid dirs. All the assert will do is fail early on assert enabled (test) runs, so reducing coverage of the constructor itself.

          This patch will obsolete HDFS-890, which didn't have any code associated with it anyway.

          Nigel Daley added a comment -

          From the patch:

          +    try {
          +      dn = DataNode.createDataNode(new String[]{}, conf);
          +    } catch(IOException e) {
          +      // expecting exception here
          +    }
          +    if(dn != null) dn.shutdown();
          

          Shouldn't there be a fail() call after the dn assignment line?
          If you're updating patch then dn.shutdown() should be on it's own line.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12467853/InvalidDirs.patch
          against trunk revision 1056206.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these core unit tests:

          -1 contrib tests. The patch failed contrib unit tests.

          -1 system test framework. The patch failed system test framework compile.

          Test results: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/94//testReport/
          Findbugs warnings: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/94//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/94//console

          This message is automatically generated.

          Konstantin Shvachko made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Konstantin Shvachko made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Nigel Daley added a comment -

          Konstantin, if you're trying to kick a new patch build for this you now longer move it to "Open" and back to "Patch Available". Instead, you must upload a new patch. Or, if you have permission, you can kick https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/ and enter the issue number.

          Jakob Homan added a comment -

          bq, Konstantin, if you're trying to kick a new patch build for this you now longer move it to "Open" and back to "Patch Available". Instead, you must upload a new patch.
          That makes me sad. Is this a new feature or regression?

          Konstantin Shvachko added a comment -

          N> Shouldn't there be a fail() call after the dn assignment line?

          See the next line

          assertNull("Data-node startup should have failed.", dn);

          This will fail the test if the DN starts.

          Konstantin Shvachko added a comment -

          Attaching same patch with shutdown on new line. To trigger the build.

          Konstantin Shvachko made changes -
          Attachment InvalidDirs.patch [ 12468205 ]
          Konstantin Shvachko made changes -
          Attachment InvalidDirs.patch [ 12468205 ]
          Konstantin Shvachko made changes -
          Attachment InvalidDirs.patch [ 12468207 ]
          Konstantin Shvachko made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Konstantin Shvachko made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Nigel Daley made changes -
          Fix Version/s 0.22.0 [ 12314241 ]
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12468207/InvalidDirs.patch
          against trunk revision 1057414.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 3 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these core unit tests:
          org.apache.hadoop.hdfs.server.namenode.TestStorageRestore

          -1 contrib tests. The patch failed contrib unit tests.

          +1 system test framework. The patch passed system test framework compile.

          Test results: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/102//testReport/
          Findbugs warnings: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/102//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: https://hudson.apache.org/hudson/job/PreCommit-HDFS-Build/102//console

          This message is automatically generated.

          Konstantin Shvachko added a comment -

          I just committed this. Thank you Steve.

          Konstantin Shvachko made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Hadoop Flags [Reviewed]
          Fix Version/s 0.22.0 [ 12314241 ]
          Resolution Fixed [ 1 ]
          Steve Loughran added a comment -

          no need to thank me, all I provided was a deployment where none of the directories were valid

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #643 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk/643/)

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-22-branch #35 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-22-branch/35/)


            People

            • Assignee:
              Steve Loughran
              Reporter:
              Steve Loughran
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development