Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-8809

HDFS fsck reports under construction blocks as "CORRUPT"

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.7.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: tools
    • Labels:
      None
    • Environment:

      Hadoop 2.7.1 and HBase 1.1.1, on SUSE11sp3 (other Linuxes not tested, probably not platform-dependent). This did NOT happen with Hadoop 2.4 and HBase 0.98.

    • Hadoop Flags:
      Reviewed

      Description

      Whenever HBase is running, the "hdfs fsck /" reports four hbase-related files in the path "hbase/data/WALs/" as CORRUPT. Even after letting the cluster sit idle for a couple hours, it is still in the corrupt state. If HBase is shut down, the problem goes away. If HBase is then restarted, the problem recurs. This was observed with Hadoop 2.7.1 and HBase 1.1.1, and did NOT happen with Hadoop 2.4 and HBase 0.98.

      hades1:/var/opt/teradata/packages # su hdfs
      hdfs@hades1:/var/opt/teradata/packages> hdfs fsck /
      Connecting to namenode via http://hades1.labs.teradata.com:50070/fsck?ugi=hdfs&path=%2F
      FSCK started by hdfs (auth:SIMPLE) from /39.0.8.2 for path / at Wed Jun 24 20:40:17 GMT 2015
      ...
      /apps/hbase/data/WALs/hades4.labs.teradata.com,16020,1435168292684/hades4.labs.teradata.com%2C16020%2C1435168292684.default.1435175500556: MISSING 1 blocks of total size 83 B.
      /apps/hbase/data/WALs/hades5.labs.teradata.com,16020,1435168290466/hades5.labs.teradata.com%2C16020%2C1435168290466..meta.1435175562144.meta: MISSING 1 blocks of total size 83 B.
      /apps/hbase/data/WALs/hades5.labs.teradata.com,16020,1435168290466/hades5.labs.teradata.com%2C16020%2C1435168290466.default.1435175498500: MISSING 1 blocks of total size 83 B.
      /apps/hbase/data/WALs/hades6.labs.teradata.com,16020,1435168292373/hades6.labs.teradata.com%2C16020%2C1435168292373.default.1435175500301: MISSING 1 blocks of total size 83 B..................................................................................................
      ....................................................................................................
      ....................................................................................................
      ........................................................................................Status: CORRUPT
       Total size:    723977553 B (Total open files size: 332 B)
       Total dirs:    79
       Total files:   388
       Total symlinks:                0 (Files currently being written: 5)
       Total blocks (validated):      387 (avg. block size 1870743 B) (Total open file blocks (not validated): 4)
        ********************************
        UNDER MIN REPL'D BLOCKS:      4 (1.0335917 %)
        dfs.namenode.replication.min: 1
        CORRUPT FILES:        4
        MISSING BLOCKS:       4
        MISSING SIZE:         332 B
        ********************************
       Minimally replicated blocks:   387 (100.0 %)
       Over-replicated blocks:        0 (0.0 %)
       Under-replicated blocks:       0 (0.0 %)
       Mis-replicated blocks:         0 (0.0 %)
       Default replication factor:    3
       Average block replication:     3.0
       Corrupt blocks:                0
       Missing replicas:              0 (0.0 %)
       Number of data-nodes:          3
       Number of racks:               1
      FSCK ended at Wed Jun 24 20:40:17 GMT 2015 in 7 milliseconds
      
      
      The filesystem under path '/' is CORRUPT
      hdfs@hades1:/var/opt/teradata/packages>
      

        Issue Links

          Activity

          housejester James Estes added a comment -

          We are seeing very similar behavior with HBase 0.98.12 on Hadoop 2.6.0, though in our case, the CORRUPT blocks are only reported when using the -openforwrite flag. It is indicating missing blocks for WALs being written to, and the same 83 B you see here. Further, when we shut hbase down, the report is healthy again. We did not see this behavior on HBase 0.98.12 and Hadoop 2.2.0

          Here is our corrupt blocks report:

          bin/hdfs fsck -openforwrite
          Connecting to namenode via http://prod-nn2:50070
          FSCK started by hadoop (auth:SIMPLE) from /10.73.3.15 for path / at Thu Jul 23 16:02:58 UTC 2015
          /data/hbase/WALs/prod-h1,60020,1437667330408/prod-h1%2C60020%2C1437667330408.1437667332462 83 bytes, 1 block(s), OPENFORWRITE:
          /data/hbase/WALs/prod-h1,60020,1437667330408/prod-h1%2C60020%2C1437667330408.1437667332462: MISSING 1 blocks of total size 83 B./data/hbase/WALs/prod-h2,60020,1437667330869/prod-h2%2C60020%2C1437667330869.1437667332991 83 bytes, 1 block(s), OPENFORWRITE:
          /data/hbase/WALs/prod-h2,60020,1437667330869/prod-h2%2C60020%2C1437667330869.1437667332991: MISSING 1 blocks of total size 83 B./data/hbase/WALs/prod-h3,60020,1437667330149/prod-h3%2C60020%2C1437667330149.1437667332298 83 bytes, 1 block(s), OPENFORWRITE:
          /data/hbase/WALs/prod-h3,60020,1437667330149/prod-h3%2C60020%2C1437667330149.1437667332298: MISSING 1 blocks of total size 83 B./data/hbase/WALs/prod-h4,60020,1437667330435/prod-h4%2C60020%2C1437667330435.1437667332567 83 bytes, 1 block(s), OPENFORWRITE:
          /data/hbase/WALs/prod-h4,60020,1437667330435/prod-h4%2C60020%2C1437667330435.1437667332567: MISSING 1 blocks of total size 83 B./data/hbase/WALs/prod-h5,60020,1437667330436/prod-h5%2C60020%2C1437667330436.1437667332928 83 bytes, 1 block(s), OPENFORWRITE:
          /data/hbase/WALs/prod-h5,60020,1437667330436/prod-h5%2C60020%2C1437667330436.1437667332928: MISSING 1 blocks of total size 83 B./data/hbase/WALs/prod-h6,60020,1437667330455/prod-h6%2C60020%2C1437667330455.1437667332532 83 bytes, 1 block(s), OPENFORWRITE:
          /data/hbase/WALs/prod-h6,60020,1437667330455/prod-h6%2C60020%2C1437667330455.1437667332532: MISSING 1 blocks of total size 83 B./data/hbase/WALs/prod-h6,60020,1437667330455/prod-h6%2C60020%2C1437667330455.1437667333025.meta 83 bytes, 1 block(s), OPENFORWRITE:
          /data/hbase/WALs/prod-h6,60020,1437667330455/prod-h6%2C60020%2C1437667330455.1437667333025.meta: MISSING 1 blocks of total size 83 B./data/hbase/WALs/prod-h7,60020,1437667330742/prod-h7%2C60020%2C1437667330742.1437667333075 83 bytes, 1 block(s), OPENFORWRITE:
          /data/hbase/WALs/prod-h7,60020,1437667330742/prod-h7%2C60020%2C1437667330742.1437667333075: MISSING 1 blocks of total size 83 B./data/hbase/WALs/prod-h8,60020,1437667330731/prod-h8%2C60020%2C1437667330731.1437667332978 83 bytes, 1 block(s), OPENFORWRITE:
          /data/hbase/WALs/prod-h8,60020,1437667330731/prod-h8%2C60020%2C1437667330731.1437667332978: MISSING 1 blocks of total size 83 B............................................................................................
          ....................................................................................................
          ....................................................................................................
          ....................................................................................................
          ....................................................................................................
          ....................................................................................................
          .......................................Status: CORRUPT
           Total size:	104358709960 B
           Total dirs:	517
           Total files:	639
           Total symlinks:		0
           Total blocks (validated):	1294 (avg. block size 80648152 B)
            ********************************
            CORRUPT FILES:	9
            MISSING BLOCKS:	9
            MISSING SIZE:		747 B
            ********************************
           Minimally replicated blocks:	1285 (99.30448 %)
           Over-replicated blocks:	0 (0.0 %)
           Under-replicated blocks:	0 (0.0 %)
           Mis-replicated blocks:		0 (0.0 %)
           Default replication factor:	3
           Average block replication:	2.9791346
           Corrupt blocks:		0
           Missing replicas:		0 (0.0 %)
           Number of data-nodes:		8
           Number of racks:		1
          FSCK ended at Thu Jul 23 16:02:58 UTC 2015 in 121 milliseconds
          
          
          jingzhao Jing Zhao added a comment -

          Looks like this is an issue caused by HDFS-8215. Before, we skip the whole check if the block is under construction and "showOpenFiles" is disabled:

              isOpen = blocks.isUnderConstruction();
              if (isOpen && !showOpenFiles) {
                // We collect these stats about open files to report with default options
                res.totalOpenFilesSize += fileLen;
                res.totalOpenFilesBlocks += blocks.locatedBlockCount();
                res.totalOpenFiles++;
                return;
              }
          

          HDFS-8215 still includes this logic in collectFileSummary but not in collectBlocksSummary, where the UC blocks are reported as missing.

          jingzhao Jing Zhao added a comment -

          There is another issue here, which I think exists before HDFS-8215. When "-OPENFORWRITE" is enabled, an UC block is still treated as missing/corrupted, since countNodes only checks the triplets inside of the BlockInfo and thus the liveReplicas is usually 0 for a UC block.

          The fix can be to ignore the check if the block is the last one and it's UC. Theoretically the penultimate block can also be in the committed state and with 0 reported replica yet, but maybe we do not need to handle this part here.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          -1 pre-patch 16m 22s Findbugs (version ) appears to be broken on trunk.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 8m 16s There were no new javac warning messages.
          +1 javadoc 10m 19s There were no new javadoc warning messages.
          +1 release audit 0m 24s The applied patch does not increase the total number of release audit warnings.
          +1 checkstyle 0m 34s There were no new checkstyle issues.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 42s mvn install still works.
          +1 eclipse:eclipse 0m 37s The patch built with eclipse:eclipse.
          +1 findbugs 2m 47s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          +1 native 3m 23s Pre-build of native portion
          -1 hdfs tests 177m 26s Tests failed in hadoop-hdfs.
              221m 53s  



          Reason Tests
          Failed unit tests hadoop.hdfs.server.namenode.ha.TestBootstrapStandbyWithQJM
          Timed out tests org.apache.hadoop.cli.TestHDFSCLI



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12751321/HDFS-8809.000.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / 3aac475
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/12048/artifact/patchprocess/testrun_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/12048/testReport/
          Java 1.7.0_55
          uname Linux asf901.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12048/console

          This message was automatically generated.

          wheat9 Haohui Mai added a comment -

          +1

          jingzhao Jing Zhao added a comment -

          Thanks Haohui for the review. I've committed this to trunk and branch-2.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8331 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8331/)
          HDFS-8809. HDFS fsck reports under construction blocks as CORRUPT. Contributed by Jing Zhao. (jing9: rev c8bca62718203a1dad9b70d164bdf10cc71b40cd)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NamenodeFsck.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #291 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/291/)
          HDFS-8809. HDFS fsck reports under construction blocks as CORRUPT. Contributed by Jing Zhao. (jing9: rev c8bca62718203a1dad9b70d164bdf10cc71b40cd)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NamenodeFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsck.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #1024 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1024/)
          HDFS-8809. HDFS fsck reports under construction blocks as CORRUPT. Contributed by Jing Zhao. (jing9: rev c8bca62718203a1dad9b70d164bdf10cc71b40cd)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NamenodeFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #294 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/294/)
          HDFS-8809. HDFS fsck reports under construction blocks as CORRUPT. Contributed by Jing Zhao. (jing9: rev c8bca62718203a1dad9b70d164bdf10cc71b40cd)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NamenodeFsck.java
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Mapreduce-trunk #2240 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2240/)
          HDFS-8809. HDFS fsck reports under construction blocks as CORRUPT. Contributed by Jing Zhao. (jing9: rev c8bca62718203a1dad9b70d164bdf10cc71b40cd)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NamenodeFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsck.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #283 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/283/)
          HDFS-8809. HDFS fsck reports under construction blocks as CORRUPT. Contributed by Jing Zhao. (jing9: rev c8bca62718203a1dad9b70d164bdf10cc71b40cd)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NamenodeFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsck.java
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Hdfs-trunk #2221 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2221/)
          HDFS-8809. HDFS fsck reports under construction blocks as CORRUPT. Contributed by Jing Zhao. (jing9: rev c8bca62718203a1dad9b70d164bdf10cc71b40cd)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/NamenodeFsck.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt

            People

            • Assignee:
              jingzhao Jing Zhao
              Reporter:
              heat23 Sudhir Prakash
            • Votes:
              0 Vote for this issue
              Watchers:
              14 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development