Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Currently we use TreeMap for corruptReplicasMap, actually the only need sorted place is getCorruptReplicaBlockIds which is used by test.
      So we can use HashMap.

      From memory and performance view, HashMap is better than TreeMap, a simliar optimization HDFS-7433. Of course we need to make few change to getCorruptReplicaBlockIds.

      1. HDFS-8794.001.patch
        2 kB
        Yi Liu
      2. HDFS-8794.002.patch
        5 kB
        Yi Liu

        Activity

        hitliuyi Yi Liu added a comment -

        TestCorruptReplicaInfo can be as the regression test.

        arpitagarwal Arpit Agarwal added a comment - - edited

        Hi Yi Liu, thanks for starting this effort.

        Of course we need to make few change to getCorruptReplicaBlockIds.

        Do you mean an additional fix to getCorruptReplicaBlockIds beyond your current patch is needed? It looks like getCorruptReplicaBlockIds won't work in general since it assumes the map is sorted. Can you add an @VisibleForTesting annotation and also rename the function to getCorruptReplicaBlockIdsForTesting so this function is not used inadvertently?

        +1 otherwise, pending Jenkins.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 17m 9s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 javac 7m 38s There were no new javac warning messages.
        +1 javadoc 9m 44s There were no new javadoc warning messages.
        +1 release audit 0m 23s The applied patch does not increase the total number of release audit warnings.
        +1 checkstyle 1m 20s There were no new checkstyle issues.
        -1 whitespace 0m 0s The patch has 2 line(s) that end in whitespace. Use git apply --whitespace=fix.
        +1 install 1m 19s mvn install still works.
        +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
        +1 findbugs 2m 30s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
        +1 native 3m 4s Pre-build of native portion
        -1 hdfs tests 158m 9s Tests failed in hadoop-hdfs.
            201m 52s  



        Reason Tests
        Failed unit tests hadoop.hdfs.server.namenode.ha.TestStandbyIsHot
          hadoop.hdfs.TestDistributedFileSystem
          hadoop.hdfs.TestAppendSnapshotTruncate



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12745820/HDFS-8794.001.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / 9b272cc
        whitespace https://builds.apache.org/job/PreCommit-HDFS-Build/11740/artifact/patchprocess/whitespace.txt
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/11740/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/11740/testReport/
        Java 1.7.0_55
        uname Linux asf901.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/11740/console

        This message was automatically generated.

        hitliuyi Yi Liu added a comment -

        Thanks Arpit Agarwal for review!

        Actually I have added @VisibleForTesting annotation for getCorruptReplicaBlockIds, I can certainly rename it as you suggestion in next patch.

        It looks like getCorruptReplicaBlockIds won't work in general since it assumes the map is sorted

        You are right, I have fixed this too in the current patch, so no need additional fix, look at following code, it uses a TreeMap wrapper in getCorruptReplicaBlockIds. The Jenkins result also shows the fix correct.

        +    Iterator<Block> blockIt = 
        +        new TreeMap<>(corruptReplicasMap).keySet().iterator();
        
        arpitagarwal Arpit Agarwal added a comment -

        Sorry for missing that I should have looked more carefully. The test failures look unrelated.

        +1 from me. Feel free to commit after renaming the function!

        hitliuyi Yi Liu added a comment - - edited

        Arpit Agarwal, no problem, thanks a lot for the review! Update the patch to rename getCorruptReplicaBlockIds, it's a good idea then the function is not used inadvertently.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        -1 pre-patch 15m 16s Findbugs (version ) appears to be broken on trunk.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 36s There were no new javac warning messages.
        +1 javadoc 9m 38s There were no new javadoc warning messages.
        +1 release audit 0m 24s The applied patch does not increase the total number of release audit warnings.
        -1 checkstyle 1m 1s The applied patch generated 9 new checkstyle issues (total was 0, now 9).
        -1 whitespace 0m 0s The patch has 4 line(s) that end in whitespace. Use git apply --whitespace=fix.
        +1 install 1m 24s mvn install still works.
        +1 eclipse:eclipse 0m 34s The patch built with eclipse:eclipse.
        +1 findbugs 2m 29s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
        +1 native 3m 3s Pre-build of native portion
        -1 hdfs tests 160m 29s Tests failed in hadoop-hdfs.
            201m 57s  



        Reason Tests
        Failed unit tests hadoop.hdfs.util.TestByteArrayManager
          hadoop.hdfs.TestDistributedFileSystem
          hadoop.hdfs.server.namenode.ha.TestStandbyIsHot



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12745910/HDFS-8794.002.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / 419c51d
        checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/11745/artifact/patchprocess/diffcheckstylehadoop-hdfs.txt
        whitespace https://builds.apache.org/job/PreCommit-HDFS-Build/11745/artifact/patchprocess/whitespace.txt
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/11745/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/11745/testReport/
        Java 1.7.0_55
        uname Linux asf909.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/11745/console

        This message was automatically generated.

        hitliuyi Yi Liu added a comment -

        Committed to trunk and branch-2, thanks for Arpit Agarwal review.

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #8188 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8188/)
        HDFS-8794. Improve CorruptReplicasMap#corruptReplicasMap. (yliu) (yliu: rev d6d58606b8adf94b208aed5fc2d054b9dd081db1)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/CorruptReplicasMap.java
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestCorruptReplicaInfo.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #263 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/263/)
        HDFS-8794. Improve CorruptReplicasMap#corruptReplicasMap. (yliu) (yliu: rev d6d58606b8adf94b208aed5fc2d054b9dd081db1)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestCorruptReplicaInfo.java
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/CorruptReplicasMap.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk #993 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/993/)
        HDFS-8794. Improve CorruptReplicasMap#corruptReplicasMap. (yliu) (yliu: rev d6d58606b8adf94b208aed5fc2d054b9dd081db1)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/CorruptReplicasMap.java
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestCorruptReplicaInfo.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2190 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2190/)
        HDFS-8794. Improve CorruptReplicasMap#corruptReplicasMap. (yliu) (yliu: rev d6d58606b8adf94b208aed5fc2d054b9dd081db1)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/CorruptReplicasMap.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestCorruptReplicaInfo.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #252 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/252/)
        HDFS-8794. Improve CorruptReplicasMap#corruptReplicasMap. (yliu) (yliu: rev d6d58606b8adf94b208aed5fc2d054b9dd081db1)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestCorruptReplicaInfo.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/CorruptReplicasMap.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #260 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/260/)
        HDFS-8794. Improve CorruptReplicasMap#corruptReplicasMap. (yliu) (yliu: rev d6d58606b8adf94b208aed5fc2d054b9dd081db1)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestCorruptReplicaInfo.java
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/CorruptReplicasMap.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        arpitagarwal Arpit Agarwal added a comment -

        +1 for the v2 patch, thanks Yi Liu.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Mapreduce-trunk #2209 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2209/)
        HDFS-8794. Improve CorruptReplicasMap#corruptReplicasMap. (yliu) (yliu: rev d6d58606b8adf94b208aed5fc2d054b9dd081db1)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestCorruptReplicaInfo.java
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/blockmanagement/CorruptReplicasMap.java

          People

          • Assignee:
            hitliuyi Yi Liu
            Reporter:
            hitliuyi Yi Liu
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development