Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The ClientProtocol class defines the RPC protocol between the NN and the client. This jira proposes to move it into the hdfs-client module.

      The jira needs to move:

      • o.a.h.hdfs.server.namenode.SafeModeException and o.a.h.hdfs.server.namenode.NotReplicatedYetException to the hdfs-client package
      • Remove the reference of DistributedFileSystem in the javadoc
      • Create a copy of DFSConfigKeys.DFS_NAMENODE_KERBEROS_PRINCIPAL_KEY in HdfsClientConfigKeys
      1. HDFS-8238.000.patch
        8 kB
        Haohui Mai
      2. HDFS-8238.001.patch
        127 kB
        Takanobu Asanuma
      3. HDFS-8238.002.patch
        7 kB
        Takanobu Asanuma
      4. HDFS-8238.003.patch
        5 kB
        Takanobu Asanuma

        Issue Links

          Activity

          wheat9 Haohui Mai added a comment -

          Upload my initial patch

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 14m 48s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 javac 7m 33s There were no new javac warning messages.
          +1 javadoc 9m 34s There were no new javadoc warning messages.
          +1 release audit 0m 23s The applied patch does not increase the total number of release audit warnings.
          -1 checkstyle 1m 47s The applied patch generated 128 new checkstyle issues (total was 35, now 163).
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 38s mvn install still works.
          +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
          +1 findbugs 3m 45s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
          +1 native 3m 12s Pre-build of native portion
          -1 hdfs tests 165m 6s Tests failed in hadoop-hdfs.
          -1 hdfs tests 0m 18s Tests failed in hadoop-hdfs-client.
              208m 41s  



          Reason Tests
          Failed unit tests hadoop.hdfs.TestSafeMode
            hadoop.tracing.TestTraceAdmin
            hadoop.hdfs.tools.TestHdfsConfigFields
          Failed build hadoop-hdfs-client



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12732027/HDFS-8238.000.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / ea11590
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/10920/artifact/patchprocess/diffcheckstylehadoop-hdfs-client.txt
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/10920/artifact/patchprocess/testrun_hadoop-hdfs.txt
          hadoop-hdfs-client test log https://builds.apache.org/job/PreCommit-HDFS-Build/10920/artifact/patchprocess/testrun_hadoop-hdfs-client.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/10920/testReport/
          Java 1.7.0_55
          uname Linux asf902.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/10920/console

          This message was automatically generated.

          tasanuma0829 Takanobu Asanuma added a comment -

          Thank you very much for your support, Haohui Mai!
          I'm sorry my late work. I'm working on another JIRA and it is heavy for me. So I don't have the capacity now.

          tasanuma0829 Takanobu Asanuma added a comment -

          I investigated the cause of the error about TestSafeMode#testOperationsWhileInSafeMode. And I found that the signiture of SafeModeException(String msg) broke dependencies. It occors in the try block in RemoteException#unwrapRemoteException. So we should change the signiture. Other codes look good to me.

          tasanuma0829 Takanobu Asanuma added a comment -

          I modified a little codes on top of Haohui Mai's work and submitted it.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 14m 40s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 javac 7m 33s There were no new javac warning messages.
          +1 javadoc 9m 38s There were no new javadoc warning messages.
          +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
          -1 checkstyle 1m 46s The applied patch generated 128 new checkstyle issues (total was 35, now 163).
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 34s mvn install still works.
          +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
          +1 findbugs 3m 45s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
          +1 native 3m 13s Pre-build of native portion
          +1 hdfs tests 168m 22s Tests passed in hadoop-hdfs.
          +1 hdfs tests 0m 16s Tests passed in hadoop-hdfs-client.
              211m 46s  



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12733073/HDFS-8238.001.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / 1ea9014
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/10996/artifact/patchprocess/diffcheckstylehadoop-hdfs-client.txt
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/10996/artifact/patchprocess/testrun_hadoop-hdfs.txt
          hadoop-hdfs-client test log https://builds.apache.org/job/PreCommit-HDFS-Build/10996/artifact/patchprocess/testrun_hadoop-hdfs-client.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/10996/testReport/
          Java 1.7.0_55
          uname Linux asf900.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/10996/console

          This message was automatically generated.

          wheat9 Haohui Mai added a comment -

          Takanobu Asanuma, can you please regenerate your patch with git diff -M? Thanks.

          tasanuma0829 Takanobu Asanuma added a comment -

          I attached the patch with git diff -M. Please review it? Thank you.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 18m 29s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 javac 7m 30s There were no new javac warning messages.
          +1 javadoc 9m 38s There were no new javadoc warning messages.
          +1 release audit 0m 23s The applied patch does not increase the total number of release audit warnings.
          -1 checkstyle 1m 48s The applied patch generated 127 new checkstyle issues (total was 35, now 162).
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 38s mvn install still works.
          +1 eclipse:eclipse 0m 35s The patch built with eclipse:eclipse.
          +1 findbugs 4m 6s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          +1 native 3m 14s Pre-build of native portion
          +1 hdfs tests 161m 10s Tests passed in hadoop-hdfs.
          +1 hdfs tests 0m 16s Tests passed in hadoop-hdfs-client.
              208m 50s  



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12739739/HDFS-8238.002.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / 175e6d1
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/11364/artifact/patchprocess/diffcheckstylehadoop-hdfs-client.txt
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/11364/artifact/patchprocess/testrun_hadoop-hdfs.txt
          hadoop-hdfs-client test log https://builds.apache.org/job/PreCommit-HDFS-Build/11364/artifact/patchprocess/testrun_hadoop-hdfs-client.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/11364/testReport/
          Java 1.7.0_55
          uname Linux asf909.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/11364/console

          This message was automatically generated.

          wheat9 Haohui Mai added a comment -

          Takanobu Asanuma, it looks like there is no need to change the signature of the constructor SafeModeException after HDFS-8592 is committed. Can you please rebase your patch? Thanks.

          tasanuma0829 Takanobu Asanuma added a comment -

          Thank you for your work in HDFS-8592, Haohui Mai!
          I rebased the patch without changing the signature and resubmitted it.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 18m 48s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 javac 7m 38s There were no new javac warning messages.
          +1 javadoc 9m 45s There were no new javadoc warning messages.
          +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
          -1 checkstyle 1m 47s The applied patch generated 127 new checkstyle issues (total was 35, now 162).
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 39s mvn install still works.
          +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
          +1 findbugs 4m 8s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          +1 native 3m 17s Pre-build of native portion
          -1 hdfs tests 121m 58s Tests failed in hadoop-hdfs.
          +1 hdfs tests 0m 17s Tests passed in hadoop-hdfs-client.
              170m 17s  



          Reason Tests
          Failed unit tests hadoop.hdfs.server.namenode.snapshot.TestUpdatePipelineWithSnapshots
            hadoop.fs.TestUrlStreamHandler
            hadoop.hdfs.server.namenode.TestFileLimit
            hadoop.hdfs.server.namenode.TestEditLogAutoroll
            hadoop.TestRefreshCallQueue
            hadoop.hdfs.protocolPB.TestPBHelper
            hadoop.cli.TestCryptoAdminCLI
            hadoop.fs.viewfs.TestViewFsWithAcls
            hadoop.hdfs.server.namenode.TestFSEditLogLoader
            hadoop.fs.contract.hdfs.TestHDFSContractDelete
            hadoop.fs.TestFcHdfsSetUMask
            hadoop.fs.TestUnbuffer
            hadoop.hdfs.server.namenode.TestClusterId
            hadoop.hdfs.server.namenode.TestDeleteRace
            hadoop.hdfs.server.namenode.TestFSDirectory
            hadoop.fs.contract.hdfs.TestHDFSContractOpen
            hadoop.hdfs.server.namenode.snapshot.TestSnapshotListing
            hadoop.hdfs.server.namenode.TestFileTruncate
            hadoop.fs.contract.hdfs.TestHDFSContractMkdir
            hadoop.fs.contract.hdfs.TestHDFSContractAppend
            hadoop.hdfs.server.namenode.TestSecondaryWebUi
            hadoop.hdfs.server.namenode.TestHDFSConcat
            hadoop.hdfs.server.namenode.TestAddBlockRetry
            hadoop.fs.TestSymlinkHdfsFileSystem
            hadoop.fs.viewfs.TestViewFsDefaultValue
            hadoop.fs.TestSymlinkHdfsFileContext
            hadoop.hdfs.TestClientProtocolForPipelineRecovery
            hadoop.hdfs.TestFSInputChecker
            hadoop.hdfs.server.mover.TestStorageMover
            hadoop.cli.TestAclCLI
            hadoop.hdfs.TestEncryptedTransfer
            hadoop.hdfs.server.namenode.TestNNStorageRetentionFunctional
            hadoop.fs.contract.hdfs.TestHDFSContractSeek
            hadoop.hdfs.server.namenode.TestFileContextXAttr
            hadoop.hdfs.server.namenode.TestAclConfigFlag
            hadoop.hdfs.server.namenode.TestFSImageWithXAttr
            hadoop.hdfs.server.namenode.metrics.TestNameNodeMetrics
            hadoop.tracing.TestTracing
            hadoop.hdfs.server.namenode.TestListCorruptFileBlocks
            hadoop.hdfs.server.namenode.snapshot.TestAclWithSnapshot
            hadoop.hdfs.server.namenode.TestGenericJournalConf
            hadoop.fs.viewfs.TestViewFsWithXAttrs
            hadoop.hdfs.server.namenode.TestEditLogJournalFailures
            hadoop.hdfs.TestPersistBlocks
            hadoop.hdfs.TestDatanodeReport
            hadoop.tools.TestJMXGet
            hadoop.fs.contract.hdfs.TestHDFSContractCreate
            hadoop.hdfs.server.namenode.TestCreateEditsLog
            hadoop.hdfs.server.namenode.TestFSNamesystemMBean
            hadoop.hdfs.TestWriteRead
            hadoop.hdfs.server.balancer.TestBalancerWithMultipleNameNodes
            hadoop.fs.TestEnhancedByteBufferAccess
            hadoop.fs.TestFcHdfsPermission
            hadoop.security.TestRefreshUserMappings
            hadoop.fs.viewfs.TestViewFsHdfs
            hadoop.fs.TestResolveHdfsSymlink
            hadoop.hdfs.server.namenode.metrics.TestNNMetricFilesInGetListingOps
            hadoop.tracing.TestTracingShortCircuitLocalRead
            hadoop.hdfs.server.namenode.TestDecommissioningStatus
            hadoop.hdfs.server.namenode.snapshot.TestCheckpointsWithSnapshots
            hadoop.tracing.TestTraceAdmin
            hadoop.hdfs.server.namenode.snapshot.TestSnapshotMetrics
            hadoop.hdfs.server.namenode.TestNNThroughputBenchmark
            hadoop.hdfs.server.namenode.TestAuditLogAtDebug
            hadoop.hdfs.TestDatanodeStartupFixesLegacyStorageIDs
            hadoop.hdfs.server.namenode.TestQuotaByStorageType
            hadoop.hdfs.server.balancer.TestBalancerWithEncryptedTransfer
            hadoop.hdfs.server.namenode.TestNamenodeRetryCache
            hadoop.hdfs.server.balancer.TestBalancer
            hadoop.fs.TestFcHdfsCreateMkdir
            hadoop.hdfs.server.namenode.TestBlockUnderConstruction
            hadoop.hdfs.server.mover.TestMover
            hadoop.hdfs.server.namenode.TestDeadDatanode
            hadoop.hdfs.server.namenode.TestNameNodeRetryCacheMetrics
            hadoop.hdfs.server.namenode.TestCacheDirectives
            hadoop.hdfs.server.namenode.TestCommitBlockSynchronization
            hadoop.hdfs.server.namenode.TestFSNamesystem
            hadoop.fs.viewfs.TestViewFileSystemWithXAttrs
            hadoop.fs.viewfs.TestViewFileSystemWithAcls
            hadoop.hdfs.server.namenode.snapshot.TestINodeFileUnderConstructionWithSnapshot
            hadoop.hdfs.server.balancer.TestBalancerWithHANameNodes
            hadoop.security.TestPermission
            hadoop.hdfs.server.balancer.TestBalancerWithNodeGroup
            hadoop.fs.contract.hdfs.TestHDFSContractConcat
            hadoop.hdfs.server.namenode.TestStartupProgressServlet
            hadoop.hdfs.server.namenode.TestFSPermissionChecker
            hadoop.hdfs.server.namenode.TestLargeDirectoryDelete
            hadoop.hdfs.server.namenode.TestSecondaryNameNodeUpgrade
            hadoop.security.TestPermissionSymlinks
            hadoop.hdfs.server.namenode.TestValidateConfigurationSettings
            hadoop.net.TestNetworkTopology
            hadoop.fs.contract.hdfs.TestHDFSContractRootDirectory
            hadoop.cli.TestXAttrCLI
            hadoop.hdfs.TestEncryptionZonesWithHA
            hadoop.fs.contract.hdfs.TestHDFSContractRename
            hadoop.hdfs.server.namenode.TestSecurityTokenEditLog
            hadoop.fs.permission.TestStickyBit
            hadoop.fs.viewfs.TestViewFileSystemAtHdfsRoot
            hadoop.hdfs.server.namenode.TestTransferFsImage
            hadoop.hdfs.server.namenode.TestGetBlockLocations
            hadoop.hdfs.server.namenode.TestFSImageWithSnapshot
            hadoop.hdfs.TestPipelines
            hadoop.fs.loadGenerator.TestLoadGenerator
            hadoop.hdfs.server.namenode.snapshot.TestSnapshotRename
            hadoop.hdfs.server.namenode.TestStartupOptionUpgrade
            hadoop.cli.TestCacheAdminCLI
            hadoop.hdfs.server.namenode.TestNamenodeCapacityReport
            hadoop.fs.TestHDFSFileContextMainOperations
            hadoop.fs.TestGlobPaths
            hadoop.fs.viewfs.TestViewFsFileStatusHdfs
            hadoop.hdfs.server.namenode.TestCheckPointForSecurityTokens
            hadoop.fs.viewfs.TestViewFsAtHdfsRoot
            hadoop.TestGenericRefresh
            hadoop.hdfs.server.balancer.TestBalancerWithSaslDataTransfer
            hadoop.fs.shell.TestHdfsTextCommand
            hadoop.cli.TestHDFSCLI
            hadoop.hdfs.TestReplaceDatanodeOnFailure
            hadoop.hdfs.server.namenode.TestFavoredNodesEndToEnd
            hadoop.fs.TestSymlinkHdfsDisable
            hadoop.hdfs.server.namenode.TestFSImage
            hadoop.fs.viewfs.TestViewFileSystemHdfs
            hadoop.hdfs.TestDFSInotifyEventInputStream
            hadoop.hdfs.server.namenode.TestCheckpoint
          Timed out tests org.apache.hadoop.hdfs.server.namenode.snapshot.TestSnapshottableDirListing
            org.apache.hadoop.hdfs.server.namenode.snapshot.TestSnapshotDiffReport



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12739807/HDFS-8238.003.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / b039e69
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/11370/artifact/patchprocess/diffcheckstylehadoop-hdfs-client.txt
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/11370/artifact/patchprocess/testrun_hadoop-hdfs.txt
          hadoop-hdfs-client test log https://builds.apache.org/job/PreCommit-HDFS-Build/11370/artifact/patchprocess/testrun_hadoop-hdfs-client.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/11370/testReport/
          Java 1.7.0_55
          uname Linux asf904.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/11370/console

          This message was automatically generated.

          tasanuma0829 Takanobu Asanuma added a comment -

          The previous Jenkins report is not normal. I just have started another Jenkins build for the patch.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 18m 33s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 javac 7m 33s There were no new javac warning messages.
          +1 javadoc 9m 42s There were no new javadoc warning messages.
          +1 release audit 0m 23s The applied patch does not increase the total number of release audit warnings.
          -1 checkstyle 1m 49s The applied patch generated 127 new checkstyle issues (total was 35, now 162).
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 36s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          +1 findbugs 4m 6s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          +1 native 3m 17s Pre-build of native portion
          +1 hdfs tests 161m 15s Tests passed in hadoop-hdfs.
          +1 hdfs tests 0m 17s Tests passed in hadoop-hdfs-client.
              209m 7s  



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12739807/HDFS-8238.003.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / 5dbc8c9
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/11383/artifact/patchprocess/diffcheckstylehadoop-hdfs-client.txt
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/11383/artifact/patchprocess/testrun_hadoop-hdfs.txt
          hadoop-hdfs-client test log https://builds.apache.org/job/PreCommit-HDFS-Build/11383/artifact/patchprocess/testrun_hadoop-hdfs-client.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/11383/testReport/
          Java 1.7.0_55
          uname Linux asf907.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/11383/console

          This message was automatically generated.

          wheat9 Haohui Mai added a comment -

          +1. I'll commit it shortly.

          Takanobu Asanuma, the checkstyle warnings come from the original file. Can you please file a follow-up jira to clean up the warnings? Thanks.

          wheat9 Haohui Mai added a comment -

          I've committed the patch to trunk and branch-2. Thanks Takanobu Asanuma for the contribution.

          tasanuma0829 Takanobu Asanuma added a comment -

          OK, I'll create a jira about it. Thank you for your help and commitment!

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8035 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8035/)
          HDFS-8238. Move ClientProtocol to the hdfs-client. Contributed by Takanobu Asanuma. (wheat9: rev b8327744884bf86b01b8998849e2a42fb9e5c249)

          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/client/HdfsClientConfigKeys.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSConfigKeys.java
            Update CHANGES.txt for HDFS-8238. (wheat9: rev 2de586f60ded874b2c962d0ca8ef2ca7cad25518)
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #962 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/962/)
          HDFS-8238. Move ClientProtocol to the hdfs-client. Contributed by Takanobu Asanuma. (wheat9: rev b8327744884bf86b01b8998849e2a42fb9e5c249)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/client/HdfsClientConfigKeys.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSConfigKeys.java
            Update CHANGES.txt for HDFS-8238. (wheat9: rev 2de586f60ded874b2c962d0ca8ef2ca7cad25518)
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #232 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/232/)
          HDFS-8238. Move ClientProtocol to the hdfs-client. Contributed by Takanobu Asanuma. (wheat9: rev b8327744884bf86b01b8998849e2a42fb9e5c249)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSConfigKeys.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/client/HdfsClientConfigKeys.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
            Update CHANGES.txt for HDFS-8238. (wheat9: rev 2de586f60ded874b2c962d0ca8ef2ca7cad25518)
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Hdfs-trunk #2160 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2160/)
          HDFS-8238. Move ClientProtocol to the hdfs-client. Contributed by Takanobu Asanuma. (wheat9: rev b8327744884bf86b01b8998849e2a42fb9e5c249)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSConfigKeys.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/client/HdfsClientConfigKeys.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
            Update CHANGES.txt for HDFS-8238. (wheat9: rev 2de586f60ded874b2c962d0ca8ef2ca7cad25518)
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Hdfs-trunk-Java8 #221 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/221/)
          HDFS-8238. Move ClientProtocol to the hdfs-client. Contributed by Takanobu Asanuma. (wheat9: rev b8327744884bf86b01b8998849e2a42fb9e5c249)

          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/client/HdfsClientConfigKeys.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSConfigKeys.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
            Update CHANGES.txt for HDFS-8238. (wheat9: rev 2de586f60ded874b2c962d0ca8ef2ca7cad25518)
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #230 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/230/)
          HDFS-8238. Move ClientProtocol to the hdfs-client. Contributed by Takanobu Asanuma. (wheat9: rev b8327744884bf86b01b8998849e2a42fb9e5c249)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSConfigKeys.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/client/HdfsClientConfigKeys.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
            Update CHANGES.txt for HDFS-8238. (wheat9: rev 2de586f60ded874b2c962d0ca8ef2ca7cad25518)
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2178 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2178/)
          HDFS-8238. Move ClientProtocol to the hdfs-client. Contributed by Takanobu Asanuma. (wheat9: rev b8327744884bf86b01b8998849e2a42fb9e5c249)

          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSConfigKeys.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/server/namenode/SafeModeException.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/ClientProtocol.java
          • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/client/HdfsClientConfigKeys.java
            Update CHANGES.txt for HDFS-8238. (wheat9: rev 2de586f60ded874b2c962d0ca8ef2ca7cad25518)
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt

            People

            • Assignee:
              tasanuma0829 Takanobu Asanuma
              Reporter:
              wheat9 Haohui Mai
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development