Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-8211

DataNode UUID is always null in the JMX counter

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.7.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: datanode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The DataNode JMX counters are tagged with DataNode UUID, but it always gets a null value instead of the UUID.

      Hadoop:service=DataNode,name=FSDatasetState*-null*.
      

      This null is supposed be the datanode UUID.

      1. hdfs-8211.002.patch
        4 kB
        Anu Engineer
      2. hdfs-8211.001.patch
        6 kB
        Anu Engineer

        Issue Links

          Activity

          anu Anu Engineer added a comment -

          Also verified that FSDatasetState-UUID appears correctly using jconsole.

          brahmareddy Brahma Reddy Battula added a comment -

          Nice catch, Patch,LGTM +1 ( non binding)

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 14m 23s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 javac 7m 23s There were no new javac warning messages.
          +1 javadoc 9m 29s There were no new javadoc warning messages.
          +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
          +1 checkstyle 5m 26s There were no new checkstyle issues.
          +1 install 1m 31s mvn install still works.
          +1 eclipse:eclipse 0m 38s The patch built with eclipse:eclipse.
          +1 findbugs 3m 4s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
          +1 native 3m 17s Pre-build of native portion
          -1 hdfs tests 163m 54s Tests failed in hadoop-hdfs.
              209m 31s  



          Reason Tests
          Failed unit tests hadoop.hdfs.TestRollingUpgrade



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12727021/hdfs-8211.001.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / 2c14690
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/10337/artifact/patchprocess/testrun_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/10337/testReport/
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/10337//console

          This message was automatically generated.

          anu Anu Engineer added a comment -

          on my machine the test is passing.

          arpitagarwal Arpit Agarwal added a comment -

          Hi Anu Engineer, thank you for fixing this and adding the test case.

          The fix looks good. The test case seems to pass without the code change. The test could be simplified to just create a stub DN object with the SimulatedFSDataset and invoke initStorage on it. See SimulatedFSDataset#setFactory.

          anu Anu Engineer added a comment -

          I will make the test simpler, thanx for the pointers

          The test case seems to pass without the code change.

          The reason being that all the functions of DataNode are private and it is not possible to trigger the error path from outside. The checkuuid call would write the UUID to storage variable and then on the connection complete it gets copied to id. so the fix is just to read from the storage variable rather than id since both f them point to same values.

          At this point the test simply verifies that new code change that is made does not lead to regressions, it does not test for the initial race condition

          arpitagarwal Arpit Agarwal added a comment -

          The reason being that all the functions of DataNode are private

          Hi Anu, we often work around this by making the method package private and tagging it as @VisibleForTesting.

          anu Anu Engineer added a comment -

          I looked at the SimulatedFSDataSet unfortunately it always have been doing the right thing, it is only now that I noticed it though

          SimulatedFSDataSet.java
              @Override
              public String getStorageUuid() {
                return storage.getStorageUuid();
              }
          

          So invoking it will pass my tests, but I am afraid would not touch the code that path I modified right now. Please let me know if my understanding is correct

          arpitagarwal Arpit Agarwal added a comment -

          The storageUuid/storageId is different from the DatanodeUuid. The former is allocated per storage directory. Yes it is confusing.

          I suggested using SimulatedFSDataSet so we can bypass this code block in initStorage:

              if (!factory.isSimulated()) {
                final StartupOption startOpt = getStartupOption(conf);
          ...
          

          Then all we'd need is a spy object for DataStorage which does nothing when writeAll is invoked.

          anu Anu Engineer added a comment -
          • Make sure that tests works with new code and fails with older code
          • Converted
            checkDatanodeUuid

            to package-local scope

          • Simplified tests using call into
            checkDatanodeUuid
          arpitagarwal Arpit Agarwal added a comment -

          +1 for the new v2 patch, pending Jenkins. Thank you for updating the test case Anu.

          The Jenkins output may be misleading since there are two v2 patches in flight. Will wait for +1 on the correct patch.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 15m 5s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 javac 7m 42s There were no new javac warning messages.
          +1 javadoc 9m 52s There were no new javadoc warning messages.
          +1 release audit 0m 24s The applied patch does not increase the total number of release audit warnings.
          -1 checkstyle 5m 25s The applied patch generated 1 additional checkstyle issues.
          +1 install 1m 35s mvn install still works.
          +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
          +1 findbugs 3m 8s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
          +1 native 3m 17s Pre-build of native portion
          -1 hdfs tests 165m 20s Tests failed in hadoop-hdfs.
              212m 24s  



          Reason Tests
          Failed unit tests hadoop.hdfs.server.namenode.TestDiskspaceQuotaUpdate



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12727966/hdfs-8211.002.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / cf6c8a1
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/10374/artifact/patchprocess/checkstyle-result-diff.txt
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/10374/artifact/patchprocess/testrun_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/10374/testReport/
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/10374/console

          This message was automatically generated.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 14m 36s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 javac 7m 31s There were no new javac warning messages.
          +1 javadoc 9m 31s There were no new javadoc warning messages.
          +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
          -1 checkstyle 3m 58s The applied patch generated 1 additional checkstyle issues.
          +1 install 1m 33s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          +1 findbugs 3m 4s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
          +1 native 3m 14s Pre-build of native portion
          -1 hdfs tests 165m 50s Tests failed in hadoop-hdfs.
              210m 17s  



          Reason Tests
          Failed unit tests hadoop.hdfs.server.namenode.TestDiskspaceQuotaUpdate



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12727980/hdfs-8211.002.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / cf6c8a1
          checkstyle https://builds.apache.org/job/PreCommit-HDFS-Build/10375/artifact/patchprocess/checkstyle-result-diff.txt
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/10375/artifact/patchprocess/testrun_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/10375/testReport/
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/10375/console

          This message was automatically generated.

          anu Anu Engineer added a comment -

          This test has been failing in prior runs too, this is not related to this patch. I have created a seperate jira to track the test failure HDFS-8247

          arpitagarwal Arpit Agarwal added a comment -

          I will commit this shortly. I am going to ignore the checkstyle flag pending the discussion on the dev list.

          Also checkstyle has not identified the exact issue and the formatting looks fine to me from manual inspection.

          arpitagarwal Arpit Agarwal added a comment -

          Committed to 2.8.

          Thanks for the contribution Anu Engineer.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #7672 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7672/)
          HDFS-8211. DataNode UUID is always null in the JMX counter. (Contributed by Anu Engineer) (arp: rev dcc5455e07be75ca44eb6a33d4e706eec11b9905)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataNodeUUID.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #174 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/174/)
          HDFS-8211. DataNode UUID is always null in the JMX counter. (Contributed by Anu Engineer) (arp: rev dcc5455e07be75ca44eb6a33d4e706eec11b9905)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataNodeUUID.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #908 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/908/)
          HDFS-8211. DataNode UUID is always null in the JMX counter. (Contributed by Anu Engineer) (arp: rev dcc5455e07be75ca44eb6a33d4e706eec11b9905)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataNodeUUID.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2106 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2106/)
          HDFS-8211. DataNode UUID is always null in the JMX counter. (Contributed by Anu Engineer) (arp: rev dcc5455e07be75ca44eb6a33d4e706eec11b9905)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataNodeUUID.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #165 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/165/)
          HDFS-8211. DataNode UUID is always null in the JMX counter. (Contributed by Anu Engineer) (arp: rev dcc5455e07be75ca44eb6a33d4e706eec11b9905)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataNodeUUID.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #175 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/175/)
          HDFS-8211. DataNode UUID is always null in the JMX counter. (Contributed by Anu Engineer) (arp: rev dcc5455e07be75ca44eb6a33d4e706eec11b9905)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataNodeUUID.java
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Mapreduce-trunk #2124 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2124/)
          HDFS-8211. DataNode UUID is always null in the JMX counter. (Contributed by Anu Engineer) (arp: rev dcc5455e07be75ca44eb6a33d4e706eec11b9905)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/datanode/TestDataNodeUUID.java
          walter.k.su Walter Su added a comment -

          Changes Priority to Major.
          As Harsh J pointed out, this patch unintentionally fixes an issue that DN may regenerate its UUIDs unintentionally (See HDFS-9949).
          I think we should backport this to branch-2.7 ??


            People

            • Assignee:
              anu Anu Engineer
              Reporter:
              anu Anu Engineer
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development