Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-8026

Trace FSOutputSummer#writeChecksumChunks rather than DFSOutputStream#writeChunk

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.7.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Target Version/s:

      Description

      We should trace FSOutputSummer#writeChecksumChunks rather than DFSOutputStream#writeChunk. When tracing writeChunk, we get a new trace span every 512 bytes; when tracing writeChecksumChunks, we normally get a new trace span only when the FSOutputSummer buffer is full (9x less often.)

      1. HDFS-8026.001.patch
        4 kB
        Colin P. McCabe

        Activity

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2101 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2101/)
        HDFS-8026. Trace FSOutputSummer#writeChecksumChunks rather than DFSOutputStream#writeChunk (cmccabe) (cmccabe: rev c94d594a57806dec515e2a2053a1221f8ce48cc4)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FSOutputSummer.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #151 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/151/)
        HDFS-8026. Trace FSOutputSummer#writeChecksumChunks rather than DFSOutputStream#writeChunk (cmccabe) (cmccabe: rev c94d594a57806dec515e2a2053a1221f8ce48cc4)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FSOutputSummer.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #142 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/142/)
        HDFS-8026. Trace FSOutputSummer#writeChecksumChunks rather than DFSOutputStream#writeChunk (cmccabe) (cmccabe: rev c94d594a57806dec515e2a2053a1221f8ce48cc4)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FSOutputSummer.java
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2083 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2083/)
        HDFS-8026. Trace FSOutputSummer#writeChecksumChunks rather than DFSOutputStream#writeChunk (cmccabe) (cmccabe: rev c94d594a57806dec515e2a2053a1221f8ce48cc4)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FSOutputSummer.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #151 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/151/)
        HDFS-8026. Trace FSOutputSummer#writeChecksumChunks rather than DFSOutputStream#writeChunk (cmccabe) (cmccabe: rev c94d594a57806dec515e2a2053a1221f8ce48cc4)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FSOutputSummer.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk #885 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/885/)
        HDFS-8026. Trace FSOutputSummer#writeChecksumChunks rather than DFSOutputStream#writeChunk (cmccabe) (cmccabe: rev c94d594a57806dec515e2a2053a1221f8ce48cc4)

        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FSOutputSummer.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        cmccabe Colin P. McCabe added a comment -

        I'm not sure if there is an open jira about TestTracing being flaky. The ones that I'm familiar with (and can find in a quick search) have already been resolved. We can open a new one if it keeps re-occurring. In the meantime, I put it down to the usual jenkins flakiness. Hopefully the new test-patch.sh will resolve some of these issues...

        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-trunk-Commit #7488 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7488/)
        HDFS-8026. Trace FSOutputSummer#writeChecksumChunks rather than DFSOutputStream#writeChunk (cmccabe) (cmccabe: rev c94d594a57806dec515e2a2053a1221f8ce48cc4)

        • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FSOutputSummer.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        hitliuyi Yi Liu added a comment - - edited

        Yes, please go ahead to commit it, thanks Colin.

        I remember there is a JIRA about TestTracing failure filed few days ago, but I can't find it now, let's use that JIRA?

        cmccabe Colin P. McCabe added a comment -

        I think the previous test timeout on TestTracing was not related to this patch, since it didn't reproduce the second time I ran it on JIRA. I also can't reproduce it locally. This patch is not really changing how TestTracing works, just tweaking a string that it's looking for, so I would not expect it to regress this. While it's kind of unfortunate that the test (may be?) flaky, I think we should not let that block this patch.

        I'm going to commit in just a bit... if we hit more timeouts on TestTracing, we'll have to have a separate JIRA to investigate. Thanks, Yi Liu.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12708293/HDFS-8026.001.patch
        against trunk revision 79f7f2a.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common hadoop-hdfs-project/hadoop-hdfs:

        org.apache.hadoop.hdfs.server.namenode.ha.TestRetryCacheWithHA

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/10131//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/10131//console

        This message is automatically generated.

        cmccabe Colin P. McCabe added a comment -

        TestTracing succeeds locally for me. The jenkins failure seems to be a timeout that I can't reproduce. Let me re-run this on upstream Jenkins.

        hitliuyi Yi Liu added a comment -

        TestTracing fails again.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12708293/HDFS-8026.001.patch
        against trunk revision 1a495fb.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common hadoop-hdfs-project/hadoop-hdfs:

        org.apache.hadoop.hdfs.TestSetrepIncreasing
        org.apache.hadoop.tracing.TestTracing

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/10122//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/10122//console

        This message is automatically generated.

        hitliuyi Yi Liu added a comment -

        +1


          People

          • Assignee:
            cmccabe Colin P. McCabe
            Reporter:
            cmccabe Colin P. McCabe
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development