Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.21.0, 0.22.0
    • Fix Version/s: 0.21.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      TestHDFSCLI is failing apparently because of

      552: help: help for du
      553: help: help for dus
      
      1. HDFS-792.patch
        4 kB
        Konstantin Boudnik
      2. hdfs-792.txt
        4 kB
        Todd Lipcon

        Issue Links

          Activity

          Konstantin Boudnik added a comment -

          Seems to cause problems only in 0.21.

          Konstantin Boudnik added a comment -

          This is the regression of HADOOP-6375. The reason why it hasn't been caught by a Hudson's test-patch is that the test hasn't been actually ran as one can clearly see here

          The JIRA in question has introduced new help messages for du command and the modification has never been tested

          Todd Lipcon added a comment -

          I'll get a fix up for this today.

          Why is it that Hudson didn't include TestHDFSCLI in the test-patch?

          Konstantin Boudnik added a comment -

          I think the reason why it has been improperly reported is here

          2009-11-17 01:21:28,937 WARN  conf.Configuration (Configuration.java:<clinit>(345)) - DEPRECATED: hadoop-site.xml found in the classpath. Usage of hadoop-site.xml is deprecated. Instead use core-site.xml, mapred-site.xml and hdfs-site.xml to override properties of core-default.xml, mapred-default.xml and hdfs-default.xml respectively
          

          Test has been terminated but without setting a failure status. I'm not even sure if this is a test-patch problem.

          Konstantin Boudnik added a comment -

          Todd is working on the patch

          Konstantin Boudnik added a comment -

          +1 for the patch.
          I've ran the patched version of the test. Except for the performance issues reported by HDFS-797 everything else seems to be Ok.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12426470/hdfs-792.txt
          against trunk revision 885538.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 5 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/127/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/127/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/127/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/127/console

          This message is automatically generated.

          Konstantin Boudnik added a comment -

          0.22 is failing because of this issue as well. Recent patch verification has failed and its log file contains this info:

               [exec]     Failing tests:
               [exec]     --------------
               [exec]     552: help: help for du
               [exec]     553: help: help for dus
          

          So, the patch has to be applied to 0.22 and backported to 0.21

          Konstantin Boudnik added a comment -

          I've noticed that provided patch has a single empty line modification which is unrelated, so I've removed it. The new version of the patch is exactly is the old one except for this one empty line removal.

          Konstantin Boudnik added a comment -

          +1 on the patch. I've verified that latest version on both 0.21 and 0.22 and it works great.

          Konstantin Boudnik added a comment -

          I've just committed this. Thanks, Todd!

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #128 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/128/)
          . TestHDFSCLI is failing. Contributed by Todd Lipcon.

          Hudson added a comment -

          Integrated in Hdfs-Patch-h5.grid.sp2.yahoo.net #129 (See http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/129/)
          . TestHDFSCLI is failing. Contributed by Todd Lipcon.

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #159 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk/159/)

          Hudson added a comment -

          Integrated in Hdfs-Patch-h2.grid.sp2.yahoo.net #81 (See http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/81/)

          Hairong Kuang added a comment -

          I hit this again even with the fix. Shall we reopen this jira?

          Konstantin Boudnik added a comment -

          If you see this happening I'd suggest you try

            % ant veryclean 
          

          and then run the tests again. I've seen cases when Ivy failed to pull new version of common snapshot jar from the Maven repo.

          If it won't help then please reopen the bug.


            People

            • Assignee:
              Todd Lipcon
              Reporter:
              Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development