This is based on the code review feedback from [~arpitagarwal] on
HDFS-7723. We decide to put the refactoring/renaming work in a separate JIRA to avoid further increasing the size of current patch for HDFS-7723. Below is the initial refactoring to-do list.
- QuotaCounts: typeSpaces and typeCounts are used interchangeably. We should probably name them consistently.
- You renamed DEFAULT_DISKSPACE_QUOTA to DEFAULT_SPACE_QUOTA. DEFAULT_STORAGE_SPACE_QUOTA would be easier to understand. Comments like @return the namespace and diskspace consumed can also be edited to use storage space instead of diskspace.
- Add Javadocs to FsImageFormat.java on why storage type quota for FSImageFormat.java. "We don't have quota by storage type record in legacy fsimages, which is handled in this FSImageFormat class (used by legacy_oiv only). The current fsimage processing is done in the protobuf based class FSImageFormatProtobuf, which is updated with typeCounts by