Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-774

Intermittent race condition in TestFiPipelines

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      At least one evidence of possible race condition has been seen in the Hudson build

      1. HDFS-774.patch
        1 kB
        Konstantin Boudnik

        Activity

        Hudson added a comment -

        Integrated in Hdfs-Patch-h2.grid.sp2.yahoo.net #81 (See http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/81/)

        Hudson added a comment -

        Integrated in Hdfs-Patch-h5.grid.sp2.yahoo.net #118 (See http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h5.grid.sp2.yahoo.net/118/)

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #145 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk/145/)

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #112 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/112/)
        . Intermittent race condition in TestFiPipelines. Contributed by Konstantin Boudnik

        Konstantin Boudnik added a comment -

        Thanks for the review, Nicholas.

        The patch affects branch 0.21 as well.

        I've just committed this.

        Tsz Wo Nicholas Sze added a comment -

        +1

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12425106/HDFS-774.patch
        against trunk revision 880630.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/76/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/76/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/76/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-h2.grid.sp2.yahoo.net/76/console

        This message is automatically generated.

        Konstantin Boudnik added a comment -

        I've ran the patched code a number of times and it seems to be Ok.

        Konstantin Boudnik added a comment -

        Making shutdown() method to be synchronized should address the issue

        Konstantin Boudnik added a comment -

        The issue is seems to be caused by a concurrent attempt to shutdown mini cluster.


          People

          • Assignee:
            Konstantin Boudnik
            Reporter:
            Konstantin Boudnik
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development