Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-7671

hdfs user guide should point to the common rack awareness doc

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: documentation
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      HDFS user guide has a section on rack awareness that should really just be a pointer to the common doc.

      1. HDFS-7671.1.patch
        2 kB
        Kai Sasaki
      2. HDFS-7671.2.patch
        1 kB
        Kai Sasaki
      3. HDFS-7671.3.patch
        1 kB
        Kai Sasaki

        Activity

        kaisasak Kai Sasaki added a comment -

        I attached a link to common correspond docs. Can someone review it?

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12701829/HDFS-7671.1.patch
        against trunk revision 67ed593.

        +1 @author. The patch does not contain any @author tags.

        +0 tests included. The patch appears to be a documentation patch that doesn't require tests.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:

        org.apache.hadoop.hdfs.TestCrcCorruption
        org.apache.hadoop.hdfs.server.namenode.TestHostsFiles

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/9694//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9694//console

        This message is automatically generated.

        aw Allen Wittenauer added a comment -
        • Links should be to relative paths when referring to other documentation in the tree.
        • The actual documentation you want to link to is the html file generated by the RackAwareness.md file.
        • The rewrite shouldn't include any technical details since the rack awareness doc covers all of that.
        kaisasak Kai Sasaki added a comment -

        Allen Wittenauer Thank you for comments, but I have a question about first one and I cannot figure out second and third points.

        > Links should be to relative paths when referring to other documentation in the tree.
        The link where I want to attach belongs to common docs. So the target is not included under document root of HDFS docs. Is there any good way to make relative path to other hadoop project docs?

        > The actual documentation you want to link to is the html file generated by the RackAwareness.md file.
        Do you mean that actual link should be to the .html file or the other?

        > The rewrite shouldn't include any technical details since the rack awareness doc covers all of that.
        Should all current other contents except for the direct link to common doc be removed? Or should I move current contents to common docs?

        aw Allen Wittenauer added a comment -

        The link where I want to attach belongs to common docs. So the target is not included under document root of HDFS docs. Is there any good way to make relative path to other hadoop project docs?

        Do you mean that actual link should be to the .html file or the other?

        You want something like:

         [Rack Awareness](../../hadoop-project-dist/hadoop-common/RackAwareness.html)
        

        This will point to the rack awareness' html file after the mvn build.

        Should all current other contents except for the direct link to common doc be removed? Or should I move current contents to common docs?

        I think the current content (well, the theory and practice, not word for word, obviously) is already covered in that doc. So this section just needs some wordsmithing on why someone should go follow that link to that important topic.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12702979/HDFS-7671.2.patch
        against trunk revision 952640f.

        -1 patch. Trunk compilation may be broken.

        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9768//console

        This message is automatically generated.

        kaisasak Kai Sasaki added a comment -

        This compilation error does not seems to be caused by this patch. Can someone review it?

        ajisakaa Akira Ajisaka added a comment -

        Thanks Kai Sasaki for the patch. Mostly looks good to me. One comment: The link to rack awareness doc

        (../../hadoop-project-dist/hadoop-common/RackAwareness.html)
        

        can be shortened as

        (../hadoop-common/RackAwareness.html)
        

        I'm +1 if that is addressed.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12708265/HDFS-7671.3.patch
        against trunk revision 1a495fb.

        +1 @author. The patch does not contain any @author tags.

        +0 tests included. The patch appears to be a documentation patch that doesn't require tests.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:

        org.apache.hadoop.hdfs.server.namenode.ha.TestRetryCacheWithHA

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/10119//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/10119//console

        This message is automatically generated.

        ajisakaa Akira Ajisaka added a comment -

        +1, checking this in.

        ajisakaa Akira Ajisaka added a comment -

        Committed this to trunk and branch-2. Thanks Kai Sasaki for the contribution.

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #7476 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7476/)
        HDFS-7671. hdfs user guide should point to the common rack awareness doc. Contributed by Kai Sasaki. (aajisaka: rev 859cab2f2273f563fd70e3e616758edef91ccf41)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/site/markdown/HdfsUserGuide.md
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #150 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/150/)
        HDFS-7671. hdfs user guide should point to the common rack awareness doc. Contributed by Kai Sasaki. (aajisaka: rev 859cab2f2273f563fd70e3e616758edef91ccf41)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/site/markdown/HdfsUserGuide.md
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk #884 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/884/)
        HDFS-7671. hdfs user guide should point to the common rack awareness doc. Contributed by Kai Sasaki. (aajisaka: rev 859cab2f2273f563fd70e3e616758edef91ccf41)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/site/markdown/HdfsUserGuide.md
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2082 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2082/)
        HDFS-7671. hdfs user guide should point to the common rack awareness doc. Contributed by Kai Sasaki. (aajisaka: rev 859cab2f2273f563fd70e3e616758edef91ccf41)

        • hadoop-hdfs-project/hadoop-hdfs/src/site/markdown/HdfsUserGuide.md
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #150 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/150/)
        HDFS-7671. hdfs user guide should point to the common rack awareness doc. Contributed by Kai Sasaki. (aajisaka: rev 859cab2f2273f563fd70e3e616758edef91ccf41)

        • hadoop-hdfs-project/hadoop-hdfs/src/site/markdown/HdfsUserGuide.md
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #141 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/141/)
        HDFS-7671. hdfs user guide should point to the common rack awareness doc. Contributed by Kai Sasaki. (aajisaka: rev 859cab2f2273f563fd70e3e616758edef91ccf41)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/site/markdown/HdfsUserGuide.md
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2100 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2100/)
        HDFS-7671. hdfs user guide should point to the common rack awareness doc. Contributed by Kai Sasaki. (aajisaka: rev 859cab2f2273f563fd70e3e616758edef91ccf41)

        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/src/site/markdown/HdfsUserGuide.md

          People

          • Assignee:
            kaisasak Kai Sasaki
            Reporter:
            aw Allen Wittenauer
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development