Details
-
Improvement
-
Status: Closed
-
Minor
-
Resolution: Fixed
-
None
-
None
-
Reviewed
Description
A few minor code cleanup changes:
- The constructor of Dispatcher should not read Balancer's conf properties; the values should be passed by parameters.
- StorageGroup.utilization can be removed; it is only used in toString().
- Move Balancer.ReturnStatus to a standalone class.
- In Dispatcher, rename BalancerDatanode to DDatanode.