Details

      Description

      We don't need KeyProvider in EncryptionZoneManager any more, so we need to remove KeyProvider variable in class and KeyProvider parameter for EncryptionZoneManager#createEncryptionZone

      1. hdfs-6720.002.patch
        32 kB
        Andrew Wang
      2. hdfs-6720.001.patch
        32 kB
        Andrew Wang

        Activity

        Hide
        Andrew Wang added a comment -

        Committed to branch, thanks again for reviewing Yi!

        Show
        Andrew Wang added a comment - Committed to branch, thanks again for reviewing Yi!
        Hide
        Andrew Wang added a comment -

        Good point Yi, new patch removes this comment. Thanks for reviewing, I'll commit this shortly.

        Show
        Andrew Wang added a comment - Good point Yi, new patch removes this comment. Thanks for reviewing, I'll commit this shortly.
        Hide
        Yi Liu added a comment -

        Thanks Andrew Wang, the patch is straight and good. One comment, +1 after addressing it.

        // Re-get the new encryption zone add the latest key version
        ezi = getEncryptionZoneForPath(srcIIP);

        This is not necessary, please remove it.

        Show
        Yi Liu added a comment - Thanks Andrew Wang , the patch is straight and good. One comment, +1 after addressing it. // Re-get the new encryption zone add the latest key version ezi = getEncryptionZoneForPath(srcIIP); This is not necessary, please remove it.
        Hide
        Andrew Wang added a comment -

        Thanks for finding this issue Yi, patch attached which cleans up EZManager.

        I also took the opportunity to finish renaming "keyId" to "keyName" where I could find it, since that's the proper term used in KeyProvider. Kind of a big refactor, but straightforward. Also fixed some old javadoc in HdfsAdmin while I was there.

        Show
        Andrew Wang added a comment - Thanks for finding this issue Yi, patch attached which cleans up EZManager. I also took the opportunity to finish renaming "keyId" to "keyName" where I could find it, since that's the proper term used in KeyProvider. Kind of a big refactor, but straightforward. Also fixed some old javadoc in HdfsAdmin while I was there.

          People

          • Assignee:
            Andrew Wang
            Reporter:
            Yi Liu
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development