Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-6627

Rename DataNode#checkWriteAccess to checkReadAccess.

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.0, 3.0.0-alpha1
    • Fix Version/s: 2.6.0
    • Component/s: datanode
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Just read getReplicaVisibleLength() code and found it, DataNode.checkWriteAccess is only invoked by DataNode.getReplicaVisibleLength(), let's rename it to checkReadAccess to avoid confusing, since the real impl here is check AccessMode.READ:

              blockPoolTokenSecretManager.checkAccess(id, null, block,
                  BlockTokenSecretManager.AccessMode.READ);
      

        Attachments

        1. HDFS-6627.txt
          1.0 kB
          Liang Xie

          Issue Links

            Activity

              People

              • Assignee:
                xieliang007 Liang Xie
                Reporter:
                xieliang007 Liang Xie
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: