Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-6455

NFS: Exception should be added in NFS log for invalid separator in nfs.exports.allowed.hosts

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.6.0
    • Component/s: nfs
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The error for invalid separator in dfs.nfs.exports.allowed.hosts property should be added in nfs log file instead nfs.out file.

      Steps to reproduce:
      1. Pass invalid separator in dfs.nfs.exports.allowed.hosts

      <property><name>dfs.nfs.exports.allowed.hosts</name><value>host1  ro:host2 rw</value></property>
      

      2. restart NFS server. NFS server fails to start and print exception console.

      [hrt_qa@host1 hwqe]$ ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null host1 "sudo su - -c \"/usr/lib/hadoop/sbin/hadoop-daemon.sh start nfs3\" hdfs"
      starting nfs3, logging to /tmp/log/hadoop/hdfs/hadoop-hdfs-nfs3-horst1.out
      DEPRECATED: Use of this script to execute hdfs command is deprecated.
      Instead use the hdfs command for it.
      
      Exception in thread "main" java.lang.IllegalArgumentException: Incorrectly formatted line 'host1 ro:host2 rw'
      	at org.apache.hadoop.nfs.NfsExports.getMatch(NfsExports.java:356)
      	at org.apache.hadoop.nfs.NfsExports.<init>(NfsExports.java:151)
      	at org.apache.hadoop.nfs.NfsExports.getInstance(NfsExports.java:54)
      	at org.apache.hadoop.hdfs.nfs.nfs3.RpcProgramNfs3.<init>(RpcProgramNfs3.java:176)
      	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.<init>(Nfs3.java:43)
      	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.main(Nfs3.java:59)
      

      NFS log does not print any error message. It directly shuts down.

      STARTUP_MSG:   java = 1.6.0_31
      ************************************************************/
      2014-05-27 18:47:13,972 INFO  nfs3.Nfs3Base (SignalLogger.java:register(91)) - registered UNIX signal handlers for [TERM, HUP, INT]
      2014-05-27 18:47:14,169 INFO  nfs3.IdUserGroup (IdUserGroup.java:updateMapInternal(159)) - Updated user map size:259
      2014-05-27 18:47:14,179 INFO  nfs3.IdUserGroup (IdUserGroup.java:updateMapInternal(159)) - Updated group map size:73
      2014-05-27 18:47:14,192 INFO  nfs3.Nfs3Base (StringUtils.java:run(640)) - SHUTDOWN_MSG:
      /************************************************************
      SHUTDOWN_MSG: Shutting down Nfs3 at 
      

      NFS.out file has exception.

      EPRECATED: Use of this script to execute hdfs command is deprecated.
      Instead use the hdfs command for it.
      
      Exception in thread "main" java.lang.IllegalArgumentException: Incorrectly formatted line 'host1 ro:host2 rw'
              at org.apache.hadoop.nfs.NfsExports.getMatch(NfsExports.java:356)
              at org.apache.hadoop.nfs.NfsExports.<init>(NfsExports.java:151)
              at org.apache.hadoop.nfs.NfsExports.getInstance(NfsExports.java:54)
              at org.apache.hadoop.hdfs.nfs.nfs3.RpcProgramNfs3.<init>(RpcProgramNfs3.java:176)
              at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.<init>(Nfs3.java:43)
              at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.main(Nfs3.java:59)
      ulimit -a for user hdfs
      core file size          (blocks, -c) 409600
      data seg size           (kbytes, -d) unlimited
      scheduling priority             (-e) 0
      file size               (blocks, -f) unlimited
      pending signals                 (-i) 188893
      max locked memory       (kbytes, -l) unlimited
      max memory size         (kbytes, -m) unlimited
      open files                      (-n) 32768
      pipe size            (512 bytes, -p) 8
      POSIX message queues     (bytes, -q) 819200
      real-time priority              (-r) 0
      stack size              (kbytes, -s) 10240
      cpu time               (seconds, -t) unlimited
      max user processes              (-u) 65536
      virtual memory          (kbytes, -v) unlimited
      file locks                      (-x) unlimited
      
      1. HDFS-6455.002.patch
        4 kB
        Abhiraj Butala
      2. HDFS-6455.patch
        3 kB
        Abhiraj Butala

        Issue Links

          Activity

          Brandon Li added a comment -

          The code throws IllegalArgumentException so the error is printed into xxx.out file instead of xxx.log file.
          Here we should throw non-run-time exception since the wrong configuration is a user error.

          Abhiraj Butala added a comment -

          Hey Brandon, I compared this with the NN's behavior for illegal arguments and even it throws IllegalArgumentException. NN's main catches this exception, logs a FATAL message (making sure it gets added in logs) and then calls terminate(). Should we similarly add a log message here instead before exiting?

          Also, as per your comments in HDFS-6456, shutdown may not be desirable for incorrect exports as we want to support refreshing them without restarting NFS gateway. So we should make sure we catch the exception appropriately, log it and not shutdown here? Please advise. Thank you!

          Brandon Li added a comment -

          Should we similarly add a log message here instead before exiting?

          Yes. A log message is preferred.

          So we should make sure we catch the exception appropriately, log it and not shutdown here?

          Agree.

          Abhiraj Butala added a comment -

          Thanks for the feedback Brandon. Attaching a patch which catches the exception and logs it as ERROR in logs. NFS server does not exit now. 'showmount' command times out when invalid exports are provided.

          Output of 'hdfs nfs3':

          14/07/06 02:13:37 INFO nfs3.Nfs3Base: registered UNIX signal handlers for [TERM, HUP, INT]
          14/07/06 02:13:38 INFO oncrpc.RpcProgram: Will accept client connections from unprivileged ports
          14/07/06 02:13:38 INFO nfs3.IdUserGroup: Not doing static UID/GID mapping because '/etc/nfs.map' does not exist.
          14/07/06 02:13:38 INFO nfs3.IdUserGroup: Updated user map size: 36
          14/07/06 02:13:38 INFO nfs3.IdUserGroup: Updated group map size: 65
          14/07/06 02:13:38 ERROR nfs.NfsExports: Invalid NFS Exports provided:
          java.lang.IllegalArgumentException: Incorrectly formatted line 'abc ro :foobar rw'
          	at org.apache.hadoop.nfs.NfsExports.getMatch(NfsExports.java:363)
          	at org.apache.hadoop.nfs.NfsExports.<init>(NfsExports.java:158)
          	at org.apache.hadoop.nfs.NfsExports.getInstance(NfsExports.java:57)
          	at org.apache.hadoop.hdfs.nfs.nfs3.RpcProgramNfs3.<init>(RpcProgramNfs3.java:177)
          	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.<init>(Nfs3.java:45)
          	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.startService(Nfs3.java:66)
          	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.main(Nfs3.java:72)
          14/07/06 02:13:38 INFO nfs3.WriteManager: Stream timeout is 600000ms.
          14/07/06 02:13:38 INFO nfs3.WriteManager: Maximum open streams is 256
          14/07/06 02:13:38 INFO nfs3.OpenFileCtxCache: Maximum open streams is 256
          14/07/06 02:13:39 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
          14/07/06 02:13:39 INFO nfs3.RpcProgramNfs3: Delete current dump directory /tmp/.hdfs-nfs3
          14/07/06 02:13:39 INFO nfs3.RpcProgramNfs3: Create new dump directory /tmp/.hdfs-nfs3
          14/07/06 02:13:39 INFO nfs3.Nfs3Base: NFS server port set to: 2049
          14/07/06 02:13:39 INFO oncrpc.RpcProgram: Will accept client connections from unprivileged ports
          14/07/06 02:13:39 ERROR nfs.NfsExports: Invalid NFS Exports provided:
          java.lang.IllegalArgumentException: Incorrectly formatted line 'abc ro :foobar rw'
          	at org.apache.hadoop.nfs.NfsExports.getMatch(NfsExports.java:363)
          	at org.apache.hadoop.nfs.NfsExports.<init>(NfsExports.java:158)
          	at org.apache.hadoop.nfs.NfsExports.getInstance(NfsExports.java:57)
          	at org.apache.hadoop.hdfs.nfs.mount.RpcProgramMountd.<init>(RpcProgramMountd.java:88)
          	at org.apache.hadoop.hdfs.nfs.mount.Mountd.<init>(Mountd.java:37)
          	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.<init>(Nfs3.java:46)
          	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.startService(Nfs3.java:66)
          	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.main(Nfs3.java:72)
          14/07/06 02:13:40 INFO oncrpc.SimpleUdpServer: Started listening to UDP requests at port 4242 for Rpc program: mountd at localhost:4242 with workerCount 1
          14/07/06 02:13:40 INFO oncrpc.SimpleTcpServer: Started listening to TCP requests at port 4242 for Rpc program: mountd at localhost:4242 with workerCount 1
          14/07/06 02:13:40 INFO oncrpc.SimpleTcpServer: Started listening to TCP requests at port 2049 for Rpc program: NFS3 at localhost:2049 with workerCount 0
          
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12654201/HDFS-6455.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-nfs hadoop-hdfs-project/hadoop-hdfs-nfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/7284//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/7284//console

          This message is automatically generated.

          Brandon Li added a comment -

          The patch looks good.

          'showmount' command times out when invalid exports are provided.

          is this due to NFS bug?

          Abhiraj Butala added a comment -

          Thanks for reviewing the patch Brandon Li. This is the output of showmount command:

          abutala@abutala-vBox:~$ showmount -e 127.0.1.1
          rpc mount export: RPC: Timed out
          

          I don't see any errors or log messages in NFS server output. What should be the correct behavior of showmount in this case?

          Brandon Li added a comment -

          Sorry for the late reply. The time out is possibly due to this code in the patch:

          +      if (hostsMatcher != null) {
          +        hostsMatchers.add(hostsMatcher);
          +        out = MountResponse.writeExportList(out, xid, exports, hostsMatchers);
          +      }
          

          If hostMatcher is null, it doesn't send response back.
          I would suggest fixing HDFS-6456 first since it will fix part of the problem. After patch to HDFS-6456 is committed, this problem will be easier to fix.

          Brandon Li added a comment -

          Abhiraj Butala, HDFS-6456 has been fixed. Please rebased the current patch. I think it should be a smaller change now.

          Abhiraj Butala added a comment -

          Thanks Brandon Li, I rebased the patch and addressed the showmount timeout issue. This is how the showmount output looks like now:

          showmount -e 127.0.1.1
          rpc mount export: RPC: Procedure unavailable
          

          So to summarize the patch does following:
          1. Catch IllegalArgumentException, log it and return null NFS export instead of exiting the program.
          2. Handle null NFS exports at appropriate places to avoid NullPointerException.

          Let me know if anything. Thanks again!

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12656009/HDFS-6455.002.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-nfs hadoop-hdfs-project/hadoop-hdfs-nfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/7359//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/7359//console

          This message is automatically generated.

          Brandon Li added a comment -

          Thank you, Abhiraj Butala. The patch looks good. It would be nice to add a unit test to validate the fix. You can use TestReaddir as a reference to add the unit test.

          Abhiraj Butala added a comment -

          Thanks for reviewing the patch Brandon Li. As a part of fix to HDFS-6456, I have already added a unit test which also checks for invalid separator (given below) in allowed.hosts . Let me know if there is any other test case I should add.

          +  @Test(expected=IllegalArgumentException.class)
          +  public void testInvalidSeparator() {
          +      NfsExports matcher = new NfsExports(CacheSize, ExpirationPeriod,
          +        "foo ro : bar rw");
          +  }
          
          Brandon Li added a comment -

          Sounds ok to me.
          +1.

          Brandon Li added a comment -

          I've committed the patch. Thank you, Abhiraj Butala, for the contribution!

          Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #5955 (See https://builds.apache.org/job/Hadoop-trunk-Commit/5955/)
          HDFS-6455. NFS: Exception should be added in NFS log for invalid separator in nfs.exports.allowed.hosts. Contributed by Abhiraj Butala (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1612947)

          • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/nfs/NfsExports.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/mount/RpcProgramMountd.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/nfs3/RpcProgramNfs3.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #622 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/622/)
          HDFS-6455. NFS: Exception should be added in NFS log for invalid separator in nfs.exports.allowed.hosts. Contributed by Abhiraj Butala (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1612947)

          • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/nfs/NfsExports.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/mount/RpcProgramMountd.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/nfs3/RpcProgramNfs3.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #1814 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1814/)
          HDFS-6455. NFS: Exception should be added in NFS log for invalid separator in nfs.exports.allowed.hosts. Contributed by Abhiraj Butala (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1612947)

          • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/nfs/NfsExports.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/mount/RpcProgramMountd.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/nfs3/RpcProgramNfs3.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Mapreduce-trunk #1841 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1841/)
          HDFS-6455. NFS: Exception should be added in NFS log for invalid separator in nfs.exports.allowed.hosts. Contributed by Abhiraj Butala (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1612947)

          • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/nfs/NfsExports.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/mount/RpcProgramMountd.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs-nfs/src/main/java/org/apache/hadoop/hdfs/nfs/nfs3/RpcProgramNfs3.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt

            People

            • Assignee:
              Abhiraj Butala
              Reporter:
              Yesha Vora
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development