Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-6378

NFS registration should timeout instead of hanging when portmap/rpcbind is not available

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.5.0
    • Component/s: nfs
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      When portmap/rpcbind is not available, NFS could be stuck at registration. Instead, NFS gateway should shut down automatically with proper error message.

      1. HDFS-6378.patch
        0.7 kB
        Abhiraj Butala
      2. HDFS-6378.003.patch
        5 kB
        Abhiraj Butala
      3. HDFS-6378.002.patch
        5 kB
        Abhiraj Butala

        Activity

        Brandon Li added a comment -

        Ctrl-C can’t kill NFS if portmap is not started:

        14/05/08 15:58:06 INFO nfs3.IdUserGroup: Updated user map size:85
        14/05/08 15:58:06 INFO nfs3.IdUserGroup: Updated group map size:110
        14/05/08 15:58:06 INFO nfs3.WriteManager: Stream timeout is 1ms.
        14/05/08 15:58:06 INFO nfs3.WriteManager: Reset stream timeout to minimum value 10000ms.
        14/05/08 15:58:06 INFO nfs3.WriteManager: Maximum open streams is 2
        14/05/08 15:58:06 INFO nfs3.OpenFileCtxCache: Maximum open streams is 2
        2014-05-08 15:58:07.119 java[19176:1003] Unable to load realm info from SCDynamicStore
        14/05/08 15:58:07 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
        14/05/08 15:58:07 INFO nfs3.RpcProgramNfs3: Create new dump directory /tmp/.hdfs-nfs
        14/05/08 15:58:07 INFO nfs3.Nfs3Base: NFS server port set to: 2049
        14/05/08 15:58:07 INFO oncrpc.SimpleUdpServer: Started listening to UDP requests at port 9009 for Rpc program: mountd at localhost:9009 with workerCount 1
        14/05/08 15:58:07 INFO oncrpc.SimpleTcpServer: Started listening to TCP requests at port 9009 for Rpc program: mountd at localhost:9009 with workerCount 1
        ^C14/05/08 15:58:57 ERROR nfs3.Nfs3Base: RECEIVED SIGNAL 2: SIGINT
        ^C14/05/08 15:59:00 ERROR nfs3.Nfs3Base: RECEIVED SIGNAL 2: SIGINT
        ^C14/05/08 15:59:03 ERROR nfs3.Nfs3Base: RECEIVED SIGNAL 2: SIGINT
        

        The stack trace:

        "main" prio=5 tid=7fe77c000800 nid=0x102a8e000 runnable [102a8d000]
           java.lang.Thread.State: RUNNABLE
                at java.net.PlainDatagramSocketImpl.receive0(Native Method)
                - locked <77df4def8> (a java.net.PlainDatagramSocketImpl)
                at java.net.PlainDatagramSocketImpl.receive(PlainDatagramSocketImpl.java:188)
                - locked <77df4def8> (a java.net.PlainDatagramSocketImpl)
                at java.net.DatagramSocket.receive(DatagramSocket.java:725)
                - locked <77df4e978> (a java.net.DatagramPacket)
                - locked <77df4cfb8> (a java.net.DatagramSocket)
                at org.apache.hadoop.oncrpc.SimpleUdpClient.run(SimpleUdpClient.java:65)
                at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:119)
                at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:90)
                at org.apache.hadoop.mount.MountdBase.start(MountdBase.java:77)
                at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.startServiceInternal(Nfs3.java:58)
                at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.startService(Nfs3.java:66)
                at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.main(Nfs3.java:70)
        
        Abhiraj Butala added a comment -

        Attaching a simple patch to add a timeout to DatagramSocket which otherwise blocks indefinitely on receive(). I have kept the timeout to be 500ms, let me know if it should be changed to something more appropriate.

        Ctrl-C is now able to kill NFS gateway if portmap is not running or is exited. Note that, an exception is logged when portmap is not running, but NFS gateway does not exit until Ctrl-C is pressed.

        Output logs:

        14/06/29 03:11:46 INFO oncrpc.SimpleUdpServer: Started listening to UDP requests at port 4242 for Rpc program: mountd at localhost:4242 with workerCount 1
        14/06/29 03:11:46 INFO oncrpc.SimpleTcpServer: Started listening to TCP requests at port 4242 for Rpc program: mountd at localhost:4242 with workerCount 1
        14/06/29 03:11:46 ERROR oncrpc.RpcProgram: Registration failure with localhost:4242, portmap entry: (PortmapMapping-100005:1:17:4242)
        java.net.SocketTimeoutException: Receive timed out
        	at java.net.PlainDatagramSocketImpl.receive0(Native Method)
        	at java.net.AbstractPlainDatagramSocketImpl.receive(AbstractPlainDatagramSocketImpl.java:145)
        	at java.net.DatagramSocket.receive(DatagramSocket.java:786)
        	at org.apache.hadoop.oncrpc.SimpleUdpClient.run(SimpleUdpClient.java:66)
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:130)
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:101)
        	at org.apache.hadoop.mount.MountdBase.start(MountdBase.java:77)
        	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.startServiceInternal(Nfs3.java:55)
        	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.startService(Nfs3.java:68)
        	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.main(Nfs3.java:72)
        Exception in thread "main" java.lang.RuntimeException: Registration failure
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:135)
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:101)
        	at org.apache.hadoop.mount.MountdBase.start(MountdBase.java:77)
        	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.startServiceInternal(Nfs3.java:55)
        	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.startService(Nfs3.java:68)
        	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.main(Nfs3.java:72)
        Caused by: java.net.SocketTimeoutException: Receive timed out
        	at java.net.PlainDatagramSocketImpl.receive0(Native Method)
        	at java.net.AbstractPlainDatagramSocketImpl.receive(AbstractPlainDatagramSocketImpl.java:145)
        	at java.net.DatagramSocket.receive(DatagramSocket.java:786)
        	at org.apache.hadoop.oncrpc.SimpleUdpClient.run(SimpleUdpClient.java:66)
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:130)
        	... 5 more
        ^C14/06/29 03:18:51 ERROR nfs3.Nfs3Base: RECEIVED SIGNAL 2: SIGINT
        14/06/29 03:18:52 ERROR oncrpc.RpcProgram: Unregistration failure with localhost:4242, portmap entry: (PortmapMapping-100005:1:17:4242)
        java.net.SocketTimeoutException: Receive timed out
        	at java.net.PlainDatagramSocketImpl.receive0(Native Method)
        	at java.net.AbstractPlainDatagramSocketImpl.receive(AbstractPlainDatagramSocketImpl.java:145)
        	at java.net.DatagramSocket.receive(DatagramSocket.java:786)
        	at org.apache.hadoop.oncrpc.SimpleUdpClient.run(SimpleUdpClient.java:66)
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:130)
        	at org.apache.hadoop.oncrpc.RpcProgram.unregister(RpcProgram.java:118)
        	at org.apache.hadoop.mount.MountdBase$Unregister.run(MountdBase.java:90)
        	at org.apache.hadoop.util.ShutdownHookManager$1.run(ShutdownHookManager.java:54)
        14/06/29 03:18:52 WARN util.ShutdownHookManager: ShutdownHook 'Unregister' failed, java.lang.RuntimeException: Unregistration failure
        java.lang.RuntimeException: Unregistration failure
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:135)
        	at org.apache.hadoop.oncrpc.RpcProgram.unregister(RpcProgram.java:118)
        	at org.apache.hadoop.mount.MountdBase$Unregister.run(MountdBase.java:90)
        	at org.apache.hadoop.util.ShutdownHookManager$1.run(ShutdownHookManager.java:54)
        Caused by: java.net.SocketTimeoutException: Receive timed out
        	at java.net.PlainDatagramSocketImpl.receive0(Native Method)
        	at java.net.AbstractPlainDatagramSocketImpl.receive(AbstractPlainDatagramSocketImpl.java:145)
        	at java.net.DatagramSocket.receive(DatagramSocket.java:786)
        	at org.apache.hadoop.oncrpc.SimpleUdpClient.run(SimpleUdpClient.java:66)
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:130)
        	... 3 more
        14/06/29 03:18:52 INFO nfs3.Nfs3Base: SHUTDOWN_MSG:
        /************************************************************
        SHUTDOWN_MSG: Shutting down Nfs3 at abutala-vBox/127.0.1.1
        ************************************************************/
        
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12653049/HDFS-6378.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-nfs.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/7241//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/7241//console

        This message is automatically generated.

        Brandon Li added a comment -

        Abhiraj Butala, thanks for the fix. 500ms looks ok to me since portmap/rpcbind is supposed to be local.
        If Nfs3Base and MountdBase can catch the exception thrown by RpcProgram.register, they can choose to shutdown when the registration fails.

        Abhiraj Butala added a comment -

        Thanks for the feedback Brandon. Attaching a patch which addresses your comments. Also, I moved the Shutdown hook registration to be after the registration itself, because it would be redundant if the registration itself exited with exception. Finally, I have removed some extra white spaces.

        Here are some outputs:

        1. 'hdfs nfs3' without starting 'hdfs portmap':

        14/07/02 02:02:01 INFO nfs3.Nfs3Base: NFS server port set to: 2049
        14/07/02 02:02:01 INFO oncrpc.RpcProgram: Will accept client connections from unprivileged ports
        14/07/02 02:02:02 INFO oncrpc.SimpleUdpServer: Started listening to UDP requests at port 4242 for Rpc program: mountd at localhost:4242 with workerCount 1
        14/07/02 02:02:02 INFO oncrpc.SimpleTcpServer: Started listening to TCP requests at port 4242 for Rpc program: mountd at localhost:4242 with workerCount 1
        14/07/02 02:02:03 ERROR oncrpc.RpcProgram: Registration failure with localhost:4242, portmap entry: (PortmapMapping-100005:1:17:4242)
        14/07/02 02:02:03 FATAL mount.MountdBase: Failed to start the server. Cause:
        java.lang.RuntimeException: Registration failure
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:135)
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:101)
        	at org.apache.hadoop.mount.MountdBase.start(MountdBase.java:79)
        	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.startServiceInternal(Nfs3.java:55)
        	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.startService(Nfs3.java:68)
        	at org.apache.hadoop.hdfs.nfs.nfs3.Nfs3.main(Nfs3.java:72)
        Caused by: java.net.SocketTimeoutException: Receive timed out
        	at java.net.PlainDatagramSocketImpl.receive0(Native Method)
        	at java.net.AbstractPlainDatagramSocketImpl.receive(AbstractPlainDatagramSocketImpl.java:145)
        	at java.net.DatagramSocket.receive(DatagramSocket.java:786)
        	at org.apache.hadoop.oncrpc.SimpleUdpClient.run(SimpleUdpClient.java:66)
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:130)
        	... 5 more
        14/07/02 02:02:03 INFO nfs3.Nfs3Base: SHUTDOWN_MSG:
        /************************************************************
        SHUTDOWN_MSG: Shutting down Nfs3 at abutala-vBox/127.0.1.1
        ************************************************************/
        

        2. Started both portmap and nfs3. Then closed portmap first and did Ctrl-C on nfs3:

        14/07/02 02:02:41 INFO nfs3.Nfs3Base: NFS server port set to: 2049
        14/07/02 02:02:41 INFO oncrpc.RpcProgram: Will accept client connections from unprivileged ports
        14/07/02 02:02:42 INFO oncrpc.SimpleUdpServer: Started listening to UDP requests at port 4242 for Rpc program: mountd at localhost:4242 with workerCount 1
        14/07/02 02:02:42 INFO oncrpc.SimpleTcpServer: Started listening to TCP requests at port 4242 for Rpc program: mountd at localhost:4242 with workerCount 1
        14/07/02 02:02:42 INFO oncrpc.SimpleTcpServer: Started listening to TCP requests at port 2049 for Rpc program: NFS3 at localhost:2049 with workerCount 0
        ^C14/07/02 02:02:52 ERROR nfs3.Nfs3Base: RECEIVED SIGNAL 2: SIGINT
        14/07/02 02:02:53 ERROR oncrpc.RpcProgram: Unregistration failure with localhost:4242, portmap entry: (PortmapMapping-100005:1:17:4242)
        14/07/02 02:02:53 WARN util.ShutdownHookManager: ShutdownHook 'Unregister' failed, java.lang.RuntimeException: Unregistration failure
        java.lang.RuntimeException: Unregistration failure
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:135)
        	at org.apache.hadoop.oncrpc.RpcProgram.unregister(RpcProgram.java:118)
        	at org.apache.hadoop.mount.MountdBase$Unregister.run(MountdBase.java:98)
        	at org.apache.hadoop.util.ShutdownHookManager$1.run(ShutdownHookManager.java:54)
        Caused by: java.net.SocketTimeoutException: Receive timed out
        	at java.net.PlainDatagramSocketImpl.receive0(Native Method)
        	at java.net.AbstractPlainDatagramSocketImpl.receive(AbstractPlainDatagramSocketImpl.java:145)
        	at java.net.DatagramSocket.receive(DatagramSocket.java:786)
        	at org.apache.hadoop.oncrpc.SimpleUdpClient.run(SimpleUdpClient.java:66)
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:130)
        	... 3 more
        14/07/02 02:02:53 ERROR oncrpc.RpcProgram: Unregistration failure with localhost:2049, portmap entry: (PortmapMapping-100003:3:6:2049)
        14/07/02 02:02:53 WARN util.ShutdownHookManager: ShutdownHook 'Unregister' failed, java.lang.RuntimeException: Unregistration failure
        java.lang.RuntimeException: Unregistration failure
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:135)
        	at org.apache.hadoop.oncrpc.RpcProgram.unregister(RpcProgram.java:118)
        	at org.apache.hadoop.nfs.nfs3.Nfs3Base$Unregister.run(Nfs3Base.java:78)
        	at org.apache.hadoop.util.ShutdownHookManager$1.run(ShutdownHookManager.java:54)
        Caused by: java.net.SocketTimeoutException: Receive timed out
        	at java.net.PlainDatagramSocketImpl.receive0(Native Method)
        	at java.net.AbstractPlainDatagramSocketImpl.receive(AbstractPlainDatagramSocketImpl.java:145)
        	at java.net.DatagramSocket.receive(DatagramSocket.java:786)
        	at org.apache.hadoop.oncrpc.SimpleUdpClient.run(SimpleUdpClient.java:66)
        	at org.apache.hadoop.oncrpc.RpcProgram.register(RpcProgram.java:130)
        	... 3 more
        14/07/02 02:02:53 INFO nfs3.Nfs3Base: SHUTDOWN_MSG:
        /************************************************************
        SHUTDOWN_MSG: Shutting down Nfs3 at abutala-vBox/127.0.1.1
        ************************************************************/
        
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12653555/HDFS-6378.002.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        -1 findbugs. The patch appears to introduce 2 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-nfs.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/7271//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/7271//artifact/trunk/patchprocess/newPatchFindbugsWarningshadoop-nfs.html
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/7271//console

        This message is automatically generated.

        Brandon Li added a comment -

        Thanks for the new patch!

        I moved the Shutdown hook registration to be after the registration itself, because it would be redundant if the registration itself exited with exception.

        Shutdown hook should be called first so we can see the shutdown message when the registration fails.

        Please also fix the findbug warnings as suggested by the Jenkins run.

        Abhiraj Butala added a comment -

        Thanks Brandon Li. Attaching a new patch which addresses your comments. Replaced the System.exit() calls with terminate(), to address the findbug warnings. Let me know if anything!

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12655504/HDFS-6378.003.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-common-project/hadoop-nfs.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/7334//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/7334//console

        This message is automatically generated.

        Brandon Li added a comment -

        +1

        Brandon Li added a comment -

        I've committed the patch. Thank you, Abhiraj Butala, for the contribution!

        Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #5879 (See https://builds.apache.org/job/Hadoop-trunk-Commit/5879/)
        HDFS-6378. NFS registration should timeout instead of hanging when portmap/rpcbind is not available. Contributed by Abhiraj Butala (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1610543)

        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/mount/MountdBase.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/nfs/nfs3/Nfs3Base.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/oncrpc/RpcProgram.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/oncrpc/SimpleUdpClient.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk #613 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/613/)
        HDFS-6378. NFS registration should timeout instead of hanging when portmap/rpcbind is not available. Contributed by Abhiraj Butala (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1610543)

        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/mount/MountdBase.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/nfs/nfs3/Nfs3Base.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/oncrpc/RpcProgram.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/oncrpc/SimpleUdpClient.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #1805 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1805/)
        HDFS-6378. NFS registration should timeout instead of hanging when portmap/rpcbind is not available. Contributed by Abhiraj Butala (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1610543)

        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/mount/MountdBase.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/nfs/nfs3/Nfs3Base.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/oncrpc/RpcProgram.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/oncrpc/SimpleUdpClient.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Mapreduce-trunk #1832 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1832/)
        HDFS-6378. NFS registration should timeout instead of hanging when portmap/rpcbind is not available. Contributed by Abhiraj Butala (brandonli: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1610543)

        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/mount/MountdBase.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/nfs/nfs3/Nfs3Base.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/oncrpc/RpcProgram.java
        • /hadoop/common/trunk/hadoop-common-project/hadoop-nfs/src/main/java/org/apache/hadoop/oncrpc/SimpleUdpClient.java
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt

          People

          • Assignee:
            Abhiraj Butala
            Reporter:
            Brandon Li
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development