Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-623

hdfs jar-test ant target fails with the latest commons jar's from the common trunk

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Not a Problem
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      [javac] <somelocation>/src/test/hdfs/org/apache/hadoop/hdfs/server/namenode/TestReplicationPolicy.java:67: incompatible types
      [javac] found : org.apache.hadoop.hdfs.server.namenode.ReplicationTargetChooser
      [javac] required: org.apache.hadoop.hdfs.server.namenode.BlockPlacementPolicy
      [javac] replicator = fsNamesystem.blockManager.replicator;
      [javac] ^
      [javac] Note: Some input files use or override a deprecated API.
      [javac] Note: Recompile with -Xlint:deprecation for details.
      [javac] 5 errors

        Issue Links

          Activity

          Konstantin Boudnik added a comment -

          Is there any information on the sources of the problem? Was it a fix of some other issue or what?

          Giridharan Kesavan added a comment -

          when we copy the latest common jar file from trunk build and use it with hdfs ant jar-test target fails.

          I doubt these two issues which would have caused this.
          HDFS-617.
          HADOOP-6246

          dhruba borthakur added a comment -

          This could be related to HDFS-385. Can you pl provide more details on how I can reproduce this compilation problem?

          Giridharan Kesavan added a comment -

          To reproduce:
          copy the latest trunk builds common jar's to hdfs-trunk lib folder and execute ant jar-test

          dhruba borthakur added a comment -

          I followed ur steps, and it works for me:

          svn status lib
          M lib/hadoop-core-test-0.21.0-dev.jar
          M lib/hadoop-core-0.21.0-dev.jar

          ant test-jar
          ...
          ...
          jar-hdfs-test:
          [jar] Building jar: /mnt/vol/devrs004.snc1/dhruba/calm/build/hadoop-hdfs-test-0.21.0-dev.jar

          compile-hdfs-with-mr-test:
          [mkdir] Created dir: /mnt/vol/devrs004.snc1/dhruba/calm/build/test/hdfs-with-mr/classes
          [javac] Compiling 16 source files to /mnt/vol/devrs004.snc1/dhruba/calm/build/test/hdfs-with-mr/classes
          [javac] Note: Some input files use or override a deprecated API.
          [javac] Note: Recompile with -Xlint:deprecation for details.

          jar-hdfswithmr-test:
          [copy] Copying 48 files to /mnt/vol/devrs004.snc1/dhruba/calm/build/test/classes
          [jar] Building jar: /mnt/vol/devrs004.snc1/dhruba/calm/build/hadoop-hdfs-hdfswithmr-test-0.21.0-dev.jar

          jar-test:

          BUILD SUCCESSFUL
          Total time: 8 seconds

          Tsz Wo Nicholas Sze added a comment -

          I believe this is not a problem anymore.


            People

            • Assignee:
              Unassigned
              Reporter:
              Giridharan Kesavan
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development