Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-6033

PBImageXmlWriter incorrectly handles processing cache directives

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4.0
    • Fix Version/s: 2.4.0
    • Component/s: caching
    • Labels:
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      When attempting to process cache directives in PBImageXmlWriter#dumpCacheManagerSection, we incorrectly loop the number of cache pools, not directives.

      1. HDFS-6033.patch
        0.9 kB
        Aaron T. Myers

        Activity

        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Mapreduce-trunk #1713 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1713/)
        HDFS-6033. PBImageXmlWriter incorrectly handles processing cache directives. Contributed by Aaron T. Myers. (atm: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1573050)

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/PBImageXmlWriter.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #1688 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1688/)
        HDFS-6033. PBImageXmlWriter incorrectly handles processing cache directives. Contributed by Aaron T. Myers. (atm: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1573050)

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/PBImageXmlWriter.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk #496 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/496/)
        HDFS-6033. PBImageXmlWriter incorrectly handles processing cache directives. Contributed by Aaron T. Myers. (atm: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1573050)

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/PBImageXmlWriter.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-trunk-Commit #5247 (See https://builds.apache.org/job/Hadoop-trunk-Commit/5247/)
        HDFS-6033. PBImageXmlWriter incorrectly handles processing cache directives. Contributed by Aaron T. Myers. (atm: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1573050)

        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/PBImageXmlWriter.java
        atm Aaron T. Myers added a comment -

        Thanks a lot for the quick reviews. I've just committed this to trunk, branch-2, and branch-2.4.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12631648/HDFS-6033.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/6264//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/6264//console

        This message is automatically generated.

        djp Junping Du added a comment -

        +1. Thanks ATM for working on this. You are right that the bug is so obvious and fix is so tiny so we can skip test this time.

        ajisakaa Akira Ajisaka added a comment -

        +1

        atm Aaron T. Myers added a comment -

        Trivial patch attached. I tested this manually and confirmed that it works as expected. No test included since the bug is so obvious and the fix is so trivial, but I could write one if anyone feels strongly about it.


          People

          • Assignee:
            atm Aaron T. Myers
            Reporter:
            atm Aaron T. Myers
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development