Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-6027

hadoop-fuse-dfs is not strictly consistent for "cp" actions file contents.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Running the tests patched in https://issues.apache.org/jira/browse/BIGTOP-1221 demonstrate that the copy action is not consistent (if you remove the sleep directive, which is a workaround to allow the tests to pass).

      Although CP returns 1, and the namespaces appears to have file copied in it, the actual copied file has no contents. To reproduce easily, you can follow the bash recipe outlined in the JIRA above, or else, run the BIGTOP HDFS-FUSE smoke test, (after we commit the BIGTOP-1221 patch, which has now been submitted).

        Issue Links

          Activity

          Colin Patrick McCabe added a comment -

          This is a duplicate of HDFS-2551. The issue is that HDFS doesn't allow other readers to see what the writer wrote until DFSOutputStream#close has finished. But fuse's close doesn't wait until that happens. Hence the inconsistency you saw.

          jay vyas added a comment -

          okay, thanks for the review Colin. That clears it up.


            People

            • Assignee:
              Unassigned
              Reporter:
              jay vyas
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development