Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-5860

Refactor INodeDirectory getDirectoryXFeature methods to use common getFeature helper method.

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: HDFS ACLs (HDFS-4685)
    • Fix Version/s: HDFS ACLs (HDFS-4685)
    • Component/s: namenode
    • Labels:
      None

      Description

      The HDFS-4685 feature branch has introduced a helper method for getting an inode feature of a particular class: INodeWithAdditionalFields#getFeature. Currently, this is only called by code related to ACLs, but we can also use the same method to reduce code duplication in the various INodeDirectory methods that get different kinds of features.

        Attachments

        1. HDFS-5860.000.patch
          1 kB
          Jing Zhao

          Issue Links

            Activity

              People

              • Assignee:
                jingzhao Jing Zhao
                Reporter:
                cnauroth Chris Nauroth
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: