> I am not sure how useful the addition of Util.getBlockLocations() is. ...
The idea is to remove some public methods which are used for unit tests.
> In order to establish the right precedence it would be better to change parameter FSNamesystem to NameNode in Util.getBlockLocations(). That way we will be able to make getNamesystem() method package private down the road.
Changed the parameter from FSNamesystem to NameNode. Also changed NameNode.getNamesystem() method package private.
> May I suggest to rename the class to something like AccessWrappers because it is likely that we are going to see more like these in the feature.
Renamed Util to AccessWrappers.
Thanks Suresh, Konstantin and Cos for all the review comments.