Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: HDFS-4949
    • Fix Version/s: HDFS-4949
    • Component/s: datanode, namenode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    • Target Version/s:

      Description

      Before merging the HDFS-4949 feature branch to trunk, we need to resolve any regressions introduced in Windows compatibility.

      1. HDFS-5404.1.patch
        9 kB
        Chris Nauroth

        Issue Links

          Activity

          Andrew Wang made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Hadoop Flags Reviewed [ 10343 ]
          Fix Version/s HDFS-4949 [ 12324878 ]
          Resolution Fixed [ 1 ]
          Andrew Wang added a comment -

          Thanks Chris, committed to branch.

          Andrew Wang added a comment -

          Thanks Chris, +1. I'll commit this shortly.

          Chris Nauroth made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Chris Nauroth made changes -
          Attachment HDFS-5404.1.patch [ 12609888 ]
          Chris Nauroth added a comment -

          This patch is sufficient to resolve regressions on Windows before we merge HDFS-4949 to trunk. Summary:

          1. Stub native implementations of mlock_native and munlock_native, just enough for a successful compile and link of hadoop.dll.
          2. TestFsDatasetCache must skip tests if running on Windows or native code is not loaded.
          3. Fixed failure to shutdown a MiniDFSCluster in TestPathBasedCacheRequests, which would cause file handle leaks and failures on Windows due to file locking.

          Andrew Wang and Colin Patrick McCabe, would you please review? Thanks!

          Chris Nauroth made changes -
          Link This issue is related to HDFS-5202 [ HDFS-5202 ]
          Chris Nauroth added a comment -

          There is at least one known problem: the new calls to mlock and munlock cause the native build on Windows to fail during link due to unresolved external symbols. We'll need to stub that call to throw on Windows.

          Chris Nauroth made changes -
          Field Original Value New Value
          Component/s datanode [ 12312927 ]
          Component/s namenode [ 12312926 ]
          Chris Nauroth created issue -

            People

            • Assignee:
              Chris Nauroth
              Reporter:
              Chris Nauroth
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development