Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-5336

DataNode should not output 'StartupProgress' metrics

VotersStop watchingWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 2.1.0-beta
    • 2.3.0
    • namenode
    • trunk

    • Reviewed

    Description

      I found the following metrics output from DataNode.

      1381355455731 default.StartupProgress: Hostname=trunk, ElapsedTime=0, PercentComplete=0.0, LoadingFsImageCount=0, LoadingFsImageElapsedTime=0, LoadingFsImageTotal=0, LoadingFsImagePercentComplete=0.0, LoadingEditsCount=0, LoadingEditsElapsedTime=0, LoadingEditsTotal=0, LoadingEditsPercentComplete=0.0, SavingCheckpointCount=0, SavingCheckpointElapsedTime=0, SavingCheckpointTotal=0, SavingCheckpointPercentComplete=0.0, SafeModeCount=0, SafeModeElapsedTime=0, SafeModeTotal=0, SafeModePercentComplete=0.0
      

      DataNode should not output 'StartupProgress' metrics because the metrics shows the progress of NameNode startup.

      Attachments

        1. HDFS-5336.2.patch
          1 kB
          Akira Ajisaka
        2. HDFS-5336.patch
          2 kB
          Akira Ajisaka

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            aajisaka Akira Ajisaka
            aajisaka Akira Ajisaka
            Votes:
            0 Vote for this issue
            Watchers:
            3 Stop watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment