Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: datanode, namenode
    • Labels:
      None

      Description

      We should consider renaming StorageID to something else since we have changed the meaning of the field. Previously it was used to identify the single logical storage attached to a datanode and hence it was a de-facto identifier for a Datanode. Now the StorageID identifies a single storage. To avoid confusion of meaning especially when merging with other feature branches it may be best to rename it to something else.

      We can do so when merging phase 1 of the Heterogeneous Storage work into trunk.

      A partial list of places to update:

      1. FsVolumeSpi#storageID
      2. DatanodeStorageInfo#storageID
      3. DatanodeStorage#storageID
      4. StorageReceivedDeletedBlocks#storageID
      5. StorageReport#storageID
      6. LocatedBlock#storageIDs
      7. processFirstBlockReport
      8. DatanodeStorage#getStorageInfo
      9. TestDatanodeDescriptor#testBlocksCounter
      10. TestBlockManager.java
      11. FsDatasetSpi#getBlockReports

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                arp Arpit Agarwal
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: