Rename DatanodeBlockInfo to be ReplicaInfo to improve readablility.
Redesign DataNode volumeMap to include all types of Replicas
> Not sure how to do it yet. Will try later.
I should mention that Arun and I have spent sometime this afternoon but we are still not sure how to resurrect the change history. Please help if you know how to do so.
> ... So Nicholas if know how to do this, please reopen the issue and correct it. I give up.
Not sure how to do it yet. Will try later.
Integrated in Hadoop-Hdfs-trunk #34 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk/34/)
. Rename DatanodeBlockInfo to be ReplicaInfo. Contributed by Jakob Homan & Hairong Kuang.
. Reverting incorrect commit.
. Correction: Contributed by Jakob Homan and Hairong Kuang.
. Rename DatanodeBlockInfo to be ReplicaInfo. Contributed by Hairong Kuang.
Sorry for multiple commits. I was trying preserve the history of DatanodeBlockInfo.java in ReplicaInfo.java. Did svn move, but history seems to disappear anyway. So Nicholas if know how to do this, please reopen the issue and correct it. I give up.
This patch does a rename.
I think we need a "svn move" for committing this. Otherwise, we will lose the change history.
I just committed this. Thank you Jakob and Hairong.
Unit tests all pass.
[exec] +1 overall.
[exec] +1 @author. The patch does not contain any @author tags.
[exec] +1 tests included. The patch appears to include 3 new or modified tests.
[exec] +1 javadoc. The javadoc tool did not generate any warning messages.
[exec] +1 javac. The applied patch does not increase the total number of javac compiler warnings.
[exec] +1 findbugs. The patch does not introduce any new Findbugs warnings.
[exec] +1 release audit. The applied patch does not increase the total number of release audit warnings.
Oops! My attachment duplicated Jacob's. Removing them for easy management.
My previous patch seems to have a problem. Thanks Jacob for generating a new patch for me.
I had trouble applying the patch as uploaded. Looks like there may be a Subversion issue. Since it's a simple refactor, I regenerated the patch. Is attached.
Here is the patch that does the rename.